summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2006-12-04 21:35:50 +0000
committerLuca Longinotti <chtekk@gentoo.org>2006-12-04 21:35:50 +0000
commitb1d26619ed321a08955ede3e8cc7f3a1feab78fc (patch)
treef0c18c5cda6ad33204cd701d7efe3b3b732c60c5 /dev-php
parentStable on sparc wrt #157100 (diff)
downloadgentoo-2-b1d26619ed321a08955ede3e8cc7f3a1feab78fc.tar.gz
gentoo-2-b1d26619ed321a08955ede3e8cc7f3a1feab78fc.tar.bz2
gentoo-2-b1d26619ed321a08955ede3e8cc7f3a1feab78fc.zip
Add sandbox depend.
(Portage version: 2.1.2_rc2-r2)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-PEAR/ChangeLog6
-rw-r--r--dev-php/PEAR-PEAR/PEAR-PEAR-1.4.11.ebuild13
2 files changed, 14 insertions, 5 deletions
diff --git a/dev-php/PEAR-PEAR/ChangeLog b/dev-php/PEAR-PEAR/ChangeLog
index e8ce92e15fc4..27d7f2812972 100644
--- a/dev-php/PEAR-PEAR/ChangeLog
+++ b/dev-php/PEAR-PEAR/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/PEAR-PEAR
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/ChangeLog,v 1.84 2006/11/24 15:50:27 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/ChangeLog,v 1.85 2006/12/04 21:35:50 chtekk Exp $
+
+ 04 Dec 2006; Luca Longinotti <chtekk@gentoo.org> PEAR-PEAR-1.4.11.ebuild:
+ Add sandbox depend to avoid lots of bugreports due to users still having old
+ sandbox installs around that don't work well with PEAR-PEAR.
24 Nov 2006; Luca Longinotti <chtekk@gentoo.org>
-PEAR-PEAR-1.4.9-r1.ebuild, PEAR-PEAR-1.4.11.ebuild:
diff --git a/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.11.ebuild b/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.11.ebuild
index c628829938bc..8da646b1dfdf 100644
--- a/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.11.ebuild
+++ b/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.11.ebuild,v 1.13 2006/11/24 15:50:27 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.11.ebuild,v 1.14 2006/12/04 21:35:50 chtekk Exp $
inherit depend.php
@@ -11,6 +11,8 @@ XML_RPC="1.5.0"
[[ -z "${PEAR_CACHEDIR}" ]] && PEAR_CACHEDIR="/var/cache/pear"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
+
DESCRIPTION="PEAR Base System (PEAR, Archive_Tar, Console_Getopt, XML_RPC)."
HOMEPAGE="http://pear.php.net/"
SRC_URI="http://pear.php.net/get/Archive_Tar-${ARCHIVE_TAR}.tgz
@@ -20,12 +22,13 @@ SRC_URI="http://pear.php.net/get/Archive_Tar-${ARCHIVE_TAR}.tgz
LICENSE="PHP"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
IUSE=""
# we deliberately force people to remove their old PEAR installations,
# and any package which may have put an old-style PEAR installation onto
-# the box
+# their box
+# we also depend on a recent sandbox version to mitigate problems users
+# have been experiencing
DEPEND="dev-lang/php
!dev-php/php
@@ -34,7 +37,9 @@ DEPEND="dev-lang/php
!<dev-php/PEAR-PEAR-1.3.6-r2
!dev-php/PEAR-Archive_Tar
!dev-php/PEAR-Console_Getopt
- !dev-php/PEAR-XML_RPC"
+ !dev-php/PEAR-XML_RPC
+ >=sys-apps/sandbox-1.2.17"
+RDEPEND="${DEPEND}"
pkg_setup() {
# we call this here, to ensure that the eclass picks the right