summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2013-03-30 11:38:56 +0000
committerMatti Bickel <mabi@gentoo.org>2013-03-30 11:38:56 +0000
commit6df5d3ccc0f2b8fbb843d16d318a12bae9beb4da (patch)
tree65e520304a06476160fb10a4a628164c636c2ed9 /dev-php
parentLinux patch 3.8.5. (diff)
downloadgentoo-2-6df5d3ccc0f2b8fbb843d16d318a12bae9beb4da.tar.gz
gentoo-2-6df5d3ccc0f2b8fbb843d16d318a12bae9beb4da.tar.bz2
gentoo-2-6df5d3ccc0f2b8fbb843d16d318a12bae9beb4da.zip
version bump (smarty3 doesnt use smarty-docs anymore), cleanup
(Portage version: 2.2.0_alpha168/cvs/Linux x86_64, signed Manifest commit with key 0x4849EC6C)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/smarty/ChangeLog9
-rw-r--r--dev-php/smarty/smarty-2.6.27.ebuild40
-rw-r--r--dev-php/smarty/smarty-3.1.12.ebuild (renamed from dev-php/smarty/smarty-3.1.7.ebuild)10
3 files changed, 52 insertions, 7 deletions
diff --git a/dev-php/smarty/ChangeLog b/dev-php/smarty/ChangeLog
index 3da5b854a274..c38b127b2f54 100644
--- a/dev-php/smarty/ChangeLog
+++ b/dev-php/smarty/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-php/smarty
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.112 2013/01/21 18:09:47 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.113 2013/03/30 11:38:56 mabi Exp $
+
+*smarty-3.1.12 (30 Mar 2013)
+*smarty-2.6.27 (30 Mar 2013)
+
+ 30 Mar 2013; Matti Bickel <mabi@gentoo.org> +smarty-2.6.27.ebuild,
+ +smarty-3.1.12.ebuild, -smarty-3.1.7.ebuild:
+ version bump (smarty3 doesnt use smarty-docs anymore), cleanup
21 Jan 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup as talked with him
diff --git a/dev-php/smarty/smarty-2.6.27.ebuild b/dev-php/smarty/smarty-2.6.27.ebuild
new file mode 100644
index 000000000000..0c9fd178a886
--- /dev/null
+++ b/dev-php/smarty/smarty-2.6.27.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.27.ebuild,v 1.1 2013/03/30 11:38:56 mabi Exp $
+
+EAPI=4
+
+inherit eutils
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_P="Smarty-${PV}"
+
+DESCRIPTION="A template engine for PHP."
+HOMEPAGE="http://www.smarty.net/"
+SRC_URI="http://www.smarty.net/files/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+PDEPEND="doc? ( =dev-php/smarty-docs-2* )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="BUGS ChangeLog FAQ NEWS QUICK_START README RELEASE_NOTES TODO"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r libs/*
+ dodoc ${DOCS}
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "To use it in your scripts, either"
+ elog "1. define('SMARTY_DIR', \"/usr/share/php/${PN}/\") in your scripts, or"
+ elog "2. add '/usr/share/php/${PN}/' to the 'include_path' variable in your"
+ elog "php.ini file under /etc/php/*-php5.x"
+}
diff --git a/dev-php/smarty/smarty-3.1.7.ebuild b/dev-php/smarty/smarty-3.1.12.ebuild
index eaf267e899e0..9d13bfda752d 100644
--- a/dev-php/smarty/smarty-3.1.7.ebuild
+++ b/dev-php/smarty/smarty-3.1.12.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-3.1.7.ebuild,v 1.1 2012/01/28 14:24:23 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-3.1.12.ebuild,v 1.1 2013/03/30 11:38:56 mabi Exp $
EAPI=4
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
MY_P="Smarty-${PV}"
+DOC_PV="3.1.8"
DESCRIPTION="A template engine for PHP."
HOMEPAGE="http://www.smarty.net/"
SRC_URI="http://www.smarty.net/files/${MY_P}.tar.gz
- doc? ( http://www.smarty.net/files/docs/manual-en-${PV}.zip )"
+ doc? ( http://www.smarty.net/files/docs/manual-en-${DOC_PV}.zip )"
LICENSE="LGPL-2.1"
SLOT="0"
IUSE="doc"
@@ -36,7 +37,4 @@ pkg_postinst() {
elog "2. add '/usr/share/php/${PN}/' to the 'include_path' variable in your"
elog "php.ini file under /etc/php/SAPI (where SAPI is e.g apache2-php5.3,"
elog "cgi-php5.3, etc)."
- elog
- elog "If you're upgrading from a previous version make sure to clear out your"
- elog "templates_c and cache directories as some include paths have changed!"
}