summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-12-24 14:49:26 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-12-24 14:49:26 +0000
commit5661314b69605217d7b3f564b9026383ec916e0a (patch)
treecf5d6f0cdd48cbac93698e05b33034b99ff7e7af /dev-php5
parentVersion bump from the php-overlay (diff)
downloadgentoo-2-5661314b69605217d7b3f564b9026383ec916e0a.tar.gz
gentoo-2-5661314b69605217d7b3f564b9026383ec916e0a.tar.bz2
gentoo-2-5661314b69605217d7b3f564b9026383ec916e0a.zip
Version bump from the php-overlay
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/phpunit/ChangeLog10
-rw-r--r--dev-php5/phpunit/files/digest-phpunit-3.2.53
-rw-r--r--dev-php5/phpunit/phpunit-3.2.5.ebuild35
3 files changed, 47 insertions, 1 deletions
diff --git a/dev-php5/phpunit/ChangeLog b/dev-php5/phpunit/ChangeLog
index da8b41c989a5..a28629a7a5cb 100644
--- a/dev-php5/phpunit/ChangeLog
+++ b/dev-php5/phpunit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/phpunit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.9 2007/11/24 17:12:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.10 2007/12/24 14:49:25 armin76 Exp $
+
+*phpunit-3.2.5 (24 Dec 2007)
+
+ 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> +phpunit-3.2.5.ebuild:
+ Version bump from the php-overlay
+
+ 21 Dec 2007; Jakub Moc <jakub@gentoo.org> +phpunit-3.2.5.ebuild:
+ Version bump
*phpunit-3.2.0 (24 Nov 2007)
diff --git a/dev-php5/phpunit/files/digest-phpunit-3.2.5 b/dev-php5/phpunit/files/digest-phpunit-3.2.5
new file mode 100644
index 000000000000..16a0b49b02bc
--- /dev/null
+++ b/dev-php5/phpunit/files/digest-phpunit-3.2.5
@@ -0,0 +1,3 @@
+MD5 8ccc8012df0121be23015ae8b1defa3d PHPUnit-3.2.5.tgz 198096
+RMD160 0beda526d104825fd4a076ad45d881133a3099dd PHPUnit-3.2.5.tgz 198096
+SHA256 c7db69dc49da9643626752e642902a12350f861b27aa7aff7fdc06797cf8db49 PHPUnit-3.2.5.tgz 198096
diff --git a/dev-php5/phpunit/phpunit-3.2.5.ebuild b/dev-php5/phpunit/phpunit-3.2.5.ebuild
new file mode 100644
index 000000000000..ff411b69bd99
--- /dev/null
+++ b/dev-php5/phpunit/phpunit-3.2.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/phpunit-3.2.5.ebuild,v 1.1 2007/12/24 14:49:25 armin76 Exp $
+
+inherit php-pear-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Unit Testing framework for PHP 5."
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND="!dev-php4/phpunit"
+RDEPEND="${DEPEND}
+ !minimal? ( >=dev-php5/xdebug-2.0.0_rc2
+ >=dev-php/PEAR-Image_GraphViz-1.2.1
+ >=dev-php/PEAR-Log-1.8.7-r1
+ >=dev-php/PEAR-Testing_Selenium-0.2.0 )"
+
+S="${WORKDIR}/PHPUnit-${PV}"
+
+need_php_by_category
+
+pkg_setup() {
+ require_php_with_use pcre reflection spl xml tokenizer
+}
+
+pkg_postinst() {
+ has_php
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge ${PHP_PKG} with USE=\"json pdo sqlite mysql\"."
+}