summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2008-02-06 15:04:49 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2008-02-06 15:04:49 +0000
commit8d1ed5e705042e8ab4a66b1f8e27bcf5e73e5358 (patch)
tree5a944620d752ae97ba077324f313ebb763daef93 /dev-php5/suhosin
parentAdded hdf5 local flag for sci-physics/meep (diff)
downloadgentoo-2-8d1ed5e705042e8ab4a66b1f8e27bcf5e73e5358.tar.gz
gentoo-2-8d1ed5e705042e8ab4a66b1f8e27bcf5e73e5358.tar.bz2
gentoo-2-8d1ed5e705042e8ab4a66b1f8e27bcf5e73e5358.zip
bump to 0.9.23, bug 209070
(Portage version: 2.1.4.1)
Diffstat (limited to 'dev-php5/suhosin')
-rw-r--r--dev-php5/suhosin/ChangeLog8
-rw-r--r--dev-php5/suhosin/suhosin-0.9.23.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-php5/suhosin/ChangeLog b/dev-php5/suhosin/ChangeLog
index 9fb41b0e8309..e019a8cdc973 100644
--- a/dev-php5/suhosin/ChangeLog
+++ b/dev-php5/suhosin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/suhosin
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/suhosin/ChangeLog,v 1.25 2008/01/16 00:24:33 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/suhosin/ChangeLog,v 1.26 2008/02/06 15:04:49 hoffie Exp $
+
+*suhosin-0.9.23 (06 Feb 2008)
+
+ 06 Feb 2008; Christian Hoffmann <hoffie@gentoo.org>
+ +suhosin-0.9.23.ebuild:
+ bump to 0.9.23, bug 209070
16 Jan 2008; Hanno Boeck <hanno@gentoo.org> suhosin-0.9.22.ebuild:
Stable on amd64.
diff --git a/dev-php5/suhosin/suhosin-0.9.23.ebuild b/dev-php5/suhosin/suhosin-0.9.23.ebuild
new file mode 100644
index 000000000000..b4ff52d3c7c5
--- /dev/null
+++ b/dev-php5/suhosin/suhosin-0.9.23.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/suhosin/suhosin-0.9.23.ebuild,v 1.1 2008/02/06 15:04:49 hoffie Exp $
+
+PHP_EXT_NAME="suhosin"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-source-r1
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="Suhosin is an advanced protection system for PHP installations."
+HOMEPAGE="http://www.suhosin.org/"
+SRC_URI="http://download.suhosin.org/${P}.tgz"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+ require_php_with_use unicode
+}
+
+src_install() {
+ php-ext-source-r1_src_install
+ dodoc-php CREDITS
+
+ for inifile in ${PHPINIFILELIST} ; do
+ insinto "${inifile/${PHP_EXT_NAME}.ini/}"
+ insopts -m644
+ doins "suhosin.ini"
+ done
+}