summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2008-10-18 20:52:40 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2008-10-18 20:52:40 +0000
commit28c817daf554785e9294f3fa46029557fc747a91 (patch)
treec5b3059d2bd023971c755f4c13a38316485f3de1 /dev-php5/pecl-memcache
parentamd64/x86 stable, bug #235824 (diff)
downloadgentoo-2-28c817daf554785e9294f3fa46029557fc747a91.tar.gz
gentoo-2-28c817daf554785e9294f3fa46029557fc747a91.tar.bz2
gentoo-2-28c817daf554785e9294f3fa46029557fc747a91.zip
version bump, thanks to Lars Strojny <lars@strojny.net> for testing this version; removing old
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'dev-php5/pecl-memcache')
-rw-r--r--dev-php5/pecl-memcache/ChangeLog10
-rw-r--r--dev-php5/pecl-memcache/pecl-memcache-2.2.1.ebuild26
-rw-r--r--dev-php5/pecl-memcache/pecl-memcache-3.0.2.ebuild (renamed from dev-php5/pecl-memcache/pecl-memcache-3.0.0.ebuild)13
3 files changed, 18 insertions, 31 deletions
diff --git a/dev-php5/pecl-memcache/ChangeLog b/dev-php5/pecl-memcache/ChangeLog
index d58cb690fcb2..729b60c6c604 100644
--- a/dev-php5/pecl-memcache/ChangeLog
+++ b/dev-php5/pecl-memcache/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/pecl-memcache
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/ChangeLog,v 1.23 2008/05/09 12:56:34 hoffie Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/ChangeLog,v 1.24 2008/10/18 20:52:39 hoffie Exp $
+
+*pecl-memcache-3.0.2 (18 Oct 2008)
+
+ 18 Oct 2008; Christian Hoffmann <hoffie@gentoo.org>
+ -pecl-memcache-2.2.1.ebuild, -pecl-memcache-3.0.0.ebuild,
+ +pecl-memcache-3.0.2.ebuild:
+ version bump, thanks to Lars Strojny <lars@strojny.net> for testing this
+ version
09 May 2008; Christian Hoffmann <hoffie@gentoo.org>
pecl-memcache-2.0.4.ebuild:
diff --git a/dev-php5/pecl-memcache/pecl-memcache-2.2.1.ebuild b/dev-php5/pecl-memcache/pecl-memcache-2.2.1.ebuild
deleted file mode 100644
index 487ca3f62ae3..000000000000
--- a/dev-php5/pecl-memcache/pecl-memcache-2.2.1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/pecl-memcache-2.2.1.ebuild,v 1.2 2007/12/06 01:19:01 jokey Exp $
-
-PHP_EXT_NAME="memcache"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-
-inherit php-ext-pecl-r1
-
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-
-DESCRIPTION="PHP extension for using memcached."
-LICENSE="PHP-3"
-SLOT="0"
-IUSE=""
-
-DEPEND="sys-libs/zlib"
-RDEPEND="${DEPEND}"
-
-need_php_by_category
-
-src_compile() {
- my_conf="--enable-memcache --with-zlib-dir=/usr"
- php-ext-pecl-r1_src_compile
-}
diff --git a/dev-php5/pecl-memcache/pecl-memcache-3.0.0.ebuild b/dev-php5/pecl-memcache/pecl-memcache-3.0.2.ebuild
index 88f4e11fd367..495771e3b2ca 100644
--- a/dev-php5/pecl-memcache/pecl-memcache-3.0.0.ebuild
+++ b/dev-php5/pecl-memcache/pecl-memcache-3.0.2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/pecl-memcache-3.0.0.ebuild,v 1.2 2007/12/06 01:19:01 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/pecl-memcache-3.0.2.ebuild,v 1.1 2008/10/18 20:52:40 hoffie Exp $
+EAPI="1"
PHP_EXT_NAME="memcache"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
@@ -14,15 +15,19 @@ KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
DESCRIPTION="PHP extension for using memcached."
LICENSE="PHP-3"
SLOT="0"
-IUSE=""
+IUSE="+session"
DEPEND="sys-libs/zlib"
RDEPEND="${DEPEND}"
need_php_by_category
+pkg_setup() {
+ use session && require_php_with_use session
+}
+
src_compile() {
- my_conf="--enable-memcache --with-zlib-dir=/usr"
+ my_conf="--enable-memcache --with-zlib-dir=/usr $(use_enable session memcache-session)"
php-ext-pecl-r1_src_compile
}