summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2011-01-26 23:10:29 +0000
committerMatti Bickel <mabi@gentoo.org>2011-01-26 23:10:29 +0000
commitd9527a2362037b8bdbee524a3dfd415d717ed498 (patch)
tree8233820051db980e1c579f07b1753b6509acc017 /dev-php5/pecl-gnupg
parentadd ~ppc wrt #348984 (diff)
downloadgentoo-2-d9527a2362037b8bdbee524a3dfd415d717ed498.tar.gz
gentoo-2-d9527a2362037b8bdbee524a3dfd415d717ed498.tar.bz2
gentoo-2-d9527a2362037b8bdbee524a3dfd415d717ed498.zip
fix compile failure (largefile issue, thanks to Diego for this, bug #350018)
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5/pecl-gnupg')
-rw-r--r--dev-php5/pecl-gnupg/ChangeLog8
-rw-r--r--dev-php5/pecl-gnupg/files/1.3.2/01-large_file_system.patch9
-rw-r--r--dev-php5/pecl-gnupg/pecl-gnupg-1.3.2-r1.ebuild13
3 files changed, 26 insertions, 4 deletions
diff --git a/dev-php5/pecl-gnupg/ChangeLog b/dev-php5/pecl-gnupg/ChangeLog
index efdfd3b9b446..83efa3428a9a 100644
--- a/dev-php5/pecl-gnupg/ChangeLog
+++ b/dev-php5/pecl-gnupg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php5/pecl-gnupg
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-gnupg/ChangeLog,v 1.4 2010/11/04 13:13:32 mabi Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-gnupg/ChangeLog,v 1.5 2011/01/26 23:10:29 mabi Exp $
+
+ 26 Jan 2011; Matti Bickel <mabi@gentoo.org>
+ +files/1.3.2/01-large_file_system.patch, pecl-gnupg-1.3.2-r1.ebuild:
+ fix compile failure (largefile issue, thanks to Diego for this, bug #350018)
*pecl-gnupg-1.3.2-r1 (04 Nov 2010)
*pecl-gnupg-1.3.2 (04 Nov 2010)
diff --git a/dev-php5/pecl-gnupg/files/1.3.2/01-large_file_system.patch b/dev-php5/pecl-gnupg/files/1.3.2/01-large_file_system.patch
new file mode 100644
index 000000000000..4e64e3ccef1a
--- /dev/null
+++ b/dev-php5/pecl-gnupg/files/1.3.2/01-large_file_system.patch
@@ -0,0 +1,9 @@
+--- config.m4 2007-05-04 13:23:41.000000000 +0000
++++ config.m4.new 2010-03-28 01:13:10.000000000 +0000
+@@ -41,4 +41,6 @@
+ PHP_SUBST(GNUPG_SHARED_LIBADD)
+
+ PHP_NEW_EXTENSION(gnupg, [gnupg.c gnupg_keylistiterator.c], $ext_shared)
++
++ AC_SYS_LARGEFILE
+ fi
diff --git a/dev-php5/pecl-gnupg/pecl-gnupg-1.3.2-r1.ebuild b/dev-php5/pecl-gnupg/pecl-gnupg-1.3.2-r1.ebuild
index 70845e7c3400..cf1c11f2becf 100644
--- a/dev-php5/pecl-gnupg/pecl-gnupg-1.3.2-r1.ebuild
+++ b/dev-php5/pecl-gnupg/pecl-gnupg-1.3.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-gnupg/pecl-gnupg-1.3.2-r1.ebuild,v 1.1 2010/11/04 13:13:32 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-gnupg/pecl-gnupg-1.3.2-r1.ebuild,v 1.2 2011/01/26 23:10:29 mabi Exp $
PHP_EXT_NAME="gnupg"
PHP_EXT_INI="yes"
@@ -18,3 +18,12 @@ IUSE=""
DEPEND="app-crypt/gpgme"
RDEPEND="${DEPEND}"
+
+src_prepare() {
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ epatch "${FILESDIR}/${PV}"/01-large_file_system.patch
+ done
+
+ php-ext-source-r2_src_prepare
+}