summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-12-30 22:28:27 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-12-30 22:28:27 +0000
commit8f351c43dde9491477de0e319c78c89d96e82a31 (patch)
tree405b6e944d15393e585c7c12658ec6d0de8625cd /dev-php5/onphp/onphp-0.2.7.ebuild
parentold (diff)
downloadgentoo-2-8f351c43dde9491477de0e319c78c89d96e82a31.tar.gz
gentoo-2-8f351c43dde9491477de0e319c78c89d96e82a31.tar.bz2
gentoo-2-8f351c43dde9491477de0e319c78c89d96e82a31.zip
* bump
(Portage version: 2.1_pre2)
Diffstat (limited to 'dev-php5/onphp/onphp-0.2.7.ebuild')
-rw-r--r--dev-php5/onphp/onphp-0.2.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-php5/onphp/onphp-0.2.7.ebuild b/dev-php5/onphp/onphp-0.2.7.ebuild
new file mode 100644
index 000000000000..2b5ed03a6f36
--- /dev/null
+++ b/dev-php5/onphp/onphp-0.2.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-0.2.7.ebuild,v 1.1 2005/12/30 22:28:27 voxus Exp $
+
+inherit php-lib-r1
+
+KEYWORDS="~x86 ~amd64"
+DESCRIPTION="onPHP is the GPL'ed multi-purpose object-oriented PHP framework."
+HOMEPAGE="http://onphp.org/"
+SRC_URI="http://onphp.org/download/${P}.tar.bz2
+ doc? ( http://onphp.org/download/${PN}-api-${PV}.tar.bz2 )"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+need_php_by_category
+
+src_install() {
+ has_php
+
+ if use doc ; then
+ for doc in `find doc -maxdepth 1 -type f -print`; do
+ dodoc ${doc}
+ done
+
+ dohtml -r "${WORKDIR}/${PN}-api-${PV}/"*
+ fi
+
+ cp global.inc.php.tpl global.inc.php
+ php-lib-r1_src_install ./ global.inc.php
+ php-lib-r1_src_install ./ `find core -type f -print`
+ php-lib-r1_src_install ./ `find main -type f -print`
+}