summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-22 00:20:11 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-22 00:20:11 +0000
commit27605ffe3d786e9b43bfdbb3dc2d739836f5b13a (patch)
tree41307960039ea4471c99d1a1b16fc5f5d598f130 /dev-php/awl
parentPyfa only supports wxpython:2.8. Fix dependency, add patch to select correct ... (diff)
downloadgentoo-2-27605ffe3d786e9b43bfdbb3dc2d739836f5b13a.tar.gz
gentoo-2-27605ffe3d786e9b43bfdbb3dc2d739836f5b13a.tar.bz2
gentoo-2-27605ffe3d786e9b43bfdbb3dc2d739836f5b13a.zip
Bumping to avoid name clashes with sunrise version, no functional changes
(Portage version: 2.2.0_alpha93/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/awl')
-rw-r--r--dev-php/awl/ChangeLog7
-rw-r--r--dev-php/awl/awl-0.51-r1.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-php/awl/ChangeLog b/dev-php/awl/ChangeLog
index 690d29e236f8..ee0ec7f4bc86 100644
--- a/dev-php/awl/ChangeLog
+++ b/dev-php/awl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/awl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/awl/ChangeLog,v 1.1 2012/03/14 06:43:43 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/awl/ChangeLog,v 1.2 2012/03/22 00:20:11 patrick Exp $
+
+*awl-0.51-r1 (22 Mar 2012)
+
+ 22 Mar 2012; Patrick Lauer <patrick@gentoo.org> +awl-0.51-r1.ebuild:
+ Bumping to avoid name clashes with sunrise version, no functional changes
16 Jan 2012; lebarjack <francois.perichon@univ-lille2.fr>
-awl-0.49.ebuild, +awl-0.51.ebuild:
diff --git a/dev-php/awl/awl-0.51-r1.ebuild b/dev-php/awl/awl-0.51-r1.ebuild
new file mode 100644
index 000000000000..ba9346e354b3
--- /dev/null
+++ b/dev-php/awl/awl-0.51-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/awl/awl-0.51-r1.ebuild,v 1.1 2012/03/22 00:20:11 patrick Exp $
+
+EAPI=2
+
+inherit depend.php php-lib-r1
+
+DESCRIPTION="Andrew McMillan's web libraries: A collection of generic classes
+used by the davical calendar server"
+HOMEPAGE="http://andrew.mcmillan.net.nz/projects/awl"
+SRC_URI="http://debian.mcmillan.net.nz/packages/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-lang/php[pdo,postgres,xml]
+ doc? ( dev-php/PEAR-PhpDocumentor )"
+RDEPEND="${DEPEND}"
+
+need_php5
+
+src_compile() {
+ if use doc ; then
+ ebegin "Generating documentation"
+ phpdoc -c "docs/api/phpdoc.ini" || die "Documentation failed to build"
+ fi
+}
+
+src_install() {
+ local docs="debian/README.Debian debian/changelog"
+ dodoc-php ${docs} || die "dodoc failed"
+
+ if use doc ; then
+ dohtml -r "docs/api/" || die "dohtml failed"
+ fi
+
+ php-lib-r1_src_install . dba/* inc/* scripts/*
+}