summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-03-17 12:48:52 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-03-17 12:48:52 +0000
commit542cc3802180c967ad207a02c51d3df157efffbc (patch)
tree0fcc368a9266ccf3f49481aceb511e75b52031c3 /dev-php/PEAR-PEAR
parentVersion bump from project overlay (diff)
downloadgentoo-2-542cc3802180c967ad207a02c51d3df157efffbc.tar.gz
gentoo-2-542cc3802180c967ad207a02c51d3df157efffbc.tar.bz2
gentoo-2-542cc3802180c967ad207a02c51d3df157efffbc.zip
Version bump from project overlay
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-php/PEAR-PEAR')
-rw-r--r--dev-php/PEAR-PEAR/ChangeLog15
-rw-r--r--dev-php/PEAR-PEAR/PEAR-PEAR-1.7.1.ebuild144
-rw-r--r--dev-php/PEAR-PEAR/files/pear.conf-r12
3 files changed, 159 insertions, 2 deletions
diff --git a/dev-php/PEAR-PEAR/ChangeLog b/dev-php/PEAR-PEAR/ChangeLog
index 63604f907919..bb5ca862770a 100644
--- a/dev-php/PEAR-PEAR/ChangeLog
+++ b/dev-php/PEAR-PEAR/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-php/PEAR-PEAR
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/ChangeLog,v 1.105 2007/12/06 00:45:22 jokey Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/ChangeLog,v 1.106 2008/03/17 12:48:51 jokey Exp $
+
+*PEAR-PEAR-1.7.1 (17 Mar 2008)
+
+ 17 Mar 2008; <jokey@gentoo.org> +files/pear.conf-r1,
+ +PEAR-PEAR-1.7.1.ebuild:
+ Version bump from project overlay
+
+ 03 Feb 2008; Jakub Moc <jakub@gentoo.org>
+ +PEAR-PEAR-1.7.1.ebuild:
+ Version bump; major ebuild rewrite. Masked for now, see Known bugs at
+ http://pear.php.net/package/PEAR/download/1.7.1/ before using this!
06 Dec 2007; Markus Ullmann <jokey@gentoo.org> PEAR-PEAR-1.6.1.ebuild,
PEAR-PEAR-1.6.2-r1.ebuild:
diff --git a/dev-php/PEAR-PEAR/PEAR-PEAR-1.7.1.ebuild b/dev-php/PEAR-PEAR/PEAR-PEAR-1.7.1.ebuild
new file mode 100644
index 000000000000..c064cc9a1ea1
--- /dev/null
+++ b/dev-php/PEAR-PEAR/PEAR-PEAR-1.7.1.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/PEAR-PEAR-1.7.1.ebuild,v 1.1 2008/03/17 12:48:51 jokey Exp $
+
+inherit depend.php
+
+ARCHIVE_TAR="1.3.2"
+CONSOLE_GETOPT="1.2.3"
+STRUCTURES_GRAPH="1.0.2"
+XML_RPC="1.5.1"
+PEAR="${PV}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="PEAR Base System (PEAR, Archive_Tar, Console_Getopt, Structures_Graph, XML_RPC)."
+HOMEPAGE="http://pear.php.net/"
+SRC_URI="http://pear.php.net/get/Archive_Tar-${ARCHIVE_TAR}.tgz
+ http://pear.php.net/get/Console_Getopt-${CONSOLE_GETOPT}.tgz
+ http://pear.php.net/get/Structures_Graph-${STRUCTURES_GRAPH}.tgz
+ http://pear.php.net/get/XML_RPC-${XML_RPC}.tgz
+ http://pear.php.net/get/PEAR-${PEAR}.tgz"
+LICENSE="LGPL-2.1 PHP-2.02 PHP-3 PHP-3.01 MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-lang/php"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ has_php
+
+ # we check that PHP was compiled with the correct USE flags
+ if [[ ${PHP_VERSION} == "4" ]] ; then
+ require_php_with_use cli pcre expat zlib
+ else
+ require_php_with_use cli pcre xml zlib
+ fi
+
+ [[ -z "${PEAR_CACHEDIR}" ]] && PEAR_CACHEDIR="/var/cache/pear"
+ [[ -z "${PEAR_DOWNLOADDIR}" ]] && PEAR_DOWNLOADDIR="/var/tmp/pear"
+ [[ -z "${PEAR_TEMPDIR}" ]] && PEAR_TEMPDIR="/tmp"
+
+ elog
+ elog "cache_dir is set to: ${PEAR_CACHEDIR}"
+ elog "download_dir is set to: ${PEAR_DOWNLOADDIR}"
+ elog "temp_dir is set to: ${PEAR_TEMPDIR}"
+ elog
+ elog "If you want to change the above values, you need to set"
+ elog "PEAR_CACHEDIR, PEAR_DOWNLOADDIR and PEAR_TEMPDIR variable(s)"
+ elog "accordingly in /etc/make.conf and re-emerge ${PN}."
+ elog
+}
+
+src_install() {
+ # Prevent SNMP related sandbox violoation.
+ addpredict /usr/share/snmp/mibs/.index
+ addpredict /var/lib/net-snmp/
+
+ # install PEAR package
+ cd "${S}"/PEAR-${PEAR}
+
+ insinto /usr/share/php
+ doins -r PEAR/
+ doins -r OS/
+ doins PEAR.php System.php
+ doins scripts/pearcmd.php
+ doins scripts/peclcmd.php
+
+ newbin scripts/pear.sh pear
+ newbin scripts/peardev.sh peardev
+ newbin scripts/pecl.sh pecl
+
+ # install Archive_Tar package
+ cd "${S}"/Archive_Tar-${ARCHIVE_TAR}
+ insinto /usr/share/php
+ doins -r Archive/
+
+ # install Console_Getopt package.
+ cd "${S}"/Console_Getopt-${CONSOLE_GETOPT}
+ insinto /usr/share/php
+ doins -r Console/
+
+ # install Structures_Graph package
+ cd "${S}"/Structures_Graph-${STRUCTURES_GRAPH}
+ insinto /usr/share/php
+ doins -r Structures/
+
+ # install XML_RPC package
+ cd "${S}"/XML_RPC-${XML_RPC}
+ insinto /usr/share/php/XML
+ doins RPC.php
+ insinto /usr/share/php/XML/RPC
+ doins Dump.php Server.php
+
+ # adjust some scripts for current version
+ for i in pearcmd.php peclcmd.php ; do
+ dosed "s:@pear_version@:${PEAR}:g" /usr/share/php/${i}
+ done
+
+ for i in pear peardev pecl ; do
+ dosed "s:@php_bin@:${PHPCLI}:g" /usr/bin/${i}
+ dosed "s:@bin_dir@:/usr/bin:g" /usr/bin/${i}
+ dosed "s:@php_dir@:/usr/share/php:g" /usr/bin/${i}
+ done
+ dosed "s:-d output_buffering=1:-d output_buffering=1 -d memory_limit=32M:g" /usr/bin/pear
+
+ dosed "s:@package_version@:${PEAR}:g" /usr/share/php/PEAR/Command/Package.php
+ dosed "s:@PEAR-VER@:${PEAR}:g" /usr/share/php/PEAR/Dependency2.php
+ dosed "s:@PEAR-VER@:${PEAR}:g" /usr/share/php/PEAR/PackageFile/Parser/v1.php
+ dosed "s:@PEAR-VER@:${PEAR}:g" /usr/share/php/PEAR/PackageFile/Parser/v2.php
+
+ # finalize install
+ insinto /etc
+ newins "${FILESDIR}"/pear.conf-r1 pear.conf
+ dosed "s|s:PHPCLILEN:\"PHPCLI\"|s:${#PHPCLI}:\"${PHPCLI}\"|g" /etc/pear.conf
+ dosed "s|s:CACHEDIRLEN:\"CACHEDIR\"|s:${#PEAR_CACHEDIR}:\"${PEAR_CACHEDIR}\"|g" /etc/pear.conf
+ dosed "s|s:DOWNLOADDIRLEN:\"DOWNLOADDIR\"|s:${#PEAR_DOWNLOADDIR}:\"${PEAR_DOWNLOADDIR}\"|g" /etc/pear.conf
+ dosed "s|s:TEMPDIRLEN:\"TEMPDIR\"|s:${#PEAR_TEMPDIR}:\"${PEAR_TEMPDIR}\"|g" /etc/pear.conf
+
+ [[ "${PEAR_TEMPDIR}" != "/tmp" ]] && keepdir "${PEAR_TEMPDIR}"
+ keepdir "${PEAR_CACHEDIR}"
+ diropts -m1777
+ keepdir "${PEAR_DOWNLOADDIR}"
+}
+
+pkg_preinst() {
+ rm -f "${ROOT}/etc/pear.conf"
+}
+
+pkg_postinst() {
+ pear clear-cache
+
+ # Update PEAR/PECL channels as needed, add new ones to the list if needed
+ local pearchans="pear.php.net pecl.php.net components.ez.no pear.phpdb.org pear.phing.info
+ pear.symfony-project.com pear.phpunit.de pear.php-baustelle.de pear.zeronotice.org
+ pear.phpontrax.com pear.agavi.org"
+
+ for chan in ${pearchans} ; do
+ pear channel-discover ${chan}
+ pear channel-update ${chan}
+ done
+}
diff --git a/dev-php/PEAR-PEAR/files/pear.conf-r1 b/dev-php/PEAR-PEAR/files/pear.conf-r1
new file mode 100644
index 000000000000..78f69818940f
--- /dev/null
+++ b/dev-php/PEAR-PEAR/files/pear.conf-r1
@@ -0,0 +1,2 @@
+#PEAR_Config 0.9
+a:9:{s:7:"doc_dir";s:19:"/usr/share/php/docs";s:8:"data_dir";s:19:"/usr/share/php/data";s:8:"test_dir";s:20:"/usr/share/php/tests";s:7:"php_dir";s:14:"/usr/share/php";s:7:"bin_dir";s:8:"/usr/bin";s:7:"php_bin";s:PHPCLILEN:"PHPCLI";s:9:"cache_dir";s:CACHEDIRLEN:"CACHEDIR";s:12:"download_dir";s:DOWNLOADDIRLEN:"DOWNLOADDIR";s:8:"temp_dir";s:TEMPDIRLEN:"TEMPDIR";} \ No newline at end of file