summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-08-17 13:17:03 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-08-17 13:17:03 +0000
commit8f8fdf577f84f49cf0e395b862d5fd317f6a9b47 (patch)
tree301a8ad5943ed2532cba964347fd44f36e23e8eb /dev-perl
parentBump (diff)
downloadgentoo-2-8f8fdf577f84f49cf0e395b862d5fd317f6a9b47.tar.gz
gentoo-2-8f8fdf577f84f49cf0e395b862d5fd317f6a9b47.tar.bz2
gentoo-2-8f8fdf577f84f49cf0e395b862d5fd317f6a9b47.zip
Bump
(Portage version: 2.2.0/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/HTML-Mason/ChangeLog7
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.510.0.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-perl/HTML-Mason/ChangeLog b/dev-perl/HTML-Mason/ChangeLog
index 9edd78ad6f03..9ef32f8b7d24 100644
--- a/dev-perl/HTML-Mason/ChangeLog
+++ b/dev-perl/HTML-Mason/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/HTML-Mason
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.107 2013/01/06 20:30:04 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.108 2013/08/17 13:17:03 patrick Exp $
+
+*HTML-Mason-1.510.0 (17 Aug 2013)
+
+ 17 Aug 2013; Patrick Lauer <patrick@gentoo.org> +HTML-Mason-1.510.0.ebuild:
+ Bump
06 Jan 2013; Torsten Veller <tove@gentoo.org> -HTML-Mason-1.480.0.ebuild:
Cleanup
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.510.0.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.510.0.ebuild
new file mode 100644
index 000000000000..7c109fa664ae
--- /dev/null
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.510.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.510.0.ebuild,v 1.1 2013/08/17 13:17:03 patrick Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=JSWARTZ
+MODULE_VERSION=1.51
+inherit depend.apache perl-module
+
+DESCRIPTION="A HTML development and delivery Perl Module"
+HOMEPAGE="http://www.masonhq.com/ ${HOMEPAGE}"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="modperl test"
+
+RDEPEND="!modperl? ( virtual/perl-CGI )
+ modperl? (
+ www-apache/libapreq2
+ >=www-apache/mod_perl-2
+ )
+ >=dev-perl/Params-Validate-0.7
+ >=dev-perl/Class-Container-0.08
+ >=dev-perl/Exception-Class-1.15
+ dev-perl/HTML-Parser
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-File-Spec
+ >=dev-perl/Cache-Cache-1.01
+ dev-perl/Log-Any"
+
+DEPEND="${RDEPEND}
+ virtual/perl-Module-Build
+ test? ( dev-perl/Test-Deep )"
+
+want_apache2 modperl
+
+SRC_TEST="do"
+mydoc="CREDITS UPGRADE"
+myconf="--noprompts"
+
+pkg_setup() {
+ depend.apache_pkg_setup modperl
+ perl-module_pkg_setup
+}
+
+src_prepare() {
+ # Note about new modperl use flag
+ if use !modperl ; then
+ ewarn "HTML-Mason will only install with modperl support"
+ ewarn "if the use flag modperl is enabled."
+ fi
+ # rendhalver - needed to set an env var for the build script so it finds our apache.
+ export APACHE="${APACHE_BIN}"
+ perl-module_src_prepare
+}
+
+src_install () {
+ perl-module_src_install
+ mv "${ED}"/usr/bin/convert* "${ED}"/usr/share/doc/${PF} || die
+}