summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-06-23 20:22:37 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-06-23 20:22:37 +0000
commit0949297e7bb1acba95e92b73e4a85432f370f089 (patch)
tree712fd721f2bc3a9682a3f7c622933f605e301ff8 /dev-perl/module-build
parentVersion bump upstream (diff)
downloadgentoo-2-0949297e7bb1acba95e92b73e4a85432f370f089.tar.gz
gentoo-2-0949297e7bb1acba95e92b73e4a85432f370f089.tar.bz2
gentoo-2-0949297e7bb1acba95e92b73e4a85432f370f089.zip
Version bump upstream
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'dev-perl/module-build')
-rw-r--r--dev-perl/module-build/ChangeLog8
-rw-r--r--dev-perl/module-build/files/digest-module-build-0.28.013
-rw-r--r--dev-perl/module-build/module-build-0.28.01.ebuild28
3 files changed, 38 insertions, 1 deletions
diff --git a/dev-perl/module-build/ChangeLog b/dev-perl/module-build/ChangeLog
index 829ff017b2cc..b490e8737839 100644
--- a/dev-perl/module-build/ChangeLog
+++ b/dev-perl/module-build/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/module-build
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/ChangeLog,v 1.41 2006/06/18 19:45:19 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/ChangeLog,v 1.42 2006/06/23 20:22:37 mcummings Exp $
+
+*module-build-0.28.01 (23 Jun 2006)
+
+ 23 Jun 2006; Michael Cummings <mcummings@gentoo.org>
+ +module-build-0.28.01.ebuild:
+ Version bump upstream
18 Jun 2006; Andrej Kacian <ticho@gentoo.org> module-build-0.28.ebuild:
Stable on x86. Bug #136708.
diff --git a/dev-perl/module-build/files/digest-module-build-0.28.01 b/dev-perl/module-build/files/digest-module-build-0.28.01
new file mode 100644
index 000000000000..e89089f9eeee
--- /dev/null
+++ b/dev-perl/module-build/files/digest-module-build-0.28.01
@@ -0,0 +1,3 @@
+MD5 fa10e5b53bc41e3948df56d4d115764d Module-Build-0.2801.tar.gz 180503
+RMD160 4fde62422c0e01fb8c8bffb6e2969a3415b56ebf Module-Build-0.2801.tar.gz 180503
+SHA256 cc85a53e8e8617df54d161bd126c88d2782b43538e14710122017e2c4f7e56bb Module-Build-0.2801.tar.gz 180503
diff --git a/dev-perl/module-build/module-build-0.28.01.ebuild b/dev-perl/module-build/module-build-0.28.01.ebuild
new file mode 100644
index 000000000000..12e41981ad8b
--- /dev/null
+++ b/dev-perl/module-build/module-build-0.28.01.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/module-build-0.28.01.ebuild,v 1.1 2006/06/23 20:22:37 mcummings Exp $
+
+inherit versionator perl-module
+
+MY_PV="$(delete_version_separator 2)"
+MY_P="Module-Build-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Build and install Perl modules"
+HOMEPAGE="http://search.cpan.org/~kwilliams/${MY_P}/"
+SRC_URI="mirror://cpan/authors/id/K/KW/KWILLIAMS/${MY_P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+# Removing these as hard deps. They are listed as recommended in the Build.PL,
+# but end up causing a dep loop since they require module-build to be built.
+# ~mcummings 06.16.06
+PDEPEND=">=dev-perl/ExtUtils-CBuilder-0.15
+ >=dev-perl/extutils-parsexs-1.02"
+
+DEPEND="dev-perl/yaml
+ >=dev-perl/Archive-Tar-1.09"
+
+SRC_TEST="do"