summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-04-19 11:28:37 +0000
committerTorsten Veller <tove@gentoo.org>2010-04-19 11:28:37 +0000
commit1918569bdd44706dec14d461114a3228bfd630c7 (patch)
tree0d1acb371045b16500244c6964512a9546199de6 /dev-perl/gtk2-spell
parentMask www-client/chromium dev channel release. (diff)
downloadgentoo-2-1918569bdd44706dec14d461114a3228bfd630c7.tar.gz
gentoo-2-1918569bdd44706dec14d461114a3228bfd630c7.tar.bz2
gentoo-2-1918569bdd44706dec14d461114a3228bfd630c7.zip
Maintenance. Add missing deps. Fix LICENSE. EAPI=3
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/gtk2-spell')
-rw-r--r--dev-perl/gtk2-spell/ChangeLog5
-rw-r--r--dev-perl/gtk2-spell/gtk2-spell-1.03.ebuild27
2 files changed, 19 insertions, 13 deletions
diff --git a/dev-perl/gtk2-spell/ChangeLog b/dev-perl/gtk2-spell/ChangeLog
index 56664b3e924c..f275862e7738 100644
--- a/dev-perl/gtk2-spell/ChangeLog
+++ b/dev-perl/gtk2-spell/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-perl/gtk2-spell
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/gtk2-spell/ChangeLog,v 1.19 2010/01/10 09:48:35 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/gtk2-spell/ChangeLog,v 1.20 2010/04/19 11:28:37 tove Exp $
+
+ 19 Apr 2010; Torsten Veller <tove@gentoo.org> gtk2-spell-1.03.ebuild:
+ Maintenance. Add missing deps. Fix LICENSE. EAPI=3
10 Jan 2010; Fabian Groffen <grobian@gentoo.org> gtk2-spell-1.03.ebuild:
Transfer Prefix keywords
diff --git a/dev-perl/gtk2-spell/gtk2-spell-1.03.ebuild b/dev-perl/gtk2-spell/gtk2-spell-1.03.ebuild
index 816539f06e8a..6f6763c86f66 100644
--- a/dev-perl/gtk2-spell/gtk2-spell-1.03.ebuild
+++ b/dev-perl/gtk2-spell/gtk2-spell-1.03.ebuild
@@ -1,31 +1,34 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/gtk2-spell/gtk2-spell-1.03.ebuild,v 1.17 2010/01/10 09:48:35 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/gtk2-spell/gtk2-spell-1.03.ebuild,v 1.18 2010/04/19 11:28:37 tove Exp $
-inherit perl-module
+EAPI=3
-MY_P=Gtk2-Spell-${PV}
+MY_PN=Gtk2-Spell
+MY_P=${MY_PN}-${PV}
S=${WORKDIR}/${MY_P}
+MODULE_AUTHOR=MLEHMANN
+inherit perl-module
DESCRIPTION="Bindings for GtkSpell with Gtk2.x"
-SRC_URI="mirror://cpan/authors/id/M/ML/MLEHMANN/${MY_P}.tar.gz"
-HOMEPAGE="http://gtk2-perl.sf.net/"
+HOMEPAGE="http://gtk2-perl.sf.net/ ${HOMEPAGE}"
+
SLOT="0"
-LICENSE="GPL-2"
+LICENSE="LGPL-2.1"
KEYWORDS="alpha amd64 hppa ia64 ~ppc sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
IUSE=""
RDEPEND=">=x11-libs/gtk+-2
>=app-text/gtkspell-2
>=dev-perl/glib-perl-1.012
- >=dev-perl/gtk2-perl-1.012
- dev-lang/perl"
+ >=dev-perl/gtk2-perl-1.012"
DEPEND="${RDEPEND}
+ dev-perl/extutils-depends
+ dev-perl/extutils-pkgconfig
dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd ${S}
+src_prepare() {
# Without this it cannot find gtkspell <rigo@home.nl>
- sed -ie "s:\#my:my:g" Makefile.PL || die "sed failed"
+ sed -ie "s:\#my:my:g" "${S}"/Makefile.PL || die "sed failed"
+ perl-module_src_prepare
}