summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-07-04 13:27:38 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-07-04 13:27:38 +0000
commit1c43966d17dc4352b13b5a284dcb7c38bc3dcd58 (patch)
tree62f570133f6a985a992286ab2e2176ba1cd68fb0 /dev-perl/SOAP-Lite/SOAP-Lite-0.67.ebuild
parentFixed RDEPEND wrt bug #134781; fixed header; fixed DEPEND (diff)
downloadgentoo-2-1c43966d17dc4352b13b5a284dcb7c38bc3dcd58.tar.gz
gentoo-2-1c43966d17dc4352b13b5a284dcb7c38bc3dcd58.tar.bz2
gentoo-2-1c43966d17dc4352b13b5a284dcb7c38bc3dcd58.zip
Version bump
(Portage version: 2.1.1_pre2-r2)
Diffstat (limited to 'dev-perl/SOAP-Lite/SOAP-Lite-0.67.ebuild')
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-0.67.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-0.67.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-0.67.ebuild
new file mode 100644
index 000000000000..1ff1936a697f
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-0.67.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/SOAP-Lite-0.67.ebuild,v 1.1 2006/07/04 13:27:38 mcummings Exp $
+
+IUSE="jabber ssl"
+
+inherit perl-module eutils
+
+MY_PV=${PV/a//}
+MY_P=SOAP-Lite-${MY_PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Provides a simple and lightweight interface to the SOAP protocol (sic) both on client and server side."
+
+SRC_URI="mirror://cpan/authors/id/B/BY/BYRNE/SOAP/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/~byrne/${P}"
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+myconf="${myconf} --noprompt"
+
+# TESTS ARE DISABLED ON PURPOSE
+# This module attempts to access an external website for validation
+# of the MIME::Parser - not only is that bad practice in general,
+# but in this particular case the external site isn't even valid anymore# -mpc
+# 24/10/04
+SRC_TEST="do"
+
+DEPEND="${DEPEND}
+ dev-perl/XML-Parser
+ dev-perl/libwww-perl
+ virtual/perl-libnet
+ dev-perl/MIME-Lite
+ virtual/perl-MIME-Base64
+ ssl? ( dev-perl/Crypt-SSLeay )
+ jabber? ( dev-perl/Net-Jabber )
+ ssl? ( dev-perl/IO-Socket-SSL )
+ dev-perl/Compress-Zlib
+ >=dev-perl/MIME-tools-5.413"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # The author of this module put a dep for MIME::Parser 6.X - but the6.X
+ # release of MIME::Parser was a mistake during a change in maintainers on
+ # cpan. This patch alters the dependancy to the "real" stable version of
+ # MIME::Parser.
+ epatch ${FILESDIR}/SOAP-Lite-0.60.a.patch
+}