summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-03-07 12:04:07 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-03-07 12:04:07 +0000
commit5887387bfe3602c8dfb03ced9b55c55e403c188f (patch)
tree89aea2dbdfec79950dd38e70131feb399ba50658 /dev-perl/Lab-Measurement/Lab-Measurement-3.310.0.ebuild
parentdev-python/ipython: Version Bump (diff)
downloadgentoo-2-5887387bfe3602c8dfb03ced9b55c55e403c188f.tar.gz
gentoo-2-5887387bfe3602c8dfb03ced9b55c55e403c188f.tar.bz2
gentoo-2-5887387bfe3602c8dfb03ced9b55c55e403c188f.zip
Version bump; remove old
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 94BFDF4484AD142F)
Diffstat (limited to 'dev-perl/Lab-Measurement/Lab-Measurement-3.310.0.ebuild')
-rw-r--r--dev-perl/Lab-Measurement/Lab-Measurement-3.310.0.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/dev-perl/Lab-Measurement/Lab-Measurement-3.310.0.ebuild b/dev-perl/Lab-Measurement/Lab-Measurement-3.310.0.ebuild
new file mode 100644
index 000000000000..d8cc6f434a78
--- /dev/null
+++ b/dev-perl/Lab-Measurement/Lab-Measurement-3.310.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Lab-Measurement/Lab-Measurement-3.310.0.ebuild,v 1.1 2014/03/07 12:04:07 dilfridge Exp $
+
+EAPI=5
+
+if [[ "${PV}" != "9999" ]]; then
+ MODULE_VERSION=3.31
+ MODULE_AUTHOR="AKHUETTEL"
+ KEYWORDS="~amd64 ~x86"
+ inherit perl-module
+else
+ EGIT_REPO_URI="git://gitorious.org/lab-measurement/lab.git"
+ EGIT_BRANCH="master"
+ EGIT_SOURCEDIR=${S}
+ KEYWORDS=""
+ S=${WORKDIR}/${P}/Measurement
+ inherit perl-module git-2
+fi
+
+DESCRIPTION="Measurement control and automation with Perl"
+HOMEPAGE="http://www.labmeasurement.de/"
+
+# this is perl's license, whatever it means
+LICENSE="|| ( Artistic GPL-2 )"
+
+SLOT="0"
+IUSE="debug +xpression"
+
+RDEPEND="
+ dev-perl/Clone
+ dev-perl/Exception-Class
+ dev-perl/Hook-LexWrap
+ dev-perl/List-MoreUtils
+ dev-perl/TermReadKey
+ dev-perl/TeX-Encode
+ dev-perl/XML-Generator
+ dev-perl/XML-DOM
+ dev-perl/XML-Twig
+ dev-perl/encoding-warnings
+ dev-perl/yaml
+ sci-visualization/gnuplot
+ virtual/perl-Class-ISA
+ virtual/perl-Data-Dumper
+ virtual/perl-Encode
+ virtual/perl-Switch
+ virtual/perl-Time-HiRes
+ !dev-perl/Lab-Instrument
+ !dev-perl/Lab-Tools
+ debug? (
+ dev-lang/perl[ithreads]
+ dev-perl/wxperl
+ )
+ xpression? (
+ dev-perl/wxperl
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/perl-Module-Build
+"
+
+pkg_postinst() {
+ if ( ! has_version sci-libs/linuxgpib ) && ( ! has_version dev-perl/Lab-VISA ) ; then
+ elog "You may want to install one or more backend driver modules. Supported are"
+ elog " sci-libs/linuxgpib Open-source GPIB hardware driver"
+ elog " dev-perl/Lab-VISA Bindings for the NI proprietary VISA driver"
+ elog " stack (dilfridge overlay)"
+ fi
+}