summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-06-24 17:07:19 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-06-24 17:07:19 +0000
commit6a8dd861a3eb3f02a29f62e1f85e3b8d1dceb1b2 (patch)
tree34af954afb851925eac515cf10b738cb96012e8a /dev-perl/HTML-Mason/HTML-Mason-1.33.ebuild
parentVersion bump upstream (diff)
downloadgentoo-2-6a8dd861a3eb3f02a29f62e1f85e3b8d1dceb1b2.tar.gz
gentoo-2-6a8dd861a3eb3f02a29f62e1f85e3b8d1dceb1b2.tar.bz2
gentoo-2-6a8dd861a3eb3f02a29f62e1f85e3b8d1dceb1b2.zip
Version bump upstream
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'dev-perl/HTML-Mason/HTML-Mason-1.33.ebuild')
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.33.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.33.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.33.ebuild
new file mode 100644
index 000000000000..36820e18f6da
--- /dev/null
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.33.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.33.ebuild,v 1.1 2006/06/24 17:07:19 mcummings Exp $
+
+inherit perl-module
+
+DESCRIPTION="A HTML development and delivery Perl Module"
+SRC_URI="mirror://cpan/authors/id/D/DR/DROLSKY/${P}.tar.gz"
+HOMEPAGE="http://www.masonhq.com/"
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="apache2 modperl doc"
+SRC_TEST="do"
+
+DEPEND="
+ !modperl? ( virtual/perl-CGI )
+ modperl? (
+ !apache2? (
+ =net-www/apache-1*
+ >=www-apache/libapreq-1.0-r2
+ <www-apache/mod_perl-2 )
+ apache2? (
+ >=net-www/apache-2
+ www-apache/libapreq2
+ >=www-apache/mod_perl-2 )
+ )
+ >=dev-perl/Params-Validate-0.7
+ dev-perl/module-build
+ >=dev-perl/Class-Container-0.08
+ >=dev-perl/Exception-Class-1.15
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-File-Spec
+ >=dev-perl/Cache-Cache-1.01"
+
+RDEPEND="${DEPEND}"
+
+mydoc="CREDITS UPGRADE"
+myconf="--noprompts"
+
+perl-module_src_prep() {
+ # Note about new modperl use flag
+ if use !modperl ; then
+ ewarn "HTML-Mason will only install with modperl support"
+ ewarn "if the use flag modperl is enabled."
+ sleep 5
+ fi
+ # rendhalver - needed to set an env var for the build script so it finds our apache.
+ if use apache2; then
+ APACHE="/usr/sbin/apache2"
+ else
+ APACHE="/usr/sbin/apache"
+ fi
+
+ APACHE="${APACHE}" perl ${S}/Build.PL installdirs=vendor destdir=${D} ${myconf}
+}
+
+src_install () {
+ perl-module_src_install
+ # rendhalver - the html docs have subdirs so this gets all of them
+ use doc && dohtml -r htdocs/*
+}