summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-06-12 12:40:09 +0000
committerTorsten Veller <tove@gentoo.org>2010-06-12 12:40:09 +0000
commit1fccbf6610ef855dab79be599a8666fc444fabb9 (patch)
tree230eb298f4bf5cb57ce07e96a25cb6d4b858a7d7 /dev-perl/Email-Valid
parentdo not try to sed a file that does not exist when use=-gif -png is used, bug ... (diff)
downloadgentoo-2-1fccbf6610ef855dab79be599a8666fc444fabb9.tar.gz
gentoo-2-1fccbf6610ef855dab79be599a8666fc444fabb9.tar.bz2
gentoo-2-1fccbf6610ef855dab79be599a8666fc444fabb9.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/Email-Valid')
-rw-r--r--dev-perl/Email-Valid/ChangeLog10
-rw-r--r--dev-perl/Email-Valid/Email-Valid-0.184.ebuild23
-rw-r--r--dev-perl/Email-Valid/files/0.181-disable-online-test.patch4
3 files changed, 32 insertions, 5 deletions
diff --git a/dev-perl/Email-Valid/ChangeLog b/dev-perl/Email-Valid/ChangeLog
index 812aa7bed698..492b80624d37 100644
--- a/dev-perl/Email-Valid/ChangeLog
+++ b/dev-perl/Email-Valid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/Email-Valid
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Email-Valid/ChangeLog,v 1.41 2009/06/08 06:53:15 tove Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Email-Valid/ChangeLog,v 1.42 2010/06/12 12:40:09 tove Exp $
+
+*Email-Valid-0.184 (12 Jun 2010)
+
+ 12 Jun 2010; Torsten Veller <tove@gentoo.org>
+ files/0.181-disable-online-test.patch, +Email-Valid-0.184.ebuild:
+ Version bump
08 Jun 2009; Torsten Veller <tove@gentoo.org>
+files/0.181-disable-online-test.patch, Email-Valid-0.181.ebuild:
diff --git a/dev-perl/Email-Valid/Email-Valid-0.184.ebuild b/dev-perl/Email-Valid/Email-Valid-0.184.ebuild
new file mode 100644
index 000000000000..349a90a0cfbc
--- /dev/null
+++ b/dev-perl/Email-Valid/Email-Valid-0.184.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Email-Valid/Email-Valid-0.184.ebuild,v 1.1 2010/06/12 12:40:09 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=RJBS
+inherit perl-module
+
+DESCRIPTION="Check validity of Internet email addresses."
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/MailTools
+ dev-perl/Net-DNS"
+DEPEND="test? ( ${RDEPEND}
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage )"
+
+SRC_TEST="do"
+PATCHES=( "${FILESDIR}/0.181-disable-online-test.patch" )
diff --git a/dev-perl/Email-Valid/files/0.181-disable-online-test.patch b/dev-perl/Email-Valid/files/0.181-disable-online-test.patch
index 6d30f498730c..ec716ea8c7ee 100644
--- a/dev-perl/Email-Valid/files/0.181-disable-online-test.patch
+++ b/dev-perl/Email-Valid/files/0.181-disable-online-test.patch
@@ -1,7 +1,7 @@
diff -ur Email-Valid-0.181-orig/t/valid.t Email-Valid-0.181/t/valid.t
--- Email-Valid-0.181-orig/t/valid.t 2008-11-21 22:36:54.000000000 +0100
+++ Email-Valid-0.181/t/valid.t 2009-06-08 08:43:31.000000000 +0200
-@@ -85,8 +85,7 @@
+@@ -85,6 +85,5 @@
);
SKIP: {
@@ -9,5 +9,3 @@ diff -ur Email-Valid-0.181-orig/t/valid.t Email-Valid-0.181/t/valid.t
- unless $v->address(-address=> 'devnull@pobox.com', -mxcheck => 1);
+ skip "disabled online tests", 2;
- ok(
- $v->address(-address => 'blort@aol.com', -mxcheck => 1),