summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexandre Buisse <nattfodd@gentoo.org>2006-11-03 10:51:45 +0000
committerAlexandre Buisse <nattfodd@gentoo.org>2006-11-03 10:51:45 +0000
commite7e982517f09d335a6c1b16a7530a3c791ea59d6 (patch)
treeb89daf5084dbf7c8efc081f643832686ba2d3357 /dev-ml
parents/tcltk/tk/g (bug #17808). (diff)
downloadgentoo-2-e7e982517f09d335a6c1b16a7530a3c791ea59d6.tar.gz
gentoo-2-e7e982517f09d335a6c1b16a7530a3c791ea59d6.tar.bz2
gentoo-2-e7e982517f09d335a6c1b16a7530a3c791ea59d6.zip
s/tcltk/tk/g (bug #17808).
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/lablgl/ChangeLog5
-rw-r--r--dev-ml/lablgl/lablgl-1.00.ebuild18
2 files changed, 13 insertions, 10 deletions
diff --git a/dev-ml/lablgl/ChangeLog b/dev-ml/lablgl/ChangeLog
index 5092e424f978..b2cd521c4ad8 100644
--- a/dev-ml/lablgl/ChangeLog
+++ b/dev-ml/lablgl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/lablgl
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.37 2006/04/01 06:55:13 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.38 2006/11/03 10:51:45 nattfodd Exp $
+
+ 03 Nov 2006; Alexandre Buisse <nattfodd@gentoo.org> lablgl-1.00.ebuild:
+ Change tcltk USE to tk (bug #17808).
01 Apr 2006; Alec Warner <antarus@gentoo.org> lablgl-1.00.ebuild:
QA issue bug 124326, sleep -> epause
diff --git a/dev-ml/lablgl/lablgl-1.00.ebuild b/dev-ml/lablgl/lablgl-1.00.ebuild
index 2bb9057aa2be..f408e2d05324 100644
--- a/dev-ml/lablgl/lablgl-1.00.ebuild
+++ b/dev-ml/lablgl/lablgl-1.00.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/lablgl-1.00.ebuild,v 1.22 2006/04/01 06:55:13 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/lablgl-1.00.ebuild,v 1.23 2006/11/03 10:51:45 nattfodd Exp $
inherit multilib eutils
-IUSE="tcltk glut doc"
+IUSE="tk glut doc"
DESCRIPTION="Objective CAML interface for OpenGL"
HOMEPAGE="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgl.html"
@@ -13,9 +13,9 @@ LICENSE="as-is"
DEPEND=">=dev-lang/ocaml-3.05
virtual/opengl
glut? ( virtual/glut )
- tcltk? (
+ tk? (
>=dev-lang/tcl-8.3
- >=dev-lang/tk-8.3
+ >=dev-lang/tk-8.3
)"
SRC_URI="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/${P}.tar.gz"
@@ -24,16 +24,16 @@ KEYWORDS="x86 ppc sparc alpha ia64 amd64 hppa"
pkg_setup()
{
- if ( use tcltk )
+ if ( use tk )
then
#lablgl requires ocaml compiled with tk support while ocaml has it as an optional dependency
- if ( ! built_with_use dev-lang/ocaml tcltk )
+ if ( ! built_with_use dev-lang/ocaml tk )
then
eerror "You don't have ocaml compiled with tk support"
eerror ""
eerror "lablgl requires ocaml be built with tk support."
eerror ""
- eerror "Please recompile ocaml with tcltk useflag enabled."
+ eerror "Please recompile ocaml with tk useflag enabled."
epause 5
die "Ocaml is missing tk support";
fi
@@ -48,7 +48,7 @@ src_compile() {
sed -i "s/-lglut//" Makefile.config
fi
- if use tcltk; then
+ if use tk; then
make togl toglopt
fi
@@ -73,7 +73,7 @@ src_install () {
dodoc README CHANGES COPYRIGHT
- if ( use doc && use tcltk ) then
+ if ( use doc && use tk ) then
DIR=usr/share/doc/${PF}
cp -R Togl/examples/ ${D}/${DIR}/examples.togl
fi