summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-10-24 08:34:07 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-10-24 08:34:07 +0000
commitca8efe67be25f77536ce5896377c26d7750c6217 (patch)
tree374bbb29d0bf573a8fc966d678e591a0dfbd80db /dev-ml
parentkeyword ~arm (diff)
downloadgentoo-2-ca8efe67be25f77536ce5896377c26d7750c6217.tar.gz
gentoo-2-ca8efe67be25f77536ce5896377c26d7750c6217.tar.bz2
gentoo-2-ca8efe67be25f77536ce5896377c26d7750c6217.zip
initial import, ebuild by me
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/cudf/ChangeLog10
-rw-r--r--dev-ml/cudf/cudf-0.7.ebuild46
-rw-r--r--dev-ml/cudf/metadata.xml5
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-ml/cudf/ChangeLog b/dev-ml/cudf/ChangeLog
new file mode 100644
index 000000000000..09bb9aba7040
--- /dev/null
+++ b/dev-ml/cudf/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/cudf
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/cudf/ChangeLog,v 1.1 2014/10/24 08:34:07 aballier Exp $
+
+*cudf-0.7 (24 Oct 2014)
+
+ 24 Oct 2014; Alexis Ballier <aballier@gentoo.org> +cudf-0.7.ebuild,
+ +metadata.xml:
+ initial import, ebuild by me
+
diff --git a/dev-ml/cudf/cudf-0.7.ebuild b/dev-ml/cudf/cudf-0.7.ebuild
new file mode 100644
index 000000000000..c43f2d039800
--- /dev/null
+++ b/dev-ml/cudf/cudf-0.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/cudf/cudf-0.7.ebuild,v 1.1 2014/10/24 08:34:07 aballier Exp $
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="Library to parse, pretty print, and evaluate CUDF documents"
+HOMEPAGE="http://www.mancoosi.org/cudf/"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/33593/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/extlib:=
+ dev-libs/glib:2
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )
+ dev-ml/findlib
+ dev-lang/perl
+"
+
+src_compile() {
+ emake -j1 all
+ emake c-lib
+ if use ocamlopt ; then
+ emake -j1 opt
+ emake c-lib-opt
+ fi
+}
+
+src_test() {
+ emake test
+ emake c-lib-test
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+ dodoc BUGS ChangeLog README TODO
+}
diff --git a/dev-ml/cudf/metadata.xml b/dev-ml/cudf/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/cudf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>