summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-10-10 11:46:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-10-10 11:46:26 +0000
commitbab9b3cafefd6b04e2bc498128efbd666590f1fc (patch)
tree30943ed9f927d93df7393ff5be175296474d2dfc /dev-ml
parentstable ppc ppc64, bug #437616 (diff)
downloadgentoo-2-bab9b3cafefd6b04e2bc498128efbd666590f1fc.tar.gz
gentoo-2-bab9b3cafefd6b04e2bc498128efbd666590f1fc.tar.bz2
gentoo-2-bab9b3cafefd6b04e2bc498128efbd666590f1fc.zip
version bump
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pcre-ocaml/ChangeLog7
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-7.0.2.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ml/pcre-ocaml/ChangeLog b/dev-ml/pcre-ocaml/ChangeLog
index 05cf914710cd..1bacaac285e8 100644
--- a/dev-ml/pcre-ocaml/ChangeLog
+++ b/dev-ml/pcre-ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/pcre-ocaml
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.48 2012/08/22 14:23:06 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.49 2012/10/10 11:46:26 aballier Exp $
+
+*pcre-ocaml-7.0.2 (10 Oct 2012)
+
+ 10 Oct 2012; Alexis Ballier <aballier@gentoo.org> +pcre-ocaml-7.0.2.ebuild:
+ version bump
22 Aug 2012; Alexis Ballier <aballier@gentoo.org> pcre-ocaml-6.2.5.ebuild:
set empty CLIBS, fixing bug #422663
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-7.0.2.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-7.0.2.ebuild
new file mode 100644
index 000000000000..0a36b218766d
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-7.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/pcre-ocaml-7.0.2.ebuild,v 1.1 2012/10/10 11:46:25 aballier Exp $
+
+EAPI=4
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://bitbucket.org/mmottl/pcre-ocaml"
+SRC_URI="http://bitbucket.org/mmottl/pcre-ocaml/downloads/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+IUSE="examples"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ >=dev-libs/libpcre-4.5"
+DEPEND="${RDEPEND}"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}