summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-20 15:53:35 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-20 15:53:35 +0000
commit90bedf9c24b11bb6324211420a527d1f4c1b45b2 (patch)
tree40878f13f67c0f09acf2a9472e19703e68d039c2 /dev-ml
parentmake sure to enable cxx by default (diff)
downloadgentoo-2-90bedf9c24b11bb6324211420a527d1f4c1b45b2.tar.gz
gentoo-2-90bedf9c24b11bb6324211420a527d1f4c1b45b2.tar.bz2
gentoo-2-90bedf9c24b11bb6324211420a527d1f4c1b45b2.zip
version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ounit/ChangeLog7
-rw-r--r--dev-ml/ounit/ounit-1.0.3.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ml/ounit/ChangeLog b/dev-ml/ounit/ChangeLog
index 1a6ef9d161d8..fec4dcaf1feb 100644
--- a/dev-ml/ounit/ChangeLog
+++ b/dev-ml/ounit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ounit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.14 2009/06/20 15:32:42 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.15 2009/06/20 15:53:35 aballier Exp $
+
+*ounit-1.0.3 (20 Jun 2009)
+
+ 20 Jun 2009; Alexis Ballier <aballier@gentoo.org> +ounit-1.0.3.ebuild:
+ version bump
20 Jun 2009; Alexis Ballier <aballier@gentoo.org> ounit-1.0.2.ebuild:
explicitly assign rdepend
diff --git a/dev-ml/ounit/ounit-1.0.3.ebuild b/dev-ml/ounit/ounit-1.0.3.ebuild
new file mode 100644
index 000000000000..a9045490a858
--- /dev/null
+++ b/dev-ml/ounit/ounit-1.0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ounit-1.0.3.ebuild,v 1.1 2009/06/20 15:53:35 aballier Exp $
+
+EAPI="1"
+
+inherit findlib eutils
+
+DESCRIPTION="Unit testing framework for OCaml"
+HOMEPAGE="http://www.xs4all.nl/~mmzeeman/ocaml/"
+SRC_URI="http://www.xs4all.nl/~mmzeeman/ocaml/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+DEPEND="dev-lang/ocaml"
+RDEPEND="${DEPEND}"
+IUSE="+ocamlopt"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile() {
+ emake all || die "emake failed"
+ if use ocamlopt; then
+ emake allopt || die "failed to build native code"
+ fi
+}
+
+src_install() {
+ findlib_src_install
+
+ # install documentation
+ dodoc README changelog
+}