summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-09-09 14:54:09 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-09-09 14:54:09 +0000
commit0f11f3c5e755d6b4b9cca26cb1c7ad00d3b9557c (patch)
tree5ad98fc35c2330078eed524e931447ce562e6838 /dev-ml
parentDrop the sqlite2 useflag, keep only sqlite3 around. (diff)
downloadgentoo-2-0f11f3c5e755d6b4b9cca26cb1c7ad00d3b9557c.tar.gz
gentoo-2-0f11f3c5e755d6b4b9cca26cb1c7ad00d3b9557c.tar.bz2
gentoo-2-0f11f3c5e755d6b4b9cca26cb1c7ad00d3b9557c.zip
version bump
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/extlib/ChangeLog9
-rw-r--r--dev-ml/extlib/extlib-1.5.2.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-ml/extlib/ChangeLog b/dev-ml/extlib/ChangeLog
index ec88233a60a7..d6584b026c7c 100644
--- a/dev-ml/extlib/ChangeLog
+++ b/dev-ml/extlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/extlib
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/ChangeLog,v 1.11 2010/01/02 18:34:53 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/ChangeLog,v 1.12 2011/09/09 14:54:09 aballier Exp $
+
+*extlib-1.5.2 (09 Sep 2011)
+
+ 09 Sep 2011; Alexis Ballier <aballier@gentoo.org> +extlib-1.5.2.ebuild:
+ version bump
02 Jan 2010; Christian Faulhammer <fauli@gentoo.org> extlib-1.5.1.ebuild:
Transfer Prefix keywords
diff --git a/dev-ml/extlib/extlib-1.5.2.ebuild b/dev-ml/extlib/extlib-1.5.2.ebuild
new file mode 100644
index 000000000000..55a9c42b9607
--- /dev/null
+++ b/dev-ml/extlib/extlib-1.5.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/extlib-1.5.2.ebuild,v 1.1 2011/09/09 14:54:09 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+DESCRIPTION="Standard library extensions for O'Caml"
+HOMEPAGE="http://code.google.com/p/ocaml-extlib/"
+SRC_URI="http://ocaml-extlib.googlecode.com/files/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
+RDEPEND="${DEPEND}"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc +ocamlopt"
+
+src_compile() {
+ emake all || die "failed to build"
+ if use ocamlopt; then
+ emake opt || die "failed to build"
+ fi
+
+ if use doc; then
+ emake doc || die "failed to create documentation"
+ fi
+}
+
+src_install () {
+ findlib_src_install
+
+ # install documentation
+ dodoc README.txt || die
+
+ if use doc; then
+ dohtml doc/* || die
+ fi
+}