summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-07-04 21:38:25 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-07-04 21:38:25 +0000
commit287bccc9182015301dea20c2c6ab14368d1ced0e (patch)
treead2a6f14ff692f18bcd6fbc4d02b3d3501fd6c39 /dev-ml/odns
parentreadded missing config files (diff)
downloadgentoo-2-287bccc9182015301dea20c2c6ab14368d1ced0e.tar.gz
gentoo-2-287bccc9182015301dea20c2c6ab14368d1ced0e.tar.bz2
gentoo-2-287bccc9182015301dea20c2c6ab14368d1ced0e.zip
fix parallel build, bug #422683
(Portage version: 2.2.0_alpha115/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/odns')
-rw-r--r--dev-ml/odns/ChangeLog8
-rw-r--r--dev-ml/odns/files/odns-0.3-parmake.patch16
-rw-r--r--dev-ml/odns/odns-0.3.ebuild7
3 files changed, 26 insertions, 5 deletions
diff --git a/dev-ml/odns/ChangeLog b/dev-ml/odns/ChangeLog
index 3484347faa5b..9e96be4ff562 100644
--- a/dev-ml/odns/ChangeLog
+++ b/dev-ml/odns/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/odns
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/odns/ChangeLog,v 1.3 2011/07/06 18:34:50 aballier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/odns/ChangeLog,v 1.4 2012/07/04 21:38:25 aballier Exp $
+
+ 04 Jul 2012; Alexis Ballier <aballier@gentoo.org> odns-0.3.ebuild,
+ +files/odns-0.3-parmake.patch:
+ fix parallel build, bug #422683
06 Jul 2011; Alexis Ballier <aballier@gentoo.org> -odns-0.2.ebuild:
remove old
diff --git a/dev-ml/odns/files/odns-0.3-parmake.patch b/dev-ml/odns/files/odns-0.3-parmake.patch
new file mode 100644
index 000000000000..7034abd25cf2
--- /dev/null
+++ b/dev-ml/odns/files/odns-0.3-parmake.patch
@@ -0,0 +1,16 @@
+fix parallel make
+https://bugs.gentoo.org/show_bug.cgi?id=422683
+
+Index: odns-0.3/OCamlMakefile
+===================================================================
+--- odns-0.3.orig/OCamlMakefile
++++ odns-0.3/OCamlMakefile
+@@ -1152,7 +1152,7 @@ $(BCDIDIR)/%.di $(NCDIDIR)/%.di: %.mli
+ $(DOC_DIR)/$(RESULT)/html:
+ mkdir -p $@
+
+-$(DOC_DIR)/$(RESULT)/html/index.html: $(DOC_DIR)/$(RESULT)/html $(DOC_FILES)
++$(DOC_DIR)/$(RESULT)/html/index.html: $(DOC_DIR)/$(RESULT)/html $(DOC_FILES) byte-code-library
+ rm -rf $</*
+ $(QUIET)pp=`sed -n -e '/^#/d' -e 's/(\*pp \([^*]*\) \*)/\1/p;q' $(FIRST_DOC_FILE)`; \
+ if [ -z "$$pp" ]; then \
diff --git a/dev-ml/odns/odns-0.3.ebuild b/dev-ml/odns/odns-0.3.ebuild
index d6fdbfb7db43..061b735aa786 100644
--- a/dev-ml/odns/odns-0.3.ebuild
+++ b/dev-ml/odns/odns-0.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/odns/odns-0.3.ebuild,v 1.1 2011/03/04 12:33:02 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/odns/odns-0.3.ebuild,v 1.2 2012/07/04 21:38:25 aballier Exp $
EAPI=3
-inherit findlib
+inherit findlib eutils
DESCRIPTION="OCaml library to query DNS servers"
HOMEPAGE="http://odns.tuxfamily.org/"
@@ -20,6 +20,7 @@ DEPEND="${RDEPEND}"
src_prepare() {
sed -i -e "s/version=\"0.2\"/version=\"${PV}\"/" META || die
+ epatch "${FILESDIR}/${P}-parmake.patch"
}
src_install() {