summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-12-17 18:00:58 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-12-17 18:00:58 +0000
commitc82f9de5dea919749ecf5601dba63fc335e6129a (patch)
treeab3bd8593d7df417620361024e0d2c243808d362 /dev-ml/ocamlnet
parentamd64 stable (diff)
downloadgentoo-2-c82f9de5dea919749ecf5601dba63fc335e6129a.tar.gz
gentoo-2-c82f9de5dea919749ecf5601dba63fc335e6129a.tar.bz2
gentoo-2-c82f9de5dea919749ecf5601dba63fc335e6129a.zip
Import a patch from Stefano Zacchiroli (debian) to force building with camlp5 now that is has findlib support, this fixes the build with ocaml 3.10
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'dev-ml/ocamlnet')
-rw-r--r--dev-ml/ocamlnet/ChangeLog9
-rw-r--r--dev-ml/ocamlnet/files/build_w_camlp5.dpatch188
-rw-r--r--dev-ml/ocamlnet/files/digest-ocamlnet-2.2.9-r13
-rw-r--r--dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild73
4 files changed, 272 insertions, 1 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index 2700486192c4..f26ec80602cb 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ml/ocamlnet
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.23 2007/11/16 15:11:58 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.24 2007/12/17 18:00:58 aballier Exp $
+
+*ocamlnet-2.2.9-r1 (17 Dec 2007)
+
+ 17 Dec 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/build_w_camlp5.dpatch, +ocamlnet-2.2.9-r1.ebuild:
+ Import a patch from Stefano Zacchiroli (debian) to force building with
+ camlp5 now that is has findlib support, this fixes the build with ocaml 3.10
16 Nov 2007; Steve Dibb <beandog@gentoo.org> ocamlnet-2.2.8.1.ebuild:
amd64 stable, bug 195535
diff --git a/dev-ml/ocamlnet/files/build_w_camlp5.dpatch b/dev-ml/ocamlnet/files/build_w_camlp5.dpatch
new file mode 100644
index 000000000000..885933479a73
--- /dev/null
+++ b/dev-ml/ocamlnet/files/build_w_camlp5.dpatch
@@ -0,0 +1,188 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## build_w_camlp5.dpatch by Stefano Zacchiroli <zack@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Enable building against camlp5 (the "classical" version of camlp4)
+
+@DPATCH@
+diff -urNad trunk~/Makefile.rules trunk/Makefile.rules
+--- trunk~/Makefile.rules 2007-07-31 18:20:57.000000000 +0200
++++ trunk/Makefile.rules 2007-09-08 12:42:33.000000000 +0200
+@@ -13,7 +13,7 @@
+ OCAMLFIND = ocamlfind
+ OCAMLYACC = ocamlyacc
+ OCAMLLEX = ocamllex
+-CAMLP4 = camlp4
++CAMLP4 = camlp5
+ OCAMLMKLIB = ocamlmklib
+ OCAMLDOC = $(OCAMLFIND) ocamldoc
+
+diff -urNad trunk~/src/equeue-gtk1/Makefile trunk/src/equeue-gtk1/Makefile
+--- trunk~/src/equeue-gtk1/Makefile 2007-07-31 18:20:59.000000000 +0200
++++ trunk/src/equeue-gtk1/Makefile 2007-09-08 12:42:33.000000000 +0200
+@@ -9,7 +9,7 @@
+
+ INCLUDES += $(INC_EQUEUE)
+
+-PP_OPTIONS = -syntax camlp4o -package camlp4.macro $(GTK_DEFINES)
++PP_OPTIONS = -syntax camlp5o -package camlp5.macro $(GTK_DEFINES)
+
+ include $(TOP_DIR)/Makefile.rules
+
+diff -urNad trunk~/src/equeue-gtk1/Makefile.pre trunk/src/equeue-gtk1/Makefile.pre
+--- trunk~/src/equeue-gtk1/Makefile.pre 2007-07-31 18:20:59.000000000 +0200
++++ trunk/src/equeue-gtk1/Makefile.pre 2007-09-08 12:42:33.000000000 +0200
+@@ -6,6 +6,6 @@
+
+ include ./Makefile.gtk
+
+-PP_OPTIONS = -syntax camlp4o -package camlp4.macro $(GTK_DEFINES)
++PP_OPTIONS = -syntax camlp5o -package camlp5.macro $(GTK_DEFINES)
+
+ include $(TOP_DIR)/Makefile.rules
+diff -urNad trunk~/src/equeue-gtk2/Makefile.pre trunk/src/equeue-gtk2/Makefile.pre
+--- trunk~/src/equeue-gtk2/Makefile.pre 2007-07-31 18:20:59.000000000 +0200
++++ trunk/src/equeue-gtk2/Makefile.pre 2007-09-08 12:42:33.000000000 +0200
+@@ -6,7 +6,7 @@
+
+ include ./Makefile.gtk
+
+-PP_OPTIONS = -syntax camlp4o -package camlp4.macro $(GTK_DEFINES)
++PP_OPTIONS = -syntax camlp5o -package camlp5.macro $(GTK_DEFINES)
+
+ include $(TOP_DIR)/Makefile.rules
+
+diff -urNad trunk~/src/nethttpd-for-netcgi1/Makefile trunk/src/nethttpd-for-netcgi1/Makefile
+--- trunk~/src/nethttpd-for-netcgi1/Makefile 2007-07-31 18:20:59.000000000 +0200
++++ trunk/src/nethttpd-for-netcgi1/Makefile 2007-09-08 12:42:33.000000000 +0200
+@@ -8,7 +8,7 @@
+ nethttpd_engine.mli nethttpd_services.mli nethttpd_plex.mli
+
+ INCLUDES += $(INC_EQUEUE) $(INC_NETSTRING) $(INC_NETCGI1) $(INC_NETPLEX)
+-PP_OPTIONS = -package "camlp4, camlp4.macro" -syntax "camlp4o"
++PP_OPTIONS = -package "camlp5, camlp5.macro" -syntax "camlp5o"
+
+ #PP_OPTIONS_FINDLIB += -ppopt "-DTesting"
+ # do this to enable test coverage calculations
+diff -urNad trunk~/src/nethttpd-for-netcgi1/Makefile.pre trunk/src/nethttpd-for-netcgi1/Makefile.pre
+--- trunk~/src/nethttpd-for-netcgi1/Makefile.pre 2007-09-08 12:42:32.000000000 +0200
++++ trunk/src/nethttpd-for-netcgi1/Makefile.pre 2007-09-08 12:42:33.000000000 +0200
+@@ -6,6 +6,6 @@
+
+ INSTALL_EXTRA +=
+
+-PP_OPTIONS = -package "camlp4, camlp4.macro" -syntax "camlp4o"
++PP_OPTIONS = -package "camlp5, camlp5.macro" -syntax "camlp5o"
+
+ include $(TOP_DIR)/Makefile.rules
+diff -urNad trunk~/src/nethttpd-for-netcgi1/nethttpd_types.mli trunk/src/nethttpd-for-netcgi1/nethttpd_types.mli
+--- trunk~/src/nethttpd-for-netcgi1/nethttpd_types.mli 2007-07-31 18:20:59.000000000 +0200
++++ trunk/src/nethttpd-for-netcgi1/nethttpd_types.mli 2007-09-08 12:43:01.000000000 +0200
+@@ -117,10 +117,10 @@
+ *)
+
+ class redirected_environment :
+- ?in_state : Netcgi1_compat.Netcgi_env.input_state ->
+- ?in_header : http_header ->
+- ?properties : (string * string) list ->
+- ?in_channel : Netchannels.in_obj_channel ->
++ ?in_state: Netcgi1_compat.Netcgi_env.input_state ->
++ ?in_header: http_header ->
++ ?properties: (string * string) list ->
++ ?in_channel: Netchannels.in_obj_channel ->
+ extended_environment ->
+ extended_environment
+ (** This class overlays the input-side containers of an existing environment.
+diff -urNad trunk~/src/nethttpd-for-netcgi2/Makefile trunk/src/nethttpd-for-netcgi2/Makefile
+--- trunk~/src/nethttpd-for-netcgi2/Makefile 2007-07-31 18:20:59.000000000 +0200
++++ trunk/src/nethttpd-for-netcgi2/Makefile 2007-09-08 12:42:33.000000000 +0200
+@@ -9,7 +9,7 @@
+ nethttpd_intro.txt
+
+ INCLUDES += $(INC_EQUEUE) $(INC_NETSTRING) $(INC_NETCGI2) $(INC_NETPLEX)
+-PP_OPTIONS = -package "camlp4, camlp4.macro" -syntax "camlp4o"
++PP_OPTIONS = -package "camlp5, camlp5.macro" -syntax "camlp5o"
+
+ #PP_OPTIONS_FINDLIB += -ppopt "-DTesting"
+ # do this to enable test coverage calculations
+diff -urNad trunk~/src/nethttpd-for-netcgi2/Makefile.pre trunk/src/nethttpd-for-netcgi2/Makefile.pre
+--- trunk~/src/nethttpd-for-netcgi2/Makefile.pre 2007-09-08 12:42:32.000000000 +0200
++++ trunk/src/nethttpd-for-netcgi2/Makefile.pre 2007-09-08 12:42:33.000000000 +0200
+@@ -15,7 +15,7 @@
+
+ INSTALL_EXTRA +=
+
+-PP_OPTIONS = -package "camlp4, camlp4.macro" -syntax "camlp4o"
++PP_OPTIONS = -package "camlp5, camlp5.macro" -syntax "camlp5o"
+
+ include $(TOP_DIR)/Makefile.rules
+
+diff -urNad trunk~/src/netplex/Makefile trunk/src/netplex/Makefile
+--- trunk~/src/netplex/Makefile 2007-07-31 18:21:00.000000000 +0200
++++ trunk/src/netplex/Makefile 2007-09-08 12:42:33.000000000 +0200
+@@ -19,7 +19,7 @@
+ ALLMT_EXTRA = netplex_mt.cmo
+ OPTMT_EXTRA = netplex_mt.cmx
+
+-PP_OPTIONS = -syntax camlp4o -package camlp4
++PP_OPTIONS = -syntax camlp5o -package camlp5
+
+ OCAMLC_OPTIONS_FOR_netplex_mt.ml = $(THREAD)
+ OCAMLOPT_OPTIONS_FOR_netplex_mt.ml = $(THREAD)
+diff -urNad trunk~/src/netplex/Makefile.pre trunk/src/netplex/Makefile.pre
+--- trunk~/src/netplex/Makefile.pre 2007-07-31 18:21:00.000000000 +0200
++++ trunk/src/netplex/Makefile.pre 2007-09-08 12:42:33.000000000 +0200
+@@ -9,7 +9,7 @@
+ INSTALL_EXTRA = netplex-packlist netplex_mt.cmo netplex_mt.cmx netplex_mt.o
+ INSTOTHER = install-netplex-admin
+
+-PP_OPTIONS = -syntax camlp4o -package camlp4
++PP_OPTIONS = -syntax camlp5o -package camlp5
+
+ include $(TOP_DIR)/Makefile.rules
+
+diff -urNad trunk~/src/netplex/netplex_config.ml trunk/src/netplex/netplex_config.ml
+--- trunk~/src/netplex/netplex_config.ml 2007-07-31 18:21:00.000000000 +0200
++++ trunk/src/netplex/netplex_config.ml 2007-09-08 12:42:33.000000000 +0200
+@@ -29,7 +29,7 @@
+ and semi_parse_tree_list =
+ parser
+ | [< 'Kwd ";";
+- tl = parse_tree_list;
++ tl = parse_tree_list
+ >] -> tl
+ | [< >] -> []
+
+@@ -47,7 +47,7 @@
+ and parse_rhs =
+ parser
+ | [< 'Kwd "=";
+- v = parse_param_value;
++ v = parse_param_value
+ >] ->
+ `Parameter v
+ | [< 'Kwd "{";
+diff -urNad trunk~/src/netstring/Makefile.def trunk/src/netstring/Makefile.def
+--- trunk~/src/netstring/Makefile.def 2007-07-31 18:20:58.000000000 +0200
++++ trunk/src/netstring/Makefile.def 2007-09-08 12:42:33.000000000 +0200
+@@ -46,7 +46,7 @@
+ netchannels_tut.txt netmime_tut.txt netsendmail_tut.txt \
+ netulex_tut.txt neturl_tut.txt
+
+-PP_OPTIONS = -package camlp4 -syntax camlp4o
++PP_OPTIONS = -package camlp5 -syntax camlp5o
+
+ OCAMLC_OPTIONS_FOR_netstring_mt.ml = $(THREAD)
+ OCAMLOPT_OPTIONS_FOR_netstring_mt.ml = $(THREAD)
+diff -urNad trunk~/src/netstring/netmime.ml trunk/src/netstring/netmime.ml
+--- trunk~/src/netstring/netmime.ml 2007-07-31 18:20:58.000000000 +0200
++++ trunk/src/netstring/netmime.ml 2007-09-08 12:42:33.000000000 +0200
+@@ -579,7 +579,7 @@
+ ;;
+
+
+-let storage ?ro ?fin : store -> (mime_body * out_obj_channel) = function
++let storage ?ro ?fin = function
+ `Memory ->
+ let body = new memory_mime_body_int ~ro_first:false ?ro "" in
+ let body_ch = body#open_value_wr() in
diff --git a/dev-ml/ocamlnet/files/digest-ocamlnet-2.2.9-r1 b/dev-ml/ocamlnet/files/digest-ocamlnet-2.2.9-r1
new file mode 100644
index 000000000000..9ae1f22a612c
--- /dev/null
+++ b/dev-ml/ocamlnet/files/digest-ocamlnet-2.2.9-r1
@@ -0,0 +1,3 @@
+MD5 3655e3be3bb2806e0a1f48bb7ce16fb3 ocamlnet-2.2.9.tar.gz 1877257
+RMD160 1299e1316e0547171089b0caaa9deb13c4c67c31 ocamlnet-2.2.9.tar.gz 1877257
+SHA256 134530a4357879e095bdbbb5f21f78634a16ef4d787eb151676b7fee7e4c0dc9 ocamlnet-2.2.9.tar.gz 1877257
diff --git a/dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild b/dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild
new file mode 100644
index 000000000000..8899ae4518fe
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild,v 1.1 2007/12/17 18:00:58 aballier Exp $
+
+inherit eutils findlib
+
+DESCRIPTION="Modules for OCaml application-level Internet protocols"
+HOMEPAGE="http://ocamlnet.sourceforge.net"
+SRC_URI="mirror://sourceforge/ocamlnet/${P}.tar.gz"
+
+LICENSE="as-is GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk ssl tk httpd"
+
+# the auth-dh compile flag has been disabled as well, since it depends on
+# ocaml-cryptgps, which is not available.
+
+DEPEND="!dev-ml/equeue
+ !dev-ml/rpc
+ !dev-ml/netclient
+ >=dev-ml/findlib-1.0
+ >=dev-ml/pcre-ocaml-5
+ >=dev-ml/camlp5-5.05
+ gtk? ( >=dev-ml/lablgtk-2 )
+ ssl? ( dev-ml/ocaml-ssl )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use tk && ! built_with_use 'dev-lang/ocaml' tk ;
+ then die "If you want to enable tcl/tk, you need to rebuild dev-lang/ocaml with the 'tk' USE flag";
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/build_w_camlp5.dpatch"
+}
+
+ocamlnet_use_with() {
+ if use $1; then
+ echo "-with-$2"
+ else
+ echo "-without-$2"
+ fi
+}
+
+ocamlnet_use_enable() {
+ if use $1; then
+ echo "-enable-$2"
+ else
+ echo "-disable-$2"
+ fi
+}
+
+src_compile() {
+ ./configure \
+ -bindir /usr/bin \
+ -datadir /usr/share/${PN} \
+ $(ocamlnet_use_enable gtk gtk2) \
+ $(ocamlnet_use_enable ssl ssl) \
+ $(ocamlnet_use_enable tk tcl) \
+ $(ocamlnet_use_with httpd nethttpd) \
+ || die "Error : econf failed!"
+
+ emake -j1 all opt || die "make failed"
+}
+
+src_install() {
+ findlib_src_install
+}