summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-12-13 14:21:44 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-12-13 14:21:44 +0000
commitb7f66d736f124eef363fd55dd49eb213d3b74c1c (patch)
treec4b05103885c29fc8bf205ce17aa1531b8498bb2 /dev-lua/luafilesystem
parentProperly use python.eclass. Add "readline", "ssl", "threads" and "xml" USE fl... (diff)
downloadgentoo-2-b7f66d736f124eef363fd55dd49eb213d3b74c1c.tar.gz
gentoo-2-b7f66d736f124eef363fd55dd49eb213d3b74c1c.tar.bz2
gentoo-2-b7f66d736f124eef363fd55dd49eb213d3b74c1c.zip
Version bumped, bug #348131. The patch is submitted by Bernd Lommerzheim. respect LDFLAGS, bug #336966.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-lua/luafilesystem')
-rw-r--r--dev-lua/luafilesystem/ChangeLog8
-rw-r--r--dev-lua/luafilesystem/luafilesystem-1.5.0.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-lua/luafilesystem/ChangeLog b/dev-lua/luafilesystem/ChangeLog
index b7a3428ae2e7..183f5fc6be27 100644
--- a/dev-lua/luafilesystem/ChangeLog
+++ b/dev-lua/luafilesystem/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lua/luafilesystem
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/luafilesystem/ChangeLog,v 1.1 2010/11/05 23:12:31 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luafilesystem/ChangeLog,v 1.2 2010/12/13 14:21:44 matsuu Exp $
+
+*luafilesystem-1.5.0 (13 Dec 2010)
+
+ 13 Dec 2010; MATSUU Takuto <matsuu@gentoo.org> +luafilesystem-1.5.0.ebuild:
+ Version bumped, bug #348131. The patch is submitted by Bernd Lommerzheim.
+ respect LDFLAGS, bug #336966.
05 Nov 2010; Rafael G. Martins <rafaelmartins@gentoo.org>
+luafilesystem-1.4.1.ebuild, +luafilesystem-1.4.2.ebuild, +metadata.xml:
diff --git a/dev-lua/luafilesystem/luafilesystem-1.5.0.ebuild b/dev-lua/luafilesystem/luafilesystem-1.5.0.ebuild
new file mode 100644
index 000000000000..4de678950029
--- /dev/null
+++ b/dev-lua/luafilesystem/luafilesystem-1.5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luafilesystem/luafilesystem-1.5.0.ebuild,v 1.1 2010/12/13 14:21:44 matsuu Exp $
+
+EAPI="3"
+inherit multilib toolchain-funcs
+
+DESCRIPTION="File System Library for the Lua Programming Language"
+HOMEPAGE="http://keplerproject.github.com/luafilesystem/"
+SRC_URI="https://github.com/downloads/keplerproject/luafilesystem/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/lua-5.1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "s|/usr/local|/usr|" \
+ -e "s|/lib|/$(get_libdir)|" \
+ -e "s|-O2|${CFLAGS}|" \
+ -e "/^LIB_OPTION/s|= |= ${LDFLAGS} |" \
+ -e "s|gcc|$(tc-getCC)|" \
+ config || die
+}
+
+src_install() {
+ emake PREFIX="${ED}usr" install || die
+ dodoc README || die
+ dohtml doc/us/* || die
+}