summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2014-03-09 14:16:24 +0000
committerAndrey Grozin <grozin@gentoo.org>2014-03-09 14:16:24 +0000
commitcc8f0d316618a795da1c29c16747fbca63ede5d0 (patch)
tree82b841fae95eac068a04b92d1d543e73a4ac5f03 /dev-lisp
parentbump, remove non-python-r1 ebuilds (diff)
downloadgentoo-2-cc8f0d316618a795da1c29c16747fbca63ede5d0.tar.gz
gentoo-2-cc8f0d316618a795da1c29c16747fbca63ede5d0.tar.bz2
gentoo-2-cc8f0d316618a795da1c29c16747fbca63ede5d0.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/asdf/ChangeLog9
-rw-r--r--dev-lisp/asdf/asdf-3.0.3.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/dev-lisp/asdf/ChangeLog b/dev-lisp/asdf/ChangeLog
index b2a5b1afc8b0..2dc24245b141 100644
--- a/dev-lisp/asdf/ChangeLog
+++ b/dev-lisp/asdf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/asdf
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/asdf/ChangeLog,v 1.15 2013/12/12 09:52:38 nimiux Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/asdf/ChangeLog,v 1.16 2014/03/09 14:16:24 grozin Exp $
+
+*asdf-3.0.3 (09 Mar 2014)
+
+ 09 Mar 2014; Andrey Grozin <grozin@gentoo.org> +asdf-3.0.3.ebuild:
+ Version bump
12 Dec 2013; Chema Alonso <nimiux@gentoo.org> asdf-3.0.2.4.ebuild:
Revoke stable for amd64 wrt bug #485632
diff --git a/dev-lisp/asdf/asdf-3.0.3.ebuild b/dev-lisp/asdf/asdf-3.0.3.ebuild
new file mode 100644
index 000000000000..7429e6f933f1
--- /dev/null
+++ b/dev-lisp/asdf/asdf-3.0.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/asdf/asdf-3.0.3.ebuild,v 1.1 2014/03/09 14:16:24 grozin Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="ASDF is Another System Definition Facility for Common Lisp"
+HOMEPAGE="http://common-lisp.net/project/asdf/"
+SRC_URI="http://common-lisp.net/project/${PN}/archives/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+SLOT="0/${PVR}"
+
+DEPEND="!dev-lisp/cl-${PN}
+ !dev-lisp/asdf-binary-locations
+ !dev-lisp/gentoo-init
+ !<dev-lisp/asdf-2.33-r3
+ doc? ( virtual/texi2dvi )"
+RDEPEND=""
+PDEPEND="~dev-lisp/uiop-${PV}"
+
+S="${WORKDIR}"
+
+src_compile() {
+ make
+ use doc && make doc
+}
+
+src_install() {
+ insinto /usr/share/common-lisp/source/${PN}
+ doins -r build version.lisp-expr
+ dodoc README TODO
+ dohtml doc/*.{html,css,ico,png}
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/${PN}.pdf
+ fi
+
+ insinto /etc/common-lisp
+ doins "${FILESDIR}"/gentoo-init.lisp "${FILESDIR}"/source-registry.conf
+}