summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2013-08-09 12:33:51 +0000
committerAndrey Grozin <grozin@gentoo.org>2013-08-09 12:33:51 +0000
commit7af16181d6aca975d0e70108eb68ce2ffffe4ce4 (patch)
tree67c5f3e2af8f6363598a49e5936505113892e15e /dev-lisp/uiop
parentVersion bump (diff)
downloadgentoo-2-7af16181d6aca975d0e70108eb68ce2ffffe4ce4.tar.gz
gentoo-2-7af16181d6aca975d0e70108eb68ce2ffffe4ce4.tar.bz2
gentoo-2-7af16181d6aca975d0e70108eb68ce2ffffe4ce4.zip
Version bump
(Portage version: 2.2.0_alpha195/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'dev-lisp/uiop')
-rw-r--r--dev-lisp/uiop/ChangeLog7
-rw-r--r--dev-lisp/uiop/uiop-3.0.2.1.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-lisp/uiop/ChangeLog b/dev-lisp/uiop/ChangeLog
index e33774dfa47d..5c5ecbc80a4d 100644
--- a/dev-lisp/uiop/ChangeLog
+++ b/dev-lisp/uiop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/uiop
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/uiop/ChangeLog,v 1.3 2013/05/19 05:14:03 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/uiop/ChangeLog,v 1.4 2013/08/09 12:33:51 grozin Exp $
+
+*uiop-3.0.2.1 (09 Aug 2013)
+
+ 09 Aug 2013; Andrey Grozin <grozin@gentoo.org> +uiop-3.0.2.1.ebuild:
+ Version bump
*uiop-3.0.1 (19 May 2013)
diff --git a/dev-lisp/uiop/uiop-3.0.2.1.ebuild b/dev-lisp/uiop/uiop-3.0.2.1.ebuild
new file mode 100644
index 000000000000..6de482b819db
--- /dev/null
+++ b/dev-lisp/uiop/uiop-3.0.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/uiop/uiop-3.0.2.1.ebuild,v 1.1 2013/08/09 12:33:51 grozin Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="UIOP is a portability layer spun off ASDF3"
+HOMEPAGE="http://common-lisp.net/project/asdf/"
+SRC_URI="http://common-lisp.net/project/asdf/archives/asdf-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="~dev-lisp/asdf-${PV}"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ insinto /usr/share/common-lisp/source/${PN}
+ doins -r contrib *.lisp ../version.lisp-expr uiop.asd asdf-driver.asd
+ dodir /usr/share/common-lisp/systems
+ dosym /usr/share/common-lisp/source/${PN}/uiop.asd /usr/share/common-lisp/systems/uiop.asd
+ dosym /usr/share/common-lisp/source/${PN}/asdf-driver.asd /usr/share/common-lisp/systems/asdf-driver.asd
+}