summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2013-05-29 13:24:25 +0000
committerAndrey Grozin <grozin@gentoo.org>2013-05-29 13:24:25 +0000
commit4295e1ef3038b4cff846d96fd9f3c7d0178c7418 (patch)
treeb99bd4403d2a06d01e8923a424ef4d1b56961bcc /dev-lisp/ecls
parentFix typo in ChangeLog (diff)
downloadgentoo-2-4295e1ef3038b4cff846d96fd9f3c7d0178c7418.tar.gz
gentoo-2-4295e1ef3038b4cff846d96fd9f3c7d0178c7418.tar.bz2
gentoo-2-4295e1ef3038b4cff846d96fd9f3c7d0178c7418.zip
Version bump; fixing #471364 and #468308 in 12.12.1
(Portage version: 2.2.0_alpha177/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'dev-lisp/ecls')
-rw-r--r--dev-lisp/ecls/ChangeLog10
-rw-r--r--dev-lisp/ecls/ecls-12.12.1-r5.ebuild87
-rw-r--r--dev-lisp/ecls/ecls-13.5.1.ebuild (renamed from dev-lisp/ecls/ecls-12.12.1-r4.ebuild)6
-rw-r--r--dev-lisp/ecls/files/12.12.1-asdf.patch12
-rw-r--r--dev-lisp/ecls/files/13.5.1-headers-gentoo.patch13
5 files changed, 124 insertions, 4 deletions
diff --git a/dev-lisp/ecls/ChangeLog b/dev-lisp/ecls/ChangeLog
index a7012d7a97a3..c2a0a362b0d4 100644
--- a/dev-lisp/ecls/ChangeLog
+++ b/dev-lisp/ecls/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lisp/ecls
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.45 2013/04/20 14:33:37 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.46 2013/05/29 13:24:25 grozin Exp $
+
+*ecls-13.5.1 (29 May 2013)
+*ecls-12.12.1-r5 (29 May 2013)
+
+ 29 May 2013; Andrey Grozin <grozin@gentoo.org> -ecls-12.12.1-r4.ebuild,
+ +ecls-12.12.1-r5.ebuild, +ecls-13.5.1.ebuild, +files/12.12.1-asdf.patch,
+ +files/13.5.1-headers-gentoo.patch:
+ Version bump; fixing #471364 and #468308 in 12.12.1
*ecls-12.12.1-r4 (20 Apr 2013)
diff --git a/dev-lisp/ecls/ecls-12.12.1-r5.ebuild b/dev-lisp/ecls/ecls-12.12.1-r5.ebuild
new file mode 100644
index 000000000000..213c5f48b5ce
--- /dev/null
+++ b/dev-lisp/ecls/ecls-12.12.1-r5.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-12.12.1-r5.ebuild,v 1.1 2013/05/29 13:24:25 grozin Exp $
+
+EAPI=5
+inherit eutils multilib
+
+MY_P=ecl-${PV}
+
+DESCRIPTION="ECL is an embeddable Common Lisp implementation."
+HOMEPAGE="http://ecls.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
+RESTRICT="mirror"
+
+LICENSE="BSD LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug emacs gengc precisegc sse +threads +unicode X"
+
+CDEPEND="dev-libs/gmp
+ virtual/libffi
+ >=dev-libs/boehm-gc-7.1[threads?]
+ >=dev-lisp/asdf-2.33-r3:="
+DEPEND="${CDEPEND}
+ app-text/texi2html
+ emacs? ( virtual/emacs >=app-admin/eselect-emacs-1.12 )"
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup () {
+ if use gengc || use precisegc ; then
+ ewarn "You have enabled the generational garbage collector or"
+ ewarn "the precise collection routines. These features are not very stable"
+ ewarn "at the moment and may cause crashes."
+ ewarn "Don't enable them unless you know what you're doing."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-headers-gentoo.patch
+ epatch "${FILESDIR}"/${PV}-asdf.patch
+ cp "${EPREFIX}"/usr/share/common-lisp/source/asdf/build/asdf.lisp contrib/asdf/ || die
+}
+
+src_configure() {
+ econf \
+ --with-system-gmp \
+ --enable-boehm=system \
+ --enable-longdouble \
+ --with-dffi \
+ $(use_enable gengc) \
+ $(use_enable precisegc) \
+ $(use_with debug debug-cflags) \
+ $(use_with sse) \
+ $(use_enable threads) \
+ $(use_with threads __thread) \
+ $(use_enable unicode) \
+ $(use_with X x) \
+ $(use_with X clx)
+}
+
+src_compile() {
+ if use emacs; then
+ local ETAGS=$(eselect --brief etags list | sed -ne '/emacs/{p;q}')
+ [[ -n ${ETAGS} ]] || die "No etags implementation found"
+ pushd build > /dev/null || die
+ emake ETAGS=${ETAGS} TAGS
+ popd > /dev/null
+ else
+ touch build/TAGS
+ fi
+
+ #parallel make fails
+ emake -j1 || die "Compilation failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc ANNOUNCEMENT Copyright
+ dodoc "${FILESDIR}"/README.Gentoo
+ pushd build/doc
+ newman ecl.man ecl.1
+ newman ecl-config.man ecl-config.1
+ popd
+}
diff --git a/dev-lisp/ecls/ecls-12.12.1-r4.ebuild b/dev-lisp/ecls/ecls-13.5.1.ebuild
index b52cf10f3d07..5d2f4a73b8b6 100644
--- a/dev-lisp/ecls/ecls-12.12.1-r4.ebuild
+++ b/dev-lisp/ecls/ecls-13.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-12.12.1-r4.ebuild,v 1.1 2013/04/20 14:33:37 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-13.5.1.ebuild,v 1.1 2013/05/29 13:24:25 grozin Exp $
EAPI=5
inherit eutils multilib
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
RESTRICT="mirror"
LICENSE="BSD LGPL-2"
-SLOT="0"
+SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="debug emacs gengc precisegc sse +threads +unicode X"
@@ -39,7 +39,7 @@ pkg_setup () {
src_prepare() {
epatch "${FILESDIR}"/${PV}-headers-gentoo.patch
- cp /usr/share/common-lisp/source/asdf/build/asdf.lisp contrib/asdf/ || die
+ cp "${EPREFIX}"/usr/share/common-lisp/source/asdf/build/asdf.lisp contrib/asdf/ || die
}
src_configure() {
diff --git a/dev-lisp/ecls/files/12.12.1-asdf.patch b/dev-lisp/ecls/files/12.12.1-asdf.patch
new file mode 100644
index 000000000000..344555ccfb44
--- /dev/null
+++ b/dev-lisp/ecls/files/12.12.1-asdf.patch
@@ -0,0 +1,12 @@
+--- src/compile.lsp.in.orig 2013-05-23 22:24:01.858778565 +1200
++++ src/compile.lsp.in 2013-05-23 22:24:20.478785499 +1200
+@@ -205,8 +205,7 @@
+ ;;;
+ #+WANTS-ASDF
+ (build-module "asdf"
+- '("ext:asdf;asdf.lisp"
+- "ext:asdf;asdf-bundle.lisp")
++ '("ext:asdf;asdf.lisp")
+ :dir "build:ext;"
+ :prefix "EXT"
+ :builtin #+:BUILTIN-ASDF t #-:BUILTIN-ASDF nil)
diff --git a/dev-lisp/ecls/files/13.5.1-headers-gentoo.patch b/dev-lisp/ecls/files/13.5.1-headers-gentoo.patch
new file mode 100644
index 000000000000..958b948bac41
--- /dev/null
+++ b/dev-lisp/ecls/files/13.5.1-headers-gentoo.patch
@@ -0,0 +1,13 @@
+diff -r -U1 ecl-13.5.1.orig/src/h/object.h ecl-13.5.1/src/h/object.h
+--- ecl-13.5.1.orig/src/h/object.h 2013-05-28 03:37:36.000000000 +0700
++++ ecl-13.5.1/src/h/object.h 2013-05-29 19:23:34.000000000 +0700
+@@ -25,4 +25,9 @@
+
++#ifndef TRUE
+ #define TRUE 1 /* boolean true value */
++#endif
++
++#ifndef FALSE
+ #define FALSE 0 /* boolean false value */
++#endif
+