summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2015-01-19 12:09:25 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2015-01-19 12:09:25 +0000
commitf6135958c1ca4d47f49e0231aa941fcecb6eab8b (patch)
tree25ac69195184e00d8f40646f4e32510ada5d6ce9 /dev-libs
parentAdd live 1.3 branch ebuild. (diff)
downloadgentoo-2-f6135958c1ca4d47f49e0231aa941fcecb6eab8b.tar.gz
gentoo-2-f6135958c1ca4d47f49e0231aa941fcecb6eab8b.tar.bz2
gentoo-2-f6135958c1ca4d47f49e0231aa941fcecb6eab8b.zip
version bump fix #536772 thx to Thomas D.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/liblogging/ChangeLog9
-rw-r--r--dev-libs/liblogging/liblogging-1.0.5.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-libs/liblogging/ChangeLog b/dev-libs/liblogging/ChangeLog
index 4166cc682a05..81971cf495de 100644
--- a/dev-libs/liblogging/ChangeLog
+++ b/dev-libs/liblogging/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/liblogging
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/liblogging/ChangeLog,v 1.6 2014/10/05 07:24:54 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liblogging/ChangeLog,v 1.7 2015/01/19 12:09:25 ultrabug Exp $
+
+*liblogging-1.0.5 (19 Jan 2015)
+
+ 19 Jan 2015; Ultrabug <ultrabug@gentoo.org> +liblogging-1.0.5.ebuild:
+ version bump fix #536772 thx to Thomas D.
05 Oct 2014; Agostino Sarubbo <ago@gentoo.org> liblogging-1.0.4.ebuild:
Stable for x86, wrt bug #524290
diff --git a/dev-libs/liblogging/liblogging-1.0.5.ebuild b/dev-libs/liblogging/liblogging-1.0.5.ebuild
new file mode 100644
index 000000000000..a1ea46a71bc1
--- /dev/null
+++ b/dev-libs/liblogging/liblogging-1.0.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liblogging/liblogging-1.0.5.ebuild,v 1.1 2015/01/19 12:09:25 ultrabug Exp $
+
+EAPI=5
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Liblogging is an easy to use, portable, open source library for system logging"
+HOMEPAGE="http://www.liblogging.org"
+SRC_URI="http://download.rsyslog.com/liblogging/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+IUSE="rfc3195 static-libs +stdlog systemd"
+
+RDEPEND="systemd? ( sys-apps/systemd )"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( ChangeLog )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable rfc3195)
+ $(use_enable stdlog)
+ $(use_enable systemd journal)
+ )
+ autotools-utils_src_configure
+}