summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-19 12:01:01 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-19 12:01:01 +0000
commitec9aeaf71ab1b2421ca4604d8c60d0df1b64e641 (patch)
tree20c86cf97f09d5889080c25aba72aef7c6d26c74 /dev-libs
parentDelete older ebuild. (diff)
downloadgentoo-2-ec9aeaf71ab1b2421ca4604d8c60d0df1b64e641.tar.gz
gentoo-2-ec9aeaf71ab1b2421ca4604d8c60d0df1b64e641.tar.bz2
gentoo-2-ec9aeaf71ab1b2421ca4604d8c60d0df1b64e641.zip
Version bump.
(Portage version: 15835-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/icu/ChangeLog8
-rw-r--r--dev-libs/icu/icu-4.4.ebuild71
2 files changed, 78 insertions, 1 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index 10c2263f32a9..443bc3cb7b82 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/icu
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.104 2010/03/07 15:50:54 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.105 2010/03/19 12:01:01 arfrever Exp $
+
+*icu-4.4 (19 Mar 2010)
+
+ 19 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -icu-4.4_rc1.ebuild, +icu-4.4.ebuild:
+ Version bump.
*icu-4.4_rc1 (07 Mar 2010)
diff --git a/dev-libs/icu/icu-4.4.ebuild b/dev-libs/icu/icu-4.4.ebuild
new file mode 100644
index 000000000000..7d06a8c5a796
--- /dev/null
+++ b/dev-libs/icu/icu-4.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-4.4.ebuild,v 1.1 2010/03/19 12:01:01 arfrever Exp $
+
+EAPI="3"
+
+inherit flag-o-matic versionator
+
+DESCRIPTION="International Components for Unicode"
+HOMEPAGE="http://www.icu-project.org/ http://ibm.com/software/globalization/icu/"
+
+BASEURI="http://download.icu-project.org/files/${PN}4c/${PV}"
+DOCS_PV="$(get_version_component_range 1-2)"
+DOCS_BASEURI="http://download.icu-project.org/files/${PN}4c/${DOCS_PV}"
+DOCS_PV="${DOCS_PV/./_}"
+SRCPKG="${PN}4c-${PV//./_}-src.tgz"
+APIDOCS="${PN}4c-${DOCS_PV}-docs.zip"
+
+SRC_URI="${BASEURI}/${SRCPKG}
+ doc? ( ${DOCS_BASEURI}/${APIDOCS} )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples"
+
+DEPEND="doc? ( app-arch/unzip )"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}/source"
+
+src_unpack() {
+ unpack ${SRCPKG}
+ if use doc; then
+ mkdir apidocs
+ pushd apidocs > /dev/null
+ unpack ${APIDOCS}
+ popd > /dev/null
+ fi
+}
+
+src_prepare() {
+ # Do not hardcode used CFLAGS, LDFLAGS etc. into icu-config
+ # Bug 202059
+ # https://bugs.icu-project.org/trac/ticket/6102
+ for x in ARFLAGS CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
+ sed -i -e "/^${x} =.*/s:@${x}@::" "config/Makefile.inc.in" || die "sed failed"
+ done
+}
+
+src_configure() {
+ econf \
+ --enable-static \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_test() {
+ emake check || die "emake check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dohtml ../readme.html
+ dodoc ../unicode-license.txt
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html/apidocs
+ doins -r "${WORKDIR}"/apidocs/*
+ fi
+}