summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-29 00:44:57 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-29 00:44:57 +0000
commitbf6e60d0892a63bb39cac84a8ebd494cbb699d19 (patch)
tree2d8de6bda5dbbb3c837bff4cbc1bc10c5ef50b3d /dev-libs
parentManifest recommit (diff)
downloadgentoo-2-bf6e60d0892a63bb39cac84a8ebd494cbb699d19.tar.gz
gentoo-2-bf6e60d0892a63bb39cac84a8ebd494cbb699d19.tar.bz2
gentoo-2-bf6e60d0892a63bb39cac84a8ebd494cbb699d19.zip
Moved to sci-libs/torch.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/torch/ChangeLog13
-rw-r--r--dev-libs/torch/Manifest4
-rw-r--r--dev-libs/torch/files/digest-torch-32
-rw-r--r--dev-libs/torch/metadata.xml5
-rw-r--r--dev-libs/torch/torch-3.ebuild70
5 files changed, 0 insertions, 94 deletions
diff --git a/dev-libs/torch/ChangeLog b/dev-libs/torch/ChangeLog
deleted file mode 100644
index 33d159163eea..000000000000
--- a/dev-libs/torch/ChangeLog
+++ /dev/null
@@ -1,13 +0,0 @@
-# ChangeLog for dev-libs/torch
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/torch/ChangeLog,v 1.3 2004/07/02 04:55:59 eradicator Exp $
-
- 01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> torch-3.ebuild:
- virtual/glibc -> virtual/libc
-
-*torch-3 (17 Jun 2004)
-
- 17 Jun 2004; Patrick Kursawe <phosphan@gentoo.org> metadata.xml,
- torch-3.ebuild:
- Initial version.
-
diff --git a/dev-libs/torch/Manifest b/dev-libs/torch/Manifest
deleted file mode 100644
index dec5d9d31da4..000000000000
--- a/dev-libs/torch/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-MD5 07da4b452aecfa80fc8bfb412cfc96de ChangeLog 440
-MD5 d1e8aaf081a41639772ad32e8127b95c torch-3.ebuild 1933
-MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 b783f0f266b5452761370caf0b78e7f3 files/digest-torch-3 117
diff --git a/dev-libs/torch/files/digest-torch-3 b/dev-libs/torch/files/digest-torch-3
deleted file mode 100644
index 44752ac23b2e..000000000000
--- a/dev-libs/torch/files/digest-torch-3
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 73ecbab0862a6d98aa6a602a89b2ceb6 Torch3src.tgz 775622
-MD5 3e04241c606ddeb6cf0f6a5bc4b50a2e Torch3doc.tgz 1622648
diff --git a/dev-libs/torch/metadata.xml b/dev-libs/torch/metadata.xml
deleted file mode 100644
index b229aec85b8f..000000000000
--- a/dev-libs/torch/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>sci</herd>
-</pkgmetadata>
diff --git a/dev-libs/torch/torch-3.ebuild b/dev-libs/torch/torch-3.ebuild
deleted file mode 100644
index 25db4d658de6..000000000000
--- a/dev-libs/torch/torch-3.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/torch/torch-3.ebuild,v 1.5 2004/12/13 14:52:48 phosphan Exp $
-
-inherit toolchain-funcs
-
-DESCRIPTION="machine-learning library, written in simple C++"
-HOMEPAGE="http://www.torch.ch/"
-SRC_URI="http://www.torch.ch/archives/Torch${PV}src.tgz
- doc? ( http://www.torch.ch/archives/Torch3doc.tgz )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86"
-IUSE="doc debug"
-
-DEPEND="virtual/libc"
-
-S=${WORKDIR}/Torch${PV}
-
-torch_packages="convolutions datasets decoder distributions gradients kernels matrix nonparametrics speech"
-
-src_compile() {
- local shalldebug="OPT"
- use debug && shalldebug="DBG"
- cp config/Makefile_options_Linux .
- sed -i \
- -e "s:^PACKAGES.*:PACKAGES = ${torch_packages}:" \
- -e "s:^DEBUG.*:DEBUG = ${shalldebug}:" \
- -e "s:^CFLAGS_OPT_FLOAT.*:CFLAGS_OPT_FLOAT = -Wall ${CFLAGS} -ffast-math -malign-double:" \
- Makefile_options_Linux
-
- make depend
- emake || die "emake failed"
-}
-
-src_install() {
- dolib lib/*/*.a
- dodir /usr/include/torch
- insinto /usr/include/torch
- for directory in core ${torch_packages}; do
- doins ${directory}/*.h
- done
- # prepare the options Makefile
- sed -i \
- -e 's:^LIBS_DIR.*:LIBS_DIR=/usr/lib:' \
- -e 's|^INCS := .*|INCS := -I /usr/include/torch $(MYINCS)|' \
- -e '/^INCS +=/c\' \
- Makefile_options_Linux
- dodir /usr/share/${PN}
- insinto /usr/share/${PN}
- doins Makefile_options_Linux
- dodoc LICENSE
- dodir /usr/share/doc/${PF}
- insinto /usr/share/doc/${PF}
- cp -a examples ${D}/usr/share/doc/${PF}
- cd ${D}/usr/share/doc/${PF}
- sed -i \
- -e 's|^TORCHDIR.*|TORCHDIR := /usr/share/torch|' \
- -e '/MAKE/c\' -e '/VERSION_KEY/c\' \
- examples/*/Makefile
- for ex in examples/*/Makefile; do
- echo -e '\t$(CC) $(CFLAGS_$(MODE)) $(INCS) -o $@ $< $(LIBS)' >> ${ex}
- done
- if use doc; then
- cd ${WORKDIR}/docs
- doins *.pdf
- dohtml -r manual/.
- fi
-}