summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@gentoo.org>2006-04-12 22:14:26 +0000
committerEmanuele Giaquinta <exg@gentoo.org>2006-04-12 22:14:26 +0000
commitb7fb82060829ee34934b77f25b3d120197009471 (patch)
treecc2a866663b262146bc39cfb02e8a78d5b9ae596 /dev-libs
parentVersion bump for 2.14.1 (diff)
downloadgentoo-2-b7fb82060829ee34934b77f25b3d120197009471.tar.gz
gentoo-2-b7fb82060829ee34934b77f25b3d120197009471.tar.bz2
gentoo-2-b7fb82060829ee34934b77f25b3d120197009471.zip
Various fixes for the tests suite.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/expat/ChangeLog8
-rw-r--r--dev-libs/expat/expat-2.0.0.ebuild20
-rw-r--r--dev-libs/expat/files/expat-2.0.0-test-64bit.patch11
3 files changed, 24 insertions, 15 deletions
diff --git a/dev-libs/expat/ChangeLog b/dev-libs/expat/ChangeLog
index 681c0a600150..3b166d277f40 100644
--- a/dev-libs/expat/ChangeLog
+++ b/dev-libs/expat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/expat
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/ChangeLog,v 1.51 2006/03/30 15:03:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/ChangeLog,v 1.52 2006/04/12 22:14:26 exg Exp $
+
+ 12 Apr 2006; Emanuele Giaquinta <exg@gentoo.org>
+ +files/expat-2.0.0-test-64bit.patch, expat-2.0.0.ebuild:
+ Remove dep on dev-libs/check since it's not needed anymore. Use eautoreconf
+ instead of elibtoolize to fix test linking. Add patch to fix test build on 64
+ bit hosts (thanks Flameeyes).
30 Mar 2006; Diego Pettenò <flameeyes@gentoo.org> expat-1.95.8.ebuild,
expat-2.0.0.ebuild:
diff --git a/dev-libs/expat/expat-2.0.0.ebuild b/dev-libs/expat/expat-2.0.0.ebuild
index a2a519748ac7..6ab4f210185f 100644
--- a/dev-libs/expat/expat-2.0.0.ebuild
+++ b/dev-libs/expat/expat-2.0.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-2.0.0.ebuild,v 1.3 2006/03/30 15:03:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-2.0.0.ebuild,v 1.4 2006/04/12 22:14:26 exg Exp $
-inherit libtool multilib
+inherit autotools
DESCRIPTION="XML parsing libraries"
HOMEPAGE="http://expat.sourceforge.net/"
@@ -11,24 +11,16 @@ SRC_URI="mirror://sourceforge/expat/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="test"
+IUSE=""
-DEPEND="test? ( >=dev-libs/check-0.8 )"
+DEPEND=""
RDEPEND=""
src_unpack() {
unpack ${A}
cd "${S}"
- elibtoolize
-}
-
-src_test() {
- if ! use test && [[ -z $(best_version dev-libs/check) ]] ; then
- ewarn "You dont have USE=test and dev-libs/check is not installed."
- ewarn "src_test will be skipped."
- return 0
- fi
- make check || die "make check failed"
+ epatch ${FILESDIR}/${P}-test-64bit.patch
+ eautoreconf
}
src_install() {
diff --git a/dev-libs/expat/files/expat-2.0.0-test-64bit.patch b/dev-libs/expat/files/expat-2.0.0-test-64bit.patch
new file mode 100644
index 000000000000..07d7b643089d
--- /dev/null
+++ b/dev-libs/expat/files/expat-2.0.0-test-64bit.patch
@@ -0,0 +1,11 @@
+--- tests/runtests.c.old 2006-04-12 11:32:20.616132185 +0200
++++ tests/runtests.c 2006-04-12 11:32:27.152122381 +0200
+@@ -1176,7 +1176,7 @@
+ const XML_Char *systemId,
+ const XML_Char *publicId)
+ {
+- int callno = 1 + (int)XML_GetUserData(parser);
++ long callno = 1 + (int)XML_GetUserData(parser);
+ char *text;
+ XML_Parser p2;
+