summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-04-18 23:24:39 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-04-18 23:24:39 +0000
commit3d8d44767cd19db873b2796821271460a23d7e6a (patch)
treec8bcf9cb016ae622a414d5d6bd1dbc8bfe493e42 /dev-libs
parentRemove patch_prepare() as its purpose is no longer relevant. Fixes bug #266481. (diff)
downloadgentoo-2-3d8d44767cd19db873b2796821271460a23d7e6a.tar.gz
gentoo-2-3d8d44767cd19db873b2796821271460a23d7e6a.tar.bz2
gentoo-2-3d8d44767cd19db873b2796821271460a23d7e6a.zip
Version bump. Fixes GMP version detection and tests not being run.
- make watchdog library optional - build tests in parallel since they take forever - pch USE flag (Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/ppl/ChangeLog11
-rw-r--r--dev-libs/ppl/metadata.xml1
-rw-r--r--dev-libs/ppl/ppl-0.10.1.ebuild54
-rw-r--r--dev-libs/ppl/ppl-0.10.2.ebuild64
4 files changed, 75 insertions, 55 deletions
diff --git a/dev-libs/ppl/ChangeLog b/dev-libs/ppl/ChangeLog
index 481efb2ce4a5..8ffdf653597f 100644
--- a/dev-libs/ppl/ChangeLog
+++ b/dev-libs/ppl/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/ppl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ChangeLog,v 1.8 2009/04/14 23:30:11 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ChangeLog,v 1.9 2009/04/18 23:24:39 dirtyepic Exp $
+
+*ppl-0.10.2 (18 Apr 2009)
+
+ 18 Apr 2009; Ryan Hill <dirtyepic@gentoo.org> metadata.xml,
+ -ppl-0.10.1.ebuild, +ppl-0.10.2.ebuild:
+ Version bump. Fixes GMP version detection and tests not being run.
+ - make watchdog library optional
+ - build tests in parallel since they take forever
+ - pch USE flag
*ppl-0.10.1 (14 Apr 2009)
diff --git a/dev-libs/ppl/metadata.xml b/dev-libs/ppl/metadata.xml
index 3d03e7f80e7c..1194b377ae82 100644
--- a/dev-libs/ppl/metadata.xml
+++ b/dev-libs/ppl/metadata.xml
@@ -8,5 +8,6 @@
</maintainer>
<use>
<flag name='prolog'>Build SWI Prolog interface</flag>
+ <flag name='watchdog'>Build the PPL Watchdog library - a C++ library for multiple, concurrent watchdog timers</flag>
</use>
</pkgmetadata>
diff --git a/dev-libs/ppl/ppl-0.10.1.ebuild b/dev-libs/ppl/ppl-0.10.1.ebuild
deleted file mode 100644
index c66625c8b1fe..000000000000
--- a/dev-libs/ppl/ppl-0.10.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ppl-0.10.1.ebuild,v 1.1 2009/04/14 23:30:11 dirtyepic Exp $
-
-EAPI=2
-
-DESCRIPTION="The Parma Polyhedra Library provides numerical abstractions for analysis of complex systems"
-HOMEPAGE="http://www.cs.unipr.it/ppl/"
-SRC_URI="http://www.cs.unipr.it/ppl/Download/ftp/releases/${PV}/${P}.tar.bz2
- ftp://ftp.cs.unipr.it/pub/ppl/releases/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~mips ~x86"
-IUSE="doc prolog"
-
-RDEPEND="prolog? ( dev-lang/swi-prolog[gmp] )
- >=dev-libs/gmp-4.1.3[-nocxx]"
-DEPEND="${RDEPEND}
- sys-devel/m4"
-
-src_configure() {
-
- use prolog && want_prolog="swi_prolog"
-
- econf \
- --docdir=/usr/share/doc/${PF} \
- --disable-debugging \
- --disable-optimization \
- --enable-interfaces="c cxx ${want_prolog}" \
- || die
-}
-
-src_install() {
-
- emake DESTDIR="${D}" install || die "emake install failed"
-
- if use doc; then
- cd "${D}"/usr/share/doc/${PF}
- mkdir ppl ppl-watchdog
- # the library docs get installed into ${DOCDIR}/ppl/
- # move them to the right place
- mv * ppl-watchdog
- mv ../ppl .
- # TODO - prepalldocs is banned
- # replace it with whatever takes its place when it becomes available
- # prepalldocs
- else
- rm -rf "${D}"/usr/share/doc/${PN}
- rm -rf "${D}"/usr/share/doc/${PF}
- fi
-
- dodoc NEWS README README.configure STANDARDS TODO
-}
diff --git a/dev-libs/ppl/ppl-0.10.2.ebuild b/dev-libs/ppl/ppl-0.10.2.ebuild
new file mode 100644
index 000000000000..6e16d871762a
--- /dev/null
+++ b/dev-libs/ppl/ppl-0.10.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ppl-0.10.2.ebuild,v 1.1 2009/04/18 23:24:39 dirtyepic Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="The Parma Polyhedra Library provides numerical abstractions for analysis of complex systems"
+HOMEPAGE="http://www.cs.unipr.it/ppl/"
+SRC_URI="http://www.cs.unipr.it/ppl/Download/ftp/releases/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="doc pch prolog test watchdog"
+
+RDEPEND="prolog? ( dev-lang/swi-prolog[gmp] )
+ >=dev-libs/gmp-4.1.3[-nocxx]"
+DEPEND="${RDEPEND}
+ sys-devel/m4"
+
+pkg_setup() {
+ if use test; then
+ ewarn "The PPL testsuite will be run."
+ ewarn "Note that this can take several hours to complete on a fast machine."
+ epause 3
+ fi
+}
+
+src_configure() {
+ use prolog && want_prolog="swi_prolog"
+ use test && want_check="--enable-check=quick"
+
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-debugging \
+ --disable-optimization \
+ $(use_enable pch) \
+ $(use_enable watchdog) \
+ --enable-interfaces="c cxx ${want_prolog}" \
+ ${want_check} \
+ || die "configure failed"
+}
+
+src_test() {
+ # default src_test runs with -j1, overriding it here saves about
+ # 30 minutes and recommended by upstream
+ if emake -j1 check -n &> /dev/null; then
+ emake check || die "tests failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ if ! use doc; then
+ rm -r "${D}"/usr/share/doc/${PF}/ppl-user*-html
+ rm -r "${D}"/usr/share/doc/${PF}/pwl-user*-html
+ fi
+
+ cd "${S}"
+ dodoc NEWS README README.configure STANDARDS TODO
+}