summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-10-14 09:57:35 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-10-14 09:57:35 +0000
commit3d064f517e9f84aeb7812c1215573c050a03031b (patch)
tree5c5f6a8fcb657bc292f67c4baad1acea29fbdce0 /dev-libs
parentVersion bump, drop old (diff)
downloadgentoo-2-3d064f517e9f84aeb7812c1215573c050a03031b.tar.gz
gentoo-2-3d064f517e9f84aeb7812c1215573c050a03031b.tar.bz2
gentoo-2-3d064f517e9f84aeb7812c1215573c050a03031b.zip
Building with MPI support requires threads, add REQUIRED_USE for that
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost/ChangeLog7
-rw-r--r--dev-libs/boost/boost-1.52.0-r7.ebuild6
-rw-r--r--dev-libs/boost/boost-1.53.0-r1.ebuild6
-rw-r--r--dev-libs/boost/boost-1.54.0-r1.ebuild6
-rw-r--r--dev-libs/boost/boost-1.55.0-r1.ebuild6
-rw-r--r--dev-libs/boost/boost-1.56.0.ebuild6
6 files changed, 26 insertions, 11 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 454bfb7b1ad0..f182a19d9f15 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.333 2014/09/26 08:01:25 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.334 2014/10/14 09:57:35 pinkbyte Exp $
+
+ 14 Oct 2014; Sergey Popov <pinkbyte@gentoo.org> boost-1.52.0-r7.ebuild,
+ boost-1.53.0-r1.ebuild, boost-1.54.0-r1.ebuild, boost-1.55.0-r1.ebuild,
+ boost-1.56.0.ebuild:
+ Building with MPI support requires threads, add REQUIRED_USE for that
26 Sep 2014; Sergey Popov <pinkbyte@gentoo.org> boost-1.56.0.ebuild:
Add workaround for building with USE=tools, wrt bug #522682
diff --git a/dev-libs/boost/boost-1.52.0-r7.ebuild b/dev-libs/boost/boost-1.52.0-r7.ebuild
index 2a58ed39a733..e81818614335 100644
--- a/dev-libs/boost/boost-1.52.0-r7.ebuild
+++ b/dev-libs/boost/boost-1.52.0-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.52.0-r7.ebuild,v 1.11 2014/08/19 10:37:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.52.0-r7.ebuild,v 1.12 2014/10/14 09:57:35 pinkbyte Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_2,3_3} )
@@ -29,7 +29,9 @@ RDEPEND="icu? ( >=dev-libs/icu-3.6:= )
DEPEND="${RDEPEND}
=dev-util/boost-build-1.52.0*"
-S=${WORKDIR}/${MY_P}
+REQUIRED_USE="mpi? ( threads )"
+
+S="${WORKDIR}/${MY_P}"
create_user-config.jam() {
local compiler compiler_version compiler_executable
diff --git a/dev-libs/boost/boost-1.53.0-r1.ebuild b/dev-libs/boost/boost-1.53.0-r1.ebuild
index a27a7b4e14f4..c21fc6ded78c 100644
--- a/dev-libs/boost/boost-1.53.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.53.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.53.0-r1.ebuild,v 1.6 2014/08/14 08:44:41 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.53.0-r1.ebuild,v 1.7 2014/10/14 09:57:35 pinkbyte Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_2,3_3} )
@@ -28,7 +28,9 @@ RDEPEND="icu? ( >=dev-libs/icu-3.6:= )
!app-admin/eselect-boost"
DEPEND="${RDEPEND}
=dev-util/boost-build-${MAJOR_V}*"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="
+ mpi? ( threads )
+ python? ( ${PYTHON_REQUIRED_USE} )"
S="${WORKDIR}/${MY_P}"
diff --git a/dev-libs/boost/boost-1.54.0-r1.ebuild b/dev-libs/boost/boost-1.54.0-r1.ebuild
index 9601604f817c..7c477994fde5 100644
--- a/dev-libs/boost/boost-1.54.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.54.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.54.0-r1.ebuild,v 1.6 2014/08/14 08:44:41 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.54.0-r1.ebuild,v 1.7 2014/10/14 09:57:35 pinkbyte Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_2,3_3} )
@@ -28,7 +28,9 @@ RDEPEND="icu? ( >=dev-libs/icu-3.6:= )
!app-admin/eselect-boost"
DEPEND="${RDEPEND}
=dev-util/boost-build-${MAJOR_V}*"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="
+ mpi? ( threads )
+ python? ( ${PYTHON_REQUIRED_USE} )"
S="${WORKDIR}/${MY_P}"
diff --git a/dev-libs/boost/boost-1.55.0-r1.ebuild b/dev-libs/boost/boost-1.55.0-r1.ebuild
index 36999368ff94..57a42d24df40 100644
--- a/dev-libs/boost/boost-1.55.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.55.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.55.0-r1.ebuild,v 1.8 2014/08/14 08:44:41 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.55.0-r1.ebuild,v 1.9 2014/10/14 09:57:35 pinkbyte Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
@@ -29,7 +29,9 @@ RDEPEND="icu? ( >=dev-libs/icu-3.6:= )
!app-admin/eselect-boost"
DEPEND="${RDEPEND}
=dev-util/boost-build-${MAJOR_V}*"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="
+ mpi? ( threads )
+ python? ( ${PYTHON_REQUIRED_USE} )"
S="${WORKDIR}/${MY_P}"
diff --git a/dev-libs/boost/boost-1.56.0.ebuild b/dev-libs/boost/boost-1.56.0.ebuild
index 5665ef83a632..ef8d52f675f1 100644
--- a/dev-libs/boost/boost-1.56.0.ebuild
+++ b/dev-libs/boost/boost-1.56.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.56.0.ebuild,v 1.2 2014/09/26 08:01:25 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.56.0.ebuild,v 1.3 2014/10/14 09:57:35 pinkbyte Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
@@ -30,7 +30,9 @@ RDEPEND="abi_x86_32? ( !app-emulation/emul-linux-x86-cpplibs[-abi_x86_32(-)] )
!app-admin/eselect-boost"
DEPEND="${RDEPEND}
=dev-util/boost-build-${MAJOR_V}*"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="
+ mpi? ( threads )
+ python? ( ${PYTHON_REQUIRED_USE} )"
S="${WORKDIR}/${MY_P}"