summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-24 09:35:19 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-24 09:35:19 +0000
commit1ecfad56b5de57fb493db36060f5c926ac78cbe8 (patch)
tree57942d6143ed9b105e0271ca38b9618b1742c544 /dev-libs
parentVersion Bump; thanks Marius Brehler for the work https://github.com/gentoo/ge... (diff)
downloadgentoo-2-1ecfad56b5de57fb493db36060f5c926ac78cbe8.tar.gz
gentoo-2-1ecfad56b5de57fb493db36060f5c926ac78cbe8.tar.bz2
gentoo-2-1ecfad56b5de57fb493db36060f5c926ac78cbe8.zip
Version Bump, bug #552296
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/intel-common/ChangeLog7
-rw-r--r--dev-libs/intel-common/intel-common-15.0.3.187.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-libs/intel-common/ChangeLog b/dev-libs/intel-common/ChangeLog
index d7198fd46e3c..b4b5695f3047 100644
--- a/dev-libs/intel-common/ChangeLog
+++ b/dev-libs/intel-common/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/intel-common
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/intel-common/ChangeLog,v 1.20 2015/04/07 14:11:29 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/intel-common/ChangeLog,v 1.21 2015/06/24 09:35:19 jlec Exp $
+
+*intel-common-15.0.3.187 (24 Jun 2015)
+
+ 24 Jun 2015; Justin Lecher <jlec@gentoo.org> +intel-common-15.0.3.187.ebuild:
+ Version Bump, bug #552296
*intel-common-15.0.2.164 (12 Feb 2015)
diff --git a/dev-libs/intel-common/intel-common-15.0.3.187.ebuild b/dev-libs/intel-common/intel-common-15.0.3.187.ebuild
new file mode 100644
index 000000000000..81c558d9aced
--- /dev/null
+++ b/dev-libs/intel-common/intel-common-15.0.3.187.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/intel-common/intel-common-15.0.3.187.ebuild,v 1.1 2015/06/24 09:35:19 jlec Exp $
+
+EAPI=5
+
+INTEL_DPN=parallel_studio_xe
+INTEL_DID=7538
+INTEL_DPV=2015_update3
+INTEL_SUBDIR=composerxe
+INTEL_SINGLE_ARCH=false
+
+inherit intel-sdp
+
+DESCRIPTION="Common libraries and utilities needed for Intel compilers and libraries"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-compilers/"
+
+IUSE="+compiler"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+CHECKREQS_DISK_BUILD=375M
+
+pkg_setup() {
+ einfo ${INTEL_SDP_EDIR}
+ INTEL_BIN_RPMS="openmp openmp-devel"
+ INTEL_DAT_RPMS="compilerpro-common compilerpro-common-pset"
+ if use compiler; then
+ INTEL_BIN_RPMS+=" compilerpro-devel sourcechecker-devel"
+ INTEL_DAT_RPMS+=" compilerpro-vars sourcechecker-common ccompxe compxe fcompxe"
+ fi
+ intel-sdp_pkg_setup
+}
+
+src_install() {
+ intel-sdp_src_install
+ local path rootpath ldpath arch fenv=35intelsdp
+ cat > ${fenv} <<-EOF
+ NLSPATH=${INTEL_SDP_EDIR}/lib/locale/en_US/%N
+ INTEL_LICENSE_FILE="${INTEL_SDP_EDIR}"/licenses:"${EPREFIX}/opt/intel/license"
+ EOF
+ for arch in ${INTEL_ARCH}; do
+ path=${path}:${INTEL_SDP_EDIR}/bin/${arch}:${INTEL_SDP_EDIR}/mpirt/bin/${arch}
+ rootpath=${rootpath}:${INTEL_SDP_EDIR}/bin/${arch}:${INTEL_SDP_EDIR}/mpirt/bin/${arch}
+ ldpath=${ldpath}:${INTEL_SDP_EDIR}/compiler/lib/${arch}:${INTEL_SDP_EDIR}/mpirt/lib/${arch}
+ done
+ cat >> ${fenv} <<-EOF
+ PATH=${path#:}
+ ROOTPATH=${rootpath#:}
+ LDPATH=${ldpath#:}
+ EOF
+
+ doenvd ${fenv}
+
+ cat >> "${T}"/40-${PN} <<- EOF
+ SEARCH_DIRS_MASK="${INTEL_SDP_EDIR}"
+ EOF
+ insinto /etc/revdep-rebuild/
+ doins "${T}"/40-${PN}
+}