summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-02-06 07:14:02 +0000
committerMike Frysinger <vapier@gentoo.org>2011-02-06 07:14:02 +0000
commite2d2631ca495e5cb18730c10d6db1293a1dce2c4 (patch)
tree8db8b1b2ee9a6b0d5a7631bc4decea48847de790 /dev-libs/zziplib
parentDrop to ~mips (diff)
downloadgentoo-2-e2d2631ca495e5cb18730c10d6db1293a1dce2c4.tar.gz
gentoo-2-e2d2631ca495e5cb18730c10d6db1293a1dce2c4.tar.bz2
gentoo-2-e2d2631ca495e5cb18730c10d6db1293a1dce2c4.zip
Workaround AX_CREATE_PKGCONFIG_INFO pollution in .pc files #353195 by Andrew Savchenko.
(Portage version: 2.2.0_alpha20/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/zziplib')
-rw-r--r--dev-libs/zziplib/ChangeLog8
-rw-r--r--dev-libs/zziplib/zziplib-0.13.60-r1.ebuild72
2 files changed, 79 insertions, 1 deletions
diff --git a/dev-libs/zziplib/ChangeLog b/dev-libs/zziplib/ChangeLog
index a771a8417f86..9b58f8d4b693 100644
--- a/dev-libs/zziplib/ChangeLog
+++ b/dev-libs/zziplib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/zziplib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/ChangeLog,v 1.90 2011/02/05 23:01:21 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/ChangeLog,v 1.91 2011/02/06 07:14:02 vapier Exp $
+
+*zziplib-0.13.60-r1 (06 Feb 2011)
+
+ 06 Feb 2011; Mike Frysinger <vapier@gentoo.org> +zziplib-0.13.60-r1.ebuild:
+ Workaround AX_CREATE_PKGCONFIG_INFO pollution in .pc files #353195 by Andrew
+ Savchenko.
05 Feb 2011; Markus Meier <maekke@gentoo.org> zziplib-0.13.60.ebuild:
arm stable, bug #353274
diff --git a/dev-libs/zziplib/zziplib-0.13.60-r1.ebuild b/dev-libs/zziplib/zziplib-0.13.60-r1.ebuild
new file mode 100644
index 000000000000..d53b15257e12
--- /dev/null
+++ b/dev-libs/zziplib/zziplib-0.13.60-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/zziplib-0.13.60-r1.ebuild,v 1.1 2011/02/06 07:14:02 vapier Exp $
+
+EAPI="2"
+
+inherit libtool eutils flag-o-matic
+
+DESCRIPTION="Lightweight library used to easily extract data from files archived in a single zip file"
+HOMEPAGE="http://zziplib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zziplib/${P}.tar.bz2"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc sdl static-libs test"
+
+RDEPEND="sys-libs/zlib
+ sdl? ( >=media-libs/libsdl-1.2.6 )"
+DEPEND="${RDEPEND}
+ >=dev-lang/python-2.4
+ dev-util/pkgconfig
+ test? ( app-arch/zip )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.13.49-SDL-test.patch
+
+ # workaround AX_CREATE_PKGCONFIG_INFO bug #353195
+ sed -i \
+ -e '/ax_create_pkgconfig_ldflags/s:$LDFLAGS::' \
+ -e '/ax_create_pkgconfig_cppflags/s:$CPPFLAGS::' \
+ configure || die
+
+ # zziplib tries to install backwards compat symlinks we dont want
+ sed -i -e '/^zzip-postinstall:/s|$|\ndisable-this:|' Makefile.in || die
+ sed -i -e '/^install-exec-hook:/s|$|\ndisable-this:|' zzip/Makefile.in || die
+
+ elibtoolize
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing # bug reported upstream
+ export ac_cv_path_XMLTO= # man pages are bundled in .tar's
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable sdl) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ # need this because `make test` will always return true
+ # tests fail with -j > 1 (bug #241186)
+ emake -j1 check || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ # fowners fails when we don't have enough permissions (Prefix)
+ if [[ ${EUID} == 0 ]] ; then
+ fowners -R root /usr/share/man || die #321975
+ fi
+
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -exec rm {} + || die
+ fi
+
+ dodoc ChangeLog README TODO
+
+ if use doc ; then
+ dohtml -r docs/* || die 'dohtml failed'
+ fi
+}