summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-12-01 06:28:05 +0000
committerMike Frysinger <vapier@gentoo.org>2013-12-01 06:28:05 +0000
commit565ab57be70b21f37ebf74c9b01fc6ab19058273 (patch)
tree19929e00428171950acaabb39b49fb465b3d841d /dev-libs/zziplib
parentDo not install /var/lib or /var/lock paths as the code will take care of crea... (diff)
downloadgentoo-2-565ab57be70b21f37ebf74c9b01fc6ab19058273.tar.gz
gentoo-2-565ab57be70b21f37ebf74c9b01fc6ab19058273.tar.bz2
gentoo-2-565ab57be70b21f37ebf74c9b01fc6ab19058273.zip
Version bump & update to EAPI=4 #450636 by Agostino Sarubbo. Set up the build dir ourselves to simplify things #492816 by gregg4567.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'dev-libs/zziplib')
-rw-r--r--dev-libs/zziplib/ChangeLog8
-rw-r--r--dev-libs/zziplib/zziplib-0.13.62.ebuild92
2 files changed, 99 insertions, 1 deletions
diff --git a/dev-libs/zziplib/ChangeLog b/dev-libs/zziplib/ChangeLog
index 446fc655eed1..d096c952526d 100644
--- a/dev-libs/zziplib/ChangeLog
+++ b/dev-libs/zziplib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/zziplib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/ChangeLog,v 1.110 2013/04/20 00:07:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/ChangeLog,v 1.111 2013/12/01 06:28:05 vapier Exp $
+
+*zziplib-0.13.62 (01 Dec 2013)
+
+ 01 Dec 2013; Mike Frysinger <vapier@gentoo.org> +zziplib-0.13.62.ebuild:
+ Version bump & update to EAPI=4 #450636 by Agostino Sarubbo. Set up the build
+ dir ourselves to simplify things #492816 by gregg4567.
20 Apr 2013; Mike Frysinger <vapier@gentoo.org> zziplib-0.13.60-r1.ebuild:
Disable aclocal checking since the default path works #449156 by Diego Elio
diff --git a/dev-libs/zziplib/zziplib-0.13.62.ebuild b/dev-libs/zziplib/zziplib-0.13.62.ebuild
new file mode 100644
index 000000000000..641c829bcbd1
--- /dev/null
+++ b/dev-libs/zziplib/zziplib-0.13.62.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/zziplib-0.13.62.ebuild,v 1.1 2013/12/01 06:28:05 vapier Exp $
+
+EAPI="4"
+# PYTHON_BDEPEND="2"
+
+inherit libtool eutils flag-o-matic python
+
+DESCRIPTION="Lightweight library used to easily extract data from files archived in a single zip file"
+HOMEPAGE="http://zziplib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zziplib/${P}.tar.bz2"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc sdl static-libs test"
+
+RDEPEND="sys-libs/zlib
+ sdl? ( >=media-libs/libsdl-1.2.6 )"
+DEPEND="${RDEPEND}
+ =dev-lang/python-2*
+ virtual/pkgconfig
+ test? ( app-arch/zip )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.13.49-SDL-test.patch
+
+ # workaround AX_CREATE_PKGCONFIG_INFO bug #353195
+ sed -i \
+ -e '/ax_create_pkgconfig_ldflags/s:$LDFLAGS::' \
+ -e '/ax_create_pkgconfig_cppflags/s:$CPPFLAGS::' \
+ configure || die
+
+ # zziplib tries to install backwards compat symlinks we dont want
+ sed -i -e '/^zzip-postinstall:/s|$|\ndisable-this:|' Makefile.in || die
+ sed -i -e '/^install-exec-hook:/s|$|\ndisable-this:|' zzip/Makefile.in || die
+
+ elibtoolize
+
+ # Do an out-of-tree build as their configure will do it automatically
+ # otherwise and that can lead to funky errors. #492816
+ mkdir -p build
+}
+
+src_configure() {
+ cd "${S}"/build
+
+ append-flags -fno-strict-aliasing # bug reported upstream
+ export ac_cv_path_XMLTO= # man pages are bundled in .tar's
+
+ # Disable aclocal probing as the default path works #449156
+ ECONF_SOURCE=${S} \
+ ACLOCAL=true \
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable sdl) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake -C build
+}
+
+src_test() {
+ # need this because `make test` will always return true
+ # tests fail with -j > 1 (bug #241186)
+ emake -C build -j1 check
+}
+
+src_install() {
+ emake -C build DESTDIR="${D}" install
+ # fowners fails when we don't have enough permissions (Prefix)
+ if [[ ${EUID} == 0 ]] ; then
+ fowners -R root /usr/share/man #321975
+ fi
+
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -delete || die
+ fi
+
+ dodoc ChangeLog README TODO
+
+ if use doc ; then
+ dohtml -r docs/*
+ fi
+}