summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-04-06 23:01:55 +0000
committerMike Gilbert <floppym@gentoo.org>2013-04-06 23:01:55 +0000
commitdf174653915e340d6a58758e9e0554af275e96b4 (patch)
treee7ba6f210f296a4df822928c012a57f3ac21d553 /dev-libs/re2
parentClean up old revision (diff)
downloadgentoo-2-df174653915e340d6a58758e9e0554af275e96b4.tar.gz
gentoo-2-df174653915e340d6a58758e9e0554af275e96b4.tar.bz2
gentoo-2-df174653915e340d6a58758e9e0554af275e96b4.zip
Add multilib support and install the static library as requested by Alex Efros in bug 464806. Thanks for the patch, even if I didn't use it.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-libs/re2')
-rw-r--r--dev-libs/re2/ChangeLog8
-rw-r--r--dev-libs/re2/re2-0_p20130115-r1.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-libs/re2/ChangeLog b/dev-libs/re2/ChangeLog
index 077580bd7c12..7790fb7daa4e 100644
--- a/dev-libs/re2/ChangeLog
+++ b/dev-libs/re2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/re2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/re2/ChangeLog,v 1.7 2013/04/04 20:16:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/re2/ChangeLog,v 1.8 2013/04/06 23:01:55 floppym Exp $
+
+*re2-0_p20130115-r1 (06 Apr 2013)
+
+ 06 Apr 2013; Mike Gilbert <floppym@gentoo.org> +re2-0_p20130115-r1.ebuild:
+ Add multilib support and install the static library as requested by Alex Efros
+ in bug 464806. Thanks for the patch, even if I didn't use it.
04 Apr 2013; Agostino Sarubbo <ago@gentoo.org> re2-0_p20130115.ebuild:
Stable for x86, wrt bug #463426
diff --git a/dev-libs/re2/re2-0_p20130115-r1.ebuild b/dev-libs/re2/re2-0_p20130115-r1.ebuild
new file mode 100644
index 000000000000..ff51245f71dd
--- /dev/null
+++ b/dev-libs/re2/re2-0_p20130115-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/re2/re2-0_p20130115-r1.ebuild,v 1.1 2013/04/06 23:01:55 floppym Exp $
+
+EAPI=5
+
+inherit eutils multilib multilib-build toolchain-funcs
+
+DESCRIPTION="An efficent, principled regular expression library"
+HOMEPAGE="http://code.google.com/p/re2/"
+SRC_URI="http://re2.googlecode.com/files/${PN}-${PV##*_p}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+# TODO: the directory in the tarball should really be versioned.
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # Fix problems with FilteredRE2 symbols not being exported.
+ epatch "${FILESDIR}/${PN}-symbols-r0.patch"
+ multilib_copy_sources
+}
+
+mymake() {
+ cd "${BUILD_DIR}" || die
+ local makeopts=(
+ AR="$(tc-getAR)"
+ CXX="$(tc-getCXX)"
+ CXXFLAGS="${CXXFLAGS} -pthread"
+ LDFLAGS="${LDFLAGS} -pthread"
+ NM="$(tc-getNM)"
+ )
+ emake "${makeopts[@]}" "$@"
+}
+
+src_compile() {
+ multilib_foreach_abi mymake
+}
+
+src_test() {
+ multilib_foreach_abi mymake shared-test
+}
+
+src_install() {
+ myinstall() {
+ cd "${BUILD_DIR}" || die
+ emake DESTDIR="${ED}" prefix=usr libdir=usr/$(get_libdir) install
+ multilib_check_headers
+ }
+ multilib_foreach_abi myinstall
+ dodoc AUTHORS CONTRIBUTORS README doc/syntax.txt
+ dohtml doc/syntax.html
+}