summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-18 22:46:09 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-18 22:46:09 +0000
commitd36bcf717267beffa3d02c9158dd5fc9f49a01d4 (patch)
tree27a64ce9e65d996335f6ac658ae6d5d4a375efd2 /dev-libs/mpfr
parentold (diff)
downloadgentoo-2-d36bcf717267beffa3d02c9158dd5fc9f49a01d4.tar.gz
gentoo-2-d36bcf717267beffa3d02c9158dd5fc9f49a01d4.tar.bz2
gentoo-2-d36bcf717267beffa3d02c9158dd5fc9f49a01d4.zip
Version bump.
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/mpfr')
-rw-r--r--dev-libs/mpfr/ChangeLog9
-rw-r--r--dev-libs/mpfr/files/2.4.1/patch0245
-rw-r--r--dev-libs/mpfr/files/2.4.1/patch0325
-rw-r--r--dev-libs/mpfr/files/2.4.1/patch0445
-rw-r--r--dev-libs/mpfr/files/2.4.1/patch0547
-rw-r--r--dev-libs/mpfr/mpfr-2.4.1_p5.ebuild50
6 files changed, 220 insertions, 1 deletions
diff --git a/dev-libs/mpfr/ChangeLog b/dev-libs/mpfr/ChangeLog
index 78b62a3a9c47..d30e3f26389d 100644
--- a/dev-libs/mpfr/ChangeLog
+++ b/dev-libs/mpfr/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/mpfr
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/mpfr/ChangeLog,v 1.101 2009/03/14 14:55:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mpfr/ChangeLog,v 1.102 2009/03/18 22:46:09 vapier Exp $
+
+*mpfr-2.4.1_p5 (18 Mar 2009)
+
+ 18 Mar 2009; Mike Frysinger <vapier@gentoo.org> +files/2.4.1/patch02,
+ +files/2.4.1/patch03, +files/2.4.1/patch04, +files/2.4.1/patch05,
+ +mpfr-2.4.1_p5.ebuild:
+ Version bump.
14 Mar 2009; Mike Frysinger <vapier@gentoo.org> mpfr-2.4.1_p1.ebuild:
Fix up == usage in shell test #261016 by deadhead.
diff --git a/dev-libs/mpfr/files/2.4.1/patch02 b/dev-libs/mpfr/files/2.4.1/patch02
new file mode 100644
index 000000000000..c6b6aaccde55
--- /dev/null
+++ b/dev-libs/mpfr/files/2.4.1/patch02
@@ -0,0 +1,45 @@
+diff -Naurd mpfr-2.4.1-a/PATCHES mpfr-2.4.1-b/PATCHES
+--- mpfr-2.4.1-a/PATCHES 2009-03-04 13:15:05.000000000 +0000
++++ mpfr-2.4.1-b/PATCHES 2009-03-04 13:17:04.000000000 +0000
+@@ -0,0 +1 @@
++assert
+diff -Naurd mpfr-2.4.1-a/VERSION mpfr-2.4.1-b/VERSION
+--- mpfr-2.4.1-a/VERSION 2009-02-27 16:55:37.000000000 +0000
++++ mpfr-2.4.1-b/VERSION 2009-03-04 13:16:46.000000000 +0000
+@@ -1 +1 @@
+-2.4.1-p1
++2.4.1-p2
+diff -Naurd mpfr-2.4.1-a/mpfr-gmp.c mpfr-2.4.1-b/mpfr-gmp.c
+--- mpfr-2.4.1-a/mpfr-gmp.c 2009-02-20 09:43:17.000000000 +0000
++++ mpfr-2.4.1-b/mpfr-gmp.c 2009-03-04 13:16:39.000000000 +0000
+@@ -301,7 +301,7 @@
+ if (linenum != -1)
+ fprintf (stderr, "%d: ", linenum);
+ }
+- fprintf (stderr, " assertion failed: %s\n", expr);
++ fprintf (stderr, "MPFR assertion failed: %s\n", expr);
+ abort();
+ }
+
+diff -Naurd mpfr-2.4.1-a/mpfr.h mpfr-2.4.1-b/mpfr.h
+--- mpfr-2.4.1-a/mpfr.h 2009-02-27 16:55:38.000000000 +0000
++++ mpfr-2.4.1-b/mpfr.h 2009-03-04 13:16:46.000000000 +0000
+@@ -27,7 +27,7 @@
+ #define MPFR_VERSION_MAJOR 2
+ #define MPFR_VERSION_MINOR 4
+ #define MPFR_VERSION_PATCHLEVEL 1
+-#define MPFR_VERSION_STRING "2.4.1-p1"
++#define MPFR_VERSION_STRING "2.4.1-p2"
+
+ /* Macros dealing with MPFR VERSION */
+ #define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
+diff -Naurd mpfr-2.4.1-a/version.c mpfr-2.4.1-b/version.c
+--- mpfr-2.4.1-a/version.c 2009-02-27 16:55:38.000000000 +0000
++++ mpfr-2.4.1-b/version.c 2009-03-04 13:16:46.000000000 +0000
+@@ -25,5 +25,5 @@
+ const char *
+ mpfr_get_version (void)
+ {
+- return "2.4.1-p1";
++ return "2.4.1-p2";
+ }
diff --git a/dev-libs/mpfr/files/2.4.1/patch03 b/dev-libs/mpfr/files/2.4.1/patch03
new file mode 100644
index 000000000000..e85136a5621e
--- /dev/null
+++ b/dev-libs/mpfr/files/2.4.1/patch03
@@ -0,0 +1,25 @@
+diff -Naurd mpfr-2.4.1-a/tests/tfprintf.c mpfr-2.4.1-b/tests/tfprintf.c
+--- mpfr-2.4.1-a/tests/tfprintf.c 2009-02-20 09:43:15.000000000 +0000
++++ mpfr-2.4.1-b/tests/tfprintf.c 2009-03-10 01:12:45.000000000 +0000
+@@ -195,7 +195,7 @@
+ check_vfprintf (fout, "a. %Pu, b. %c, c. %Zi%Zn", prec, ch, mpz, &mpz);
+ check_length_with_cmp (6, mpz, 17, mpz_cmp_ui (mpz, 17), Zi);
+ check_vfprintf (fout, "%% a. %#.0RNg, b. %Qx%Rn, c. %p", mpfr, mpq, &mpfr,
+- &i);
++ (void *) &i);
+ check_length_with_cmp (7, mpfr, 16, mpfr_cmp_ui (mpfr, 16), Rg);
+
+ #ifndef NPRINTF_T
+diff -Naurd mpfr-2.4.1-a/tests/tprintf.c mpfr-2.4.1-b/tests/tprintf.c
+--- mpfr-2.4.1-a/tests/tprintf.c 2009-02-20 09:43:15.000000000 +0000
++++ mpfr-2.4.1-b/tests/tprintf.c 2009-03-10 01:12:45.000000000 +0000
+@@ -191,7 +191,8 @@
+ check_length (5, sz, 34, zu);
+ check_vprintf ("a. %Pu, b. %c, c. %RUG, d. %Zi%Zn", prec, ch, mpfr, mpz, &mpz);
+ check_length_with_cmp (6, mpz, 24, mpz_cmp_ui (mpz, 24), Zi);
+- check_vprintf ("%% a. %#.0RNg, b. %Qx%Rn c. %p", mpfr, mpq, &mpfr, &i);
++ check_vprintf ("%% a. %#.0RNg, b. %Qx%Rn c. %p",
++ mpfr, mpq, &mpfr, (void *) &i);
+ check_length_with_cmp (7, mpfr, 16, mpfr_cmp_ui (mpfr, 16), Rg);
+
+ #ifndef NPRINTF_T
diff --git a/dev-libs/mpfr/files/2.4.1/patch04 b/dev-libs/mpfr/files/2.4.1/patch04
new file mode 100644
index 000000000000..08e21f25def7
--- /dev/null
+++ b/dev-libs/mpfr/files/2.4.1/patch04
@@ -0,0 +1,45 @@
+diff -Naurd mpfr-2.4.1-a/PATCHES mpfr-2.4.1-b/PATCHES
+--- mpfr-2.4.1-a/PATCHES 2009-03-10 01:44:39.000000000 +0000
++++ mpfr-2.4.1-b/PATCHES 2009-03-10 01:44:40.000000000 +0000
+@@ -0,0 +1 @@
++vasprintf-mp_limb_t
+diff -Naurd mpfr-2.4.1-a/VERSION mpfr-2.4.1-b/VERSION
+--- mpfr-2.4.1-a/VERSION 2009-03-04 13:16:46.000000000 +0000
++++ mpfr-2.4.1-b/VERSION 2009-03-10 01:44:40.000000000 +0000
+@@ -1 +1 @@
+-2.4.1-p2
++2.4.1-p4
+diff -Naurd mpfr-2.4.1-a/mpfr.h mpfr-2.4.1-b/mpfr.h
+--- mpfr-2.4.1-a/mpfr.h 2009-03-04 13:16:46.000000000 +0000
++++ mpfr-2.4.1-b/mpfr.h 2009-03-10 01:44:40.000000000 +0000
+@@ -27,7 +27,7 @@
+ #define MPFR_VERSION_MAJOR 2
+ #define MPFR_VERSION_MINOR 4
+ #define MPFR_VERSION_PATCHLEVEL 1
+-#define MPFR_VERSION_STRING "2.4.1-p2"
++#define MPFR_VERSION_STRING "2.4.1-p4"
+
+ /* Macros dealing with MPFR VERSION */
+ #define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
+diff -Naurd mpfr-2.4.1-a/vasprintf.c mpfr-2.4.1-b/vasprintf.c
+--- mpfr-2.4.1-a/vasprintf.c 2009-02-20 09:43:17.000000000 +0000
++++ mpfr-2.4.1-b/vasprintf.c 2009-03-10 01:44:40.000000000 +0000
+@@ -398,7 +398,7 @@
+ (void) va_arg ((ap), mpq_srcptr); \
+ break; \
+ case MP_LIMB_ARG: \
+- (void) va_arg ((ap), mp_ptr); \
++ (void) va_arg ((ap), mp_limb_t); \
+ break; \
+ case MP_LIMB_ARRAY_ARG: \
+ (void) va_arg ((ap), mp_ptr); \
+diff -Naurd mpfr-2.4.1-a/version.c mpfr-2.4.1-b/version.c
+--- mpfr-2.4.1-a/version.c 2009-03-04 13:16:46.000000000 +0000
++++ mpfr-2.4.1-b/version.c 2009-03-10 01:44:40.000000000 +0000
+@@ -25,5 +25,5 @@
+ const char *
+ mpfr_get_version (void)
+ {
+- return "2.4.1-p2";
++ return "2.4.1-p4";
+ }
diff --git a/dev-libs/mpfr/files/2.4.1/patch05 b/dev-libs/mpfr/files/2.4.1/patch05
new file mode 100644
index 000000000000..710c698d8898
--- /dev/null
+++ b/dev-libs/mpfr/files/2.4.1/patch05
@@ -0,0 +1,47 @@
+diff -Naurd mpfr-2.4.1-a/PATCHES mpfr-2.4.1-b/PATCHES
+--- mpfr-2.4.1-a/PATCHES 2009-03-13 02:50:47.000000000 +0000
++++ mpfr-2.4.1-b/PATCHES 2009-03-13 02:50:48.000000000 +0000
+@@ -0,0 +1 @@
++zeta_ui-shift
+diff -Naurd mpfr-2.4.1-a/VERSION mpfr-2.4.1-b/VERSION
+--- mpfr-2.4.1-a/VERSION 2009-03-10 01:44:40.000000000 +0000
++++ mpfr-2.4.1-b/VERSION 2009-03-13 02:50:48.000000000 +0000
+@@ -1 +1 @@
+-2.4.1-p4
++2.4.1-p5
+diff -Naurd mpfr-2.4.1-a/mpfr.h mpfr-2.4.1-b/mpfr.h
+--- mpfr-2.4.1-a/mpfr.h 2009-03-10 01:44:40.000000000 +0000
++++ mpfr-2.4.1-b/mpfr.h 2009-03-13 02:50:48.000000000 +0000
+@@ -27,7 +27,7 @@
+ #define MPFR_VERSION_MAJOR 2
+ #define MPFR_VERSION_MINOR 4
+ #define MPFR_VERSION_PATCHLEVEL 1
+-#define MPFR_VERSION_STRING "2.4.1-p4"
++#define MPFR_VERSION_STRING "2.4.1-p5"
+
+ /* Macros dealing with MPFR VERSION */
+ #define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
+diff -Naurd mpfr-2.4.1-a/version.c mpfr-2.4.1-b/version.c
+--- mpfr-2.4.1-a/version.c 2009-03-10 01:44:40.000000000 +0000
++++ mpfr-2.4.1-b/version.c 2009-03-13 02:50:48.000000000 +0000
+@@ -25,5 +25,5 @@
+ const char *
+ mpfr_get_version (void)
+ {
+- return "2.4.1-p4";
++ return "2.4.1-p5";
+ }
+diff -Naurd mpfr-2.4.1-a/zeta_ui.c mpfr-2.4.1-b/zeta_ui.c
+--- mpfr-2.4.1-a/zeta_ui.c 2009-02-20 09:43:17.000000000 +0000
++++ mpfr-2.4.1-b/zeta_ui.c 2009-03-13 02:50:48.000000000 +0000
+@@ -177,7 +177,9 @@
+ mpz_mul_ui (t, t, 2 * k - 1);
+ }
+ mpz_div_2exp (t, t, 1);
+- if (n < 1UL << (BITS_PER_MP_LIMB / 2))
++ /* Warning: the test below assumes that an unsigned long
++ has no padding bits. */
++ if (n < 1UL << ((sizeof(unsigned long) * CHAR_BIT) / 2))
+ /* (n - k + 1) * (n + k - 1) < n^2 */
+ mpz_divexact_ui (t, t, (n - k + 1) * (n + k - 1));
+ else
diff --git a/dev-libs/mpfr/mpfr-2.4.1_p5.ebuild b/dev-libs/mpfr/mpfr-2.4.1_p5.ebuild
new file mode 100644
index 000000000000..d98ef0dddbf2
--- /dev/null
+++ b/dev-libs/mpfr/mpfr-2.4.1_p5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mpfr/mpfr-2.4.1_p5.ebuild,v 1.1 2009/03/18 22:46:09 vapier Exp $
+
+# NOTE: we cannot depend on autotools here starting with gcc-4.3.x
+inherit eutils
+
+MY_PV=${PV/_p*}
+MY_P=${PN}-${MY_PV}
+PLEVEL=${PV/*p}
+DESCRIPTION="library for multiple-precision floating-point computations with exact rounding"
+HOMEPAGE="http://www.mpfr.org/"
+SRC_URI="http://www.mpfr.org/mpfr-current/${MY_P}.tar.lzma"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/gmp-4.1.4-r2"
+DEPEND="${RDEPEND}
+ app-arch/lzma-utils"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ [[ -d ${FILESDIR}/${PV} ]] && epatch "${FILESDIR}"/${PV}/*.patch
+ [[ ${PLEVEL} == ${PV} ]] && return 0
+ for ((i=1; i<=PLEVEL; ++i)) ; do
+ patch=patch$(printf '%02d' ${i})
+ if [[ -f ${FILESDIR}/${MY_PV}/${patch} ]] ; then
+ epatch "${FILESDIR}"/${MY_PV}/${patch}
+ elif [[ -f ${DISTDIR}/${PN}-${MY_PV}_p${i} ]] ; then
+ epatch "${DISTDIR}"/${PN}-${MY_PV}_p${i}
+ else
+ ewarn "${DISTDIR}/${PN}-${MY_PV}_p${i}"
+ die "patch ${i} missing - please report to bugs.gentoo.org"
+ fi
+ done
+ sed -i '/if test/s:==:=:' configure #261016
+ find . -type f -print0 | xargs -0 touch -r configure
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+ dohtml *.html
+}