summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2014-03-27 17:05:08 +0000
committerTony Vroon <chainsaw@gentoo.org>2014-03-27 17:05:08 +0000
commit880e90b6650786a4cd6c0dec4fbcbcb57b67b3ce (patch)
tree1cb1cb59b35a94b33346ec6cb7fc73ab836c1fa4 /dev-libs/mongo-c-driver
parentSecurity bump (bug #505948). (diff)
downloadgentoo-2-880e90b6650786a4cd6c0dec4fbcbcb57b67b3ce.tar.gz
gentoo-2-880e90b6650786a4cd6c0dec4fbcbcb57b67b3ce.tar.bz2
gentoo-2-880e90b6650786a4cd6c0dec4fbcbcb57b67b3ce.zip
Bump up the API version numbers in the header, as recent pmacct release candidates require this to build. Attempt to port to newer python eclass.
(Portage version: 2.2.9-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'dev-libs/mongo-c-driver')
-rw-r--r--dev-libs/mongo-c-driver/ChangeLog9
-rw-r--r--dev-libs/mongo-c-driver/files/0.8.1-api-version.diff14
-rw-r--r--dev-libs/mongo-c-driver/mongo-c-driver-0.8.1-r1.ebuild44
3 files changed, 66 insertions, 1 deletions
diff --git a/dev-libs/mongo-c-driver/ChangeLog b/dev-libs/mongo-c-driver/ChangeLog
index 11cf683404c8..493928b55961 100644
--- a/dev-libs/mongo-c-driver/ChangeLog
+++ b/dev-libs/mongo-c-driver/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/mongo-c-driver
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/mongo-c-driver/ChangeLog,v 1.6 2014/03/27 15:05:14 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mongo-c-driver/ChangeLog,v 1.7 2014/03/27 17:05:08 chainsaw Exp $
+
+*mongo-c-driver-0.8.1-r1 (27 Mar 2014)
+
+ 27 Mar 2014; Tony Vroon <chainsaw@gentoo.org>
+ +mongo-c-driver-0.8.1-r1.ebuild, +files/0.8.1-api-version.diff:
+ Bump up the API version numbers in the header, as recent pmacct release
+ candidates require this to build. Attempt to port to newer python eclass.
*mongo-c-driver-0.8.1 (27 Mar 2014)
diff --git a/dev-libs/mongo-c-driver/files/0.8.1-api-version.diff b/dev-libs/mongo-c-driver/files/0.8.1-api-version.diff
new file mode 100644
index 000000000000..2bd52253a17b
--- /dev/null
+++ b/dev-libs/mongo-c-driver/files/0.8.1-api-version.diff
@@ -0,0 +1,14 @@
+diff -uNr mongo-c-driver-0.8.1.ORIG/src/mongo.h mongo-c-driver-0.8.1/src/mongo.h
+--- mongo-c-driver-0.8.1.ORIG/src/mongo.h 2014-03-27 17:00:42.880465606 +0000
++++ mongo-c-driver-0.8.1/src/mongo.h 2014-03-27 17:01:05.131465940 +0000
+@@ -33,8 +33,8 @@
+ #endif
+
+ #define MONGO_MAJOR 0
+-#define MONGO_MINOR 7
+-#define MONGO_PATCH 0
++#define MONGO_MINOR 8
++#define MONGO_PATCH 1
+
+ #define MONGO_OK 0
+ #define MONGO_ERROR -1
diff --git a/dev-libs/mongo-c-driver/mongo-c-driver-0.8.1-r1.ebuild b/dev-libs/mongo-c-driver/mongo-c-driver-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..141428d9427d
--- /dev/null
+++ b/dev-libs/mongo-c-driver/mongo-c-driver-0.8.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mongo-c-driver/mongo-c-driver-0.8.1-r1.ebuild,v 1.1 2014/03/27 17:05:08 chainsaw Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit base multilib python-r1
+
+DESCRIPTION="C Driver for MongoDB"
+HOMEPAGE="http://www.mongodb.org/ https://github.com/mongodb/mongo-c-driver"
+SRC_URI="https://github.com/mongodb/${PN}/tarball/v${PV/_/} -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="doc static-libs"
+
+# tests fails to build
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="doc? ( dev-python/sphinx )"
+PATCHES=( "${FILESDIR}/${PV}-api-version.diff" )
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}
+
+src_compile() {
+ emake
+ use doc && make -C docs/source/sphinx html
+}
+
+src_install() {
+ emake install \
+ INSTALL_LIBRARY_PATH="${D}/usr/$(get_libdir)" \
+ INSTALL_INCLUDE_PATH="${D}/usr/include"
+
+ use static-libs || find "${ED}" -name '*.a' -exec rm -f {} +
+
+ use doc && dohtml -r docs/source/sphinx/build/html/*
+}