summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-07-28 21:53:31 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-07-28 21:53:31 +0000
commit12baf8a457b67be82486be2cdfcb3f29b9572544 (patch)
tree4fa377962f7e736359c0a9489cdd2ffec28616dc /dev-libs/libtommath
parentBug #262046: If used with a non-local NSS source, we need to start after those. (diff)
downloadgentoo-2-12baf8a457b67be82486be2cdfcb3f29b9572544.tar.gz
gentoo-2-12baf8a457b67be82486be2cdfcb3f29b9572544.tar.bz2
gentoo-2-12baf8a457b67be82486be2cdfcb3f29b9572544.zip
Respecting CC variable, closes bug #243928
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-libs/libtommath')
-rw-r--r--dev-libs/libtommath/ChangeLog7
-rw-r--r--dev-libs/libtommath/files/libtommath-0.36-CC.patch50
-rw-r--r--dev-libs/libtommath/files/libtommath-0.41-CC.patch48
-rw-r--r--dev-libs/libtommath/libtommath-0.36-r1.ebuild19
-rw-r--r--dev-libs/libtommath/libtommath-0.41.ebuild5
5 files changed, 117 insertions, 12 deletions
diff --git a/dev-libs/libtommath/ChangeLog b/dev-libs/libtommath/ChangeLog
index 0efa05cf7e57..85ec81df283e 100644
--- a/dev-libs/libtommath/ChangeLog
+++ b/dev-libs/libtommath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libtommath
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/ChangeLog,v 1.28 2009/07/24 16:41:31 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/ChangeLog,v 1.29 2009/07/28 21:53:31 vostorga Exp $
+
+ 28 Jul 2009; Víctor Ostorga <vostorga@gentoo.org>
+ libtommath-0.36-r1.ebuild, +files/libtommath-0.36-CC.patch,
+ libtommath-0.41.ebuild, +files/libtommath-0.41-CC.patch:
+ Respecting CC variable, closes bug #243928
24 Jul 2009; Joseph Jezak <josejx@gentoo.org> libtommath-0.36-r1.ebuild:
Marked ppc64 stable.
diff --git a/dev-libs/libtommath/files/libtommath-0.36-CC.patch b/dev-libs/libtommath/files/libtommath-0.36-CC.patch
new file mode 100644
index 000000000000..7632e42f4d81
--- /dev/null
+++ b/dev-libs/libtommath/files/libtommath-0.36-CC.patch
@@ -0,0 +1,50 @@
+diff -NrU5 libtommath-0.36.original/makefile.shared libtommath-0.36/makefile.shared
+--- libtommath-0.36.original/makefile.shared 2009-07-28 21:10:57.000000000 -0600
++++ libtommath-0.36/makefile.shared 2009-07-28 21:20:30.000000000 -0600
+@@ -1,11 +1,11 @@
+ #Makefile for GCC
+ #
+ #Tom St Denis
+ VERSION=0:36
+
+-CC = libtool --mode=compile gcc
++LTCOMPILE = libtool --mode=compile $(CC)
+
+ CFLAGS += -I./ -Wall -W -Wshadow -Wsign-compare
+
+ ifndef IGNORE_SPEED
+
+@@ -78,24 +78,27 @@
+ bn_mp_init_multi.o bn_mp_clear_multi.o bn_mp_exteuclid.o bn_mp_toradix_n.o \
+ bn_mp_prime_random_ex.o bn_mp_get_int.o bn_mp_sqrt.o bn_mp_is_square.o bn_mp_init_set.o \
+ bn_mp_init_set_int.o bn_mp_invmod_slow.o bn_mp_prime_rabin_miller_trials.o \
+ bn_mp_to_signed_bin_n.o bn_mp_to_unsigned_bin_n.o
+
++.c.o:
++ $(LTCOMPILE) $(CFLAGS) $(LDFLAGS) -o $@ -c $<
++
+ $(LIBNAME): $(OBJECTS)
+- libtool --mode=link --tag=CC gcc $(LDFLAGS) *.lo -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
+- libtool --mode=link --tag=CC gcc *.o -o $(LIBNAME_S)
++ libtool --mode=link --tag=CC $(CC) $(LDFLAGS) *.lo -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
++ libtool --mode=link --tag=CC $(CC) *.o -o $(LIBNAME_S)
+
+ install: $(LIBNAME) $(HEADERS)
+ install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)
+ install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(INCPATH)
+ libtool --mode=install install -c $(LIBNAME) $(DESTDIR)$(LIBPATH)/$(LIBNAME)
+ install -g $(GROUP) -o $(USER) $(HEADERS) $(DESTDIR)$(INCPATH)
+
+ test: $(LIBNAME) demo/demo.o
+- gcc $(CFLAGS) -c demo/demo.c -o demo/demo.o
+- libtool --mode=link gcc $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
++ $(CC) $(CFLAGS) -c demo/demo.c -o demo/demo.o
++ libtool --mode=link $(CC) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
+
+ mtest: test
+- cd mtest ; gcc $(CFLAGS) $(LDFLAGS) mtest.c -o mtest
++ cd mtest ; $(CC) $(CFLAGS) $(LDFLAGS) mtest.c -o mtest
+
+ timing: $(LIBNAME)
+- libtool --mode=link gcc $(CFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME) -o ltmtest
++ libtool --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME) -o ltmtest
diff --git a/dev-libs/libtommath/files/libtommath-0.41-CC.patch b/dev-libs/libtommath/files/libtommath-0.41-CC.patch
new file mode 100644
index 000000000000..5eef4ee12962
--- /dev/null
+++ b/dev-libs/libtommath/files/libtommath-0.41-CC.patch
@@ -0,0 +1,48 @@
+diff -NrU5 libtommath-0.41.original/makefile.shared libtommath-0.41/makefile.shared
+--- libtommath-0.41.original/makefile.shared 2009-07-28 21:59:47.000000000 -0600
++++ libtommath-0.41/makefile.shared 2009-07-28 22:01:32.000000000 -0600
+@@ -1,11 +1,11 @@
+ #Makefile for GCC
+ #
+ #Tom St Denis
+ VERSION=0:41
+
+-CC = libtool --mode=compile --tag=CC gcc
++LTCOMPILE = libtool --mode=compile --tag=CC $(CC)
+
+ CFLAGS += -I./ -Wall -W -Wshadow -Wsign-compare
+
+ ifndef IGNORE_SPEED
+
+@@ -80,23 +80,26 @@
+ bn_mp_init_set_int.o bn_mp_invmod_slow.o bn_mp_prime_rabin_miller_trials.o \
+ bn_mp_to_signed_bin_n.o bn_mp_to_unsigned_bin_n.o
+
+ objs: $(OBJECTS)
+
++.c.o:
++ $(LTCOMPILE) $(CFLAGS) $(LDFLAGS) -o $@ -c $<
++
+ $(LIBNAME): $(OBJECTS)
+- libtool --mode=link --tag=CC gcc $(LDFLAGS) *.lo -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
++ libtool --mode=link --tag=CC $(CC) $(LDFLAGS) *.lo -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
+
+ install: $(LIBNAME)
+ install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)
+ libtool --mode=install install -c $(LIBNAME) $(DESTDIR)$(LIBPATH)/$(LIBNAME)
+ install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(INCPATH)
+ install -m 644 -g $(GROUP) -o $(USER) $(HEADERS) $(DESTDIR)$(INCPATH)
+
+ test: $(LIBNAME) demo/demo.o
+- gcc $(CFLAGS) -c demo/demo.c -o demo/demo.o
+- libtool --mode=link gcc $(LDFLAGS) -o test demo/demo.o $(LIBNAME_S)
++ $(CC) $(CFLAGS) -c demo/demo.c -o demo/demo.o
++ libtool --mode=link $(CC) $(LDFLAGS) -o test demo/demo.o $(LIBNAME_S)
+
+ mtest: test
+- cd mtest ; gcc $(CFLAGS) $(LDFLAGS) mtest.c -o mtest
++ cd mtest ; $(CC) $(CFLAGS) $(LDFLAGS) mtest.c -o mtest
+
+ timing: $(LIBNAME)
+- libtool --mode=link gcc $(CFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME_S) -o ltmtest
++ libtool --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME_S) -o ltmtest
diff --git a/dev-libs/libtommath/libtommath-0.36-r1.ebuild b/dev-libs/libtommath/libtommath-0.36-r1.ebuild
index ee8bcc911c03..c8a698672b10 100644
--- a/dev-libs/libtommath/libtommath-0.36-r1.ebuild
+++ b/dev-libs/libtommath/libtommath-0.36-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.36-r1.ebuild,v 1.12 2009/07/24 16:41:31 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.36-r1.ebuild,v 1.13 2009/07/28 21:53:31 vostorga Exp $
inherit eutils multilib
@@ -19,18 +19,19 @@ RDEPEND=""
RESTRICT="test"
src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-shared-lib.patch
- epatch "${FILESDIR}"/${P}-LDFLAGS.patch
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-shared-lib.patch
+ epatch "${FILESDIR}"/${P}-LDFLAGS.patch
+ epatch "${FILESDIR}"/${P}-CC.patch
}
src_compile() {
- emake -f makefile.shared IGNORE_SPEED=1 || die
+ emake CC="$(tc-getCC)" -f makefile.shared IGNORE_SPEED=1 || die
}
src_install() {
- make -f makefile.shared install DESTDIR="${D}" LIBPATH="/usr/$(get_libdir)" || die
- dodoc changes.txt *.pdf
- docinto demo ; dodoc demo/*
+ make -f makefile.shared install DESTDIR="${D}" LIBPATH="/usr/$(get_libdir)" || die
+ dodoc changes.txt *.pdf
+ docinto demo ; dodoc demo/*
}
diff --git a/dev-libs/libtommath/libtommath-0.41.ebuild b/dev-libs/libtommath/libtommath-0.41.ebuild
index 1e7fbcd5b221..e397c7d29e37 100644
--- a/dev-libs/libtommath/libtommath-0.41.ebuild
+++ b/dev-libs/libtommath/libtommath-0.41.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.41.ebuild,v 1.2 2009/03/30 16:28:55 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.41.ebuild,v 1.3 2009/07/28 21:53:31 vostorga Exp $
inherit eutils multilib
@@ -20,10 +20,11 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-LDFLAGS.patch
+ epatch "${FILESDIR}"/${P}-CC.patch
}
src_compile() {
- emake -f makefile.shared IGNORE_SPEED=1 || die "emake failed"
+ emake CC=$(tc-getCC) -f makefile.shared IGNORE_SPEED=1 || die "emake failed"
}
src_install() {