summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-28 01:58:22 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-28 01:58:22 +0000
commite999daa33e5e407dc4051f7e8071794dbfa6d38d (patch)
tree08ad65ca9e039fbf249cf9985a8f6b8743f78ceb /dev-libs/libtomcrypt/libtomcrypt-0.89.ebuild
parentinitial commit (diff)
downloadgentoo-2-e999daa33e5e407dc4051f7e8071794dbfa6d38d.tar.gz
gentoo-2-e999daa33e5e407dc4051f7e8071794dbfa6d38d.tar.bz2
gentoo-2-e999daa33e5e407dc4051f7e8071794dbfa6d38d.zip
version bump
Diffstat (limited to 'dev-libs/libtomcrypt/libtomcrypt-0.89.ebuild')
-rw-r--r--dev-libs/libtomcrypt/libtomcrypt-0.89.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/libtomcrypt/libtomcrypt-0.89.ebuild b/dev-libs/libtomcrypt/libtomcrypt-0.89.ebuild
new file mode 100644
index 000000000000..8dbf163ba3bc
--- /dev/null
+++ b/dev-libs/libtomcrypt/libtomcrypt-0.89.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/libtomcrypt-0.89.ebuild,v 1.1 2003/07/28 01:56:40 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="modular and portable cryptographic toolkit"
+HOMEPAGE="http://libtomcrypt.org/"
+SRC_URI="http://libtomcrypt.org/files/crypt-${PV}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ epatch ${FILESDIR}/${PV}-doc-fix.patch
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc authors changes *.pdf
+ docinto examples ; dodoc examples/*
+ docinto notes ; dodoc notes/*
+ docinto demos ; dodoc demos/*
+}