summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2012-01-29 15:42:43 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2012-01-29 15:42:43 +0000
commitccc3de1a059a2e8974896b567a26c095534fde84 (patch)
tree645728414591f6c58c38f5d511ea44eb57cdc4ae /dev-libs/libpqxx/libpqxx-4.0-r1.ebuild
parentalpha/arm/ia64/s390/sh/sparc stable (diff)
downloadgentoo-2-ccc3de1a059a2e8974896b567a26c095534fde84.tar.gz
gentoo-2-ccc3de1a059a2e8974896b567a26c095534fde84.tar.bz2
gentoo-2-ccc3de1a059a2e8974896b567a26c095534fde84.zip
Added static-libs support.
(Portage version: 2.1.10.41/cvs/Linux i686)
Diffstat (limited to 'dev-libs/libpqxx/libpqxx-4.0-r1.ebuild')
-rw-r--r--dev-libs/libpqxx/libpqxx-4.0-r1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-libs/libpqxx/libpqxx-4.0-r1.ebuild b/dev-libs/libpqxx/libpqxx-4.0-r1.ebuild
index 3d316d7b952a..e5a30b38da29 100644
--- a/dev-libs/libpqxx/libpqxx-4.0-r1.ebuild
+++ b/dev-libs/libpqxx/libpqxx-4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpqxx/libpqxx-4.0-r1.ebuild,v 1.1 2012/01/29 15:28:47 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpqxx/libpqxx-4.0-r1.ebuild,v 1.2 2012/01/29 15:42:43 titanofold Exp $
EAPI="4"
@@ -13,13 +13,17 @@ SRC_URI="http://pqxx.org/download/software/${PN}/${P}.tar.gz"
HOMEPAGE="http://pqxx.org/development/libpqxx/"
LICENSE="BSD"
SLOT="0"
-IUSE="doc"
+IUSE="doc static-libs"
DEPEND="dev-db/postgresql-base"
RDEPEND="${DEPEND}"
src_configure() {
- econf --enable-shared
+ if use static-libs ; then
+ econf --enable-static
+ else
+ econf --enable-shared
+ fi
}
src_install () {