summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2004-06-15 15:26:47 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2004-06-15 15:26:47 +0000
commit9ee56a018b20b36e80eaa3c0eada67f12d7676ff (patch)
tree77da02f4cdd350eac5de6602fa3f85b7603297d5 /dev-libs/libotf/libotf-0.9-r1.ebuild
parenttesting ~amd64, closes #53981 (Manifest recommit) (diff)
downloadgentoo-2-9ee56a018b20b36e80eaa3c0eada67f12d7676ff.tar.gz
gentoo-2-9ee56a018b20b36e80eaa3c0eada67f12d7676ff.tar.bz2
gentoo-2-9ee56a018b20b36e80eaa3c0eada67f12d7676ff.zip
Added X to IUSE. Added to ~amd64. Fixed compile problem.
Diffstat (limited to 'dev-libs/libotf/libotf-0.9-r1.ebuild')
-rw-r--r--dev-libs/libotf/libotf-0.9-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/libotf/libotf-0.9-r1.ebuild b/dev-libs/libotf/libotf-0.9-r1.ebuild
new file mode 100644
index 000000000000..917fa4d6d07d
--- /dev/null
+++ b/dev-libs/libotf/libotf-0.9-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/libotf-0.9-r1.ebuild,v 1.1 2004/06/15 15:26:47 matsuu Exp $
+
+DESCRIPTION="Library for handling OpenType fonts (OTF)"
+HOMEPAGE="http://www.m17n.org/libotf/"
+SRC_URI="http://www.m17n.org/libotf/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~amd64"
+IUSE="X"
+
+DEPEND="X? ( virtual/x11 )
+ >=media-libs/freetype-2.1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use X || sed -i -e '/^bin_PROGRAMS/s/otfview//' example/Makefile.in || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS INSTALL NEWS README ChangeLog
+}