summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-09-19 19:04:46 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-09-19 19:04:46 +0000
commit81c004dc7f985a9f7a83392d6eef01e776375128 (patch)
treee8aab539a3ada2b1bc7a5bc0e5dc10f73e9029e3 /dev-libs/libgweather
parentDisabled tests when the msn flag is not there (diff)
downloadgentoo-2-81c004dc7f985a9f7a83392d6eef01e776375128.tar.gz
gentoo-2-81c004dc7f985a9f7a83392d6eef01e776375128.tar.bz2
gentoo-2-81c004dc7f985a9f7a83392d6eef01e776375128.zip
Fix bug #285595, automagic python support which caused compilation fail when pygtk was not installed
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libgweather')
-rw-r--r--dev-libs/libgweather/ChangeLog8
-rw-r--r--dev-libs/libgweather/files/libgweather-2.26.2.1-automagic-python.patch24
-rw-r--r--dev-libs/libgweather/libgweather-2.26.2.1.ebuild7
3 files changed, 36 insertions, 3 deletions
diff --git a/dev-libs/libgweather/ChangeLog b/dev-libs/libgweather/ChangeLog
index e423935ccb43..3aa55a6f54f7 100644
--- a/dev-libs/libgweather/ChangeLog
+++ b/dev-libs/libgweather/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libgweather
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.38 2009/07/25 03:19:11 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.39 2009/09/19 19:04:45 mrpouet Exp $
+
+ 19 Sep 2009; Romain Perier <mrpouet@gentoo.org>
+ libgweather-2.26.2.1.ebuild,
+ +files/libgweather-2.26.2.1-automagic-python.patch:
+ Fix bug #285595, automagic python support which caused compilation fail
+ when pygtk was not installed.
25 Jul 2009; Joseph Jezak <josejx@gentoo.org> libgweather-2.26.1.ebuild,
libgweather-2.26.2.1.ebuild:
diff --git a/dev-libs/libgweather/files/libgweather-2.26.2.1-automagic-python.patch b/dev-libs/libgweather/files/libgweather-2.26.2.1-automagic-python.patch
new file mode 100644
index 000000000000..77f2f94eb5cf
--- /dev/null
+++ b/dev-libs/libgweather/files/libgweather-2.26.2.1-automagic-python.patch
@@ -0,0 +1,24 @@
+From 03626e45436b0b9c345e0c07e4f488375639877a Mon Sep 17 00:00:00 2001
+From: Romain Perier <mrpouet@gentoo.org>
+Date: Sat, 19 Sep 2009 20:54:32 +0200
+Subject: [PATCH] Fix automagic python support when --disable-python is given on the command line
+
+---
+ configure.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index f363571..743fe9d 100644
+--- a/configure.in
++++ b/configure.in
+@@ -215,7 +215,7 @@ dnl ***************************************************************************
+ AC_ARG_ENABLE(python,
+ [AC_HELP_STRING([--enable-python],
+ [Build libgweather python bindings])],
+- [enable_python=yes],
++ [enable_python=$enableval],
+ [enable_python=no])
+ if test "$enable_python" = "yes"; then
+ AM_PATH_PYTHON()
+--
+1.6.5.rc1
diff --git a/dev-libs/libgweather/libgweather-2.26.2.1.ebuild b/dev-libs/libgweather/libgweather-2.26.2.1.ebuild
index 6df195d94805..5303d4d7437d 100644
--- a/dev-libs/libgweather/libgweather-2.26.2.1.ebuild
+++ b/dev-libs/libgweather/libgweather-2.26.2.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/libgweather-2.26.2.1.ebuild,v 1.4 2009/07/25 03:19:11 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/libgweather-2.26.2.1.ebuild,v 1.5 2009/09/19 19:04:45 mrpouet Exp $
EAPI="2"
GCONF_DEBUG="no"
-inherit autotools gnome2
+inherit autotools gnome2 eutils
DESCRIPTION="Library to access weather information from online services"
HOMEPAGE="http://www.gnome.org/"
@@ -52,6 +52,9 @@ src_prepare() {
-i gtk-doc.make || die "sed 2 failed"
fi
+ # Fix automagic python support, bug #285595
+ epatch "${FILESDIR}/${P}-automagic-python.patch"
+
# Make it libtool-1 compatible, bug #278516
rm -v m4/lt* m4/libtool.m4 || die "removing libtool macros failed"