summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2014-07-05 17:42:59 +0000
committerDaniel Pielmeier <billie@gentoo.org>2014-07-05 17:42:59 +0000
commit1fe5b9df4ee93e53758bed2f73bc68ea715475d8 (patch)
tree3dee5024635f3f1ffe0d5c4b9f92cfa72b2b397f /dev-libs/libburn
parentVersion bump (diff)
downloadgentoo-2-1fe5b9df4ee93e53758bed2f73bc68ea715475d8.tar.gz
gentoo-2-1fe5b9df4ee93e53758bed2f73bc68ea715475d8.tar.bz2
gentoo-2-1fe5b9df4ee93e53758bed2f73bc68ea715475d8.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 215AD14D)
Diffstat (limited to 'dev-libs/libburn')
-rw-r--r--dev-libs/libburn/ChangeLog7
-rw-r--r--dev-libs/libburn/libburn-1.3.8.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-libs/libburn/ChangeLog b/dev-libs/libburn/ChangeLog
index 5f926be24afd..f4473432eb65 100644
--- a/dev-libs/libburn/ChangeLog
+++ b/dev-libs/libburn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libburn
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libburn/ChangeLog,v 1.181 2014/03/24 19:32:02 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libburn/ChangeLog,v 1.182 2014/07/05 17:42:59 billie Exp $
+
+*libburn-1.3.8 (05 Jul 2014)
+
+ 05 Jul 2014; Daniel Pielmeier <billie@gentoo.org> +libburn-1.3.8.ebuild:
+ Version bump.
24 Mar 2014; Daniel Pielmeier <billie@gentoo.org> -libburn-1.3.2.ebuild:
Remove old.
diff --git a/dev-libs/libburn/libburn-1.3.8.ebuild b/dev-libs/libburn/libburn-1.3.8.ebuild
new file mode 100644
index 000000000000..4fdc0acb9f17
--- /dev/null
+++ b/dev-libs/libburn/libburn-1.3.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libburn/libburn-1.3.8.ebuild,v 1.1 2014/07/05 17:42:59 billie Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Libburn is an open-source library for reading, mastering and writing optical discs."
+HOMEPAGE="http://libburnia-project.org"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cdio debug static-libs track-src-odirect"
+
+RDEPEND="cdio? ( >=dev-libs/libcdio-0.83 )"
+DEPEND="$RDEPEND
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable track-src-odirect) \
+ --enable-pkg-check-modules \
+ $(use_enable cdio libcdio) \
+ --disable-ldconfig-at-install \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ dodoc CONTRIBUTORS doc/{comments,*.txt}
+
+ docinto cdrskin
+ dodoc cdrskin/{*.txt,README}
+ docinto cdrskin/html
+ dohtml cdrskin/cdrskin_eng.html
+
+ prune_libtool_files --all
+}