summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 16:43:12 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 16:43:12 +0000
commitf470eeff723119e68776833b23b2f9bdb3d810ec (patch)
tree3a9c97211b299dbf3c3e21ed67d040f98102cf8b /dev-libs/gobject-introspection
parentVersion bump for Gnome 3.8 (diff)
downloadgentoo-2-f470eeff723119e68776833b23b2f9bdb3d810ec.tar.gz
gentoo-2-f470eeff723119e68776833b23b2f9bdb3d810ec.tar.bz2
gentoo-2-f470eeff723119e68776833b23b2f9bdb3d810ec.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs/gobject-introspection')
-rw-r--r--dev-libs/gobject-introspection/ChangeLog8
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-1.36.0.ebuild84
2 files changed, 91 insertions, 1 deletions
diff --git a/dev-libs/gobject-introspection/ChangeLog b/dev-libs/gobject-introspection/ChangeLog
index eff26ed56fde..aca8bbb6e9da 100644
--- a/dev-libs/gobject-introspection/ChangeLog
+++ b/dev-libs/gobject-introspection/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/gobject-introspection
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.88 2013/03/05 23:13:55 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.89 2013/03/28 16:43:12 pacho Exp $
+
+*gobject-introspection-1.36.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org>
+ +gobject-introspection-1.36.0.ebuild:
+ Version bump for Gnome 3.8
05 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org>
-gobject-introspection-1.30.0-r2.ebuild,
diff --git a/dev-libs/gobject-introspection/gobject-introspection-1.36.0.ebuild b/dev-libs/gobject-introspection/gobject-introspection-1.36.0.ebuild
new file mode 100644
index 000000000000..dc00123a4042
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-1.36.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-1.36.0.ebuild,v 1.1 2013/03/28 16:43:12 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit eutils gnome2 python-single-r1 toolchain-funcs
+
+DESCRIPTION="Introspection infrastructure for generating gobject library bindings for various languages"
+HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="cairo doctool test"
+
+RDEPEND="
+ >=dev-libs/gobject-introspection-common-${PV}
+ >=dev-libs/glib-2.36:2
+ doctool? ( dev-python/mako )
+ virtual/libffi:=
+"
+# Wants real bison, not virtual/yacc
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.15
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+# PDEPEND to avoid circular dependencies, bug #391213
+PDEPEND="cairo? ( x11-libs/cairo[glib] )"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # To prevent crosscompiling problems, bug #414105
+ CC=$(tc-getCC)
+
+ DOCS="AUTHORS CONTRIBUTORS ChangeLog NEWS README TODO"
+ gnome2_src_prepare
+
+ # avoid GNU-isms
+ sed -i -e 's/\(if test .* \)==/\1=/' configure || die
+
+ gi_skip_tests=
+ if ! has_version "x11-libs/cairo[glib]"; then
+ # Bug #391213: enable cairo-gobject support even if it's not installed
+ # We only PDEPEND on cairo to avoid circular dependencies
+ export CAIRO_LIBS="-lcairo -lcairo-gobject"
+ export CAIRO_CFLAGS="-I${EPREFIX}/usr/include/cairo"
+ if use test; then
+ G2CONF="${G2CONF} --disable-tests"
+ gi_skip_tests=yes
+ ewarn "Tests will be skipped because x11-libs/cairo[glib] is not present"
+ ewarn "on your system. Consider installing it to get tests to run."
+ fi
+ fi
+}
+src_configure(){
+ gnome2_src_configure \
+ --disable-static \
+ YACC=$(type -p yacc) \
+ $(use_with cairo) \
+ $(use_enable doctool) \
+ $(use_enable test tests)
+}
+src_test() {
+ [[ -z ${gi_skip_tests} ]] && default
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Prevent collision with gobject-introspection-common
+ rm -v "${ED}"usr/share/aclocal/introspection.m4 \
+ "${ED}"usr/share/gobject-introspection-1.0/Makefile.introspection || die
+ rmdir "${ED}"usr/share/aclocal || die
+}