summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-06 22:48:18 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-06 22:48:18 +0000
commit6ef5b373fe55a9225a46da49df53e468e76872c1 (patch)
tree6e3613e4153ccded7c60711bcd7701af419f66fa /dev-libs/expat
parentmake gentoo-sources default linux-sources provider (diff)
downloadgentoo-2-6ef5b373fe55a9225a46da49df53e468e76872c1.tar.gz
gentoo-2-6ef5b373fe55a9225a46da49df53e468e76872c1.tar.bz2
gentoo-2-6ef5b373fe55a9225a46da49df53e468e76872c1.zip
use elibtoolize instead of uclibctoolize
(Portage version: 2.0.53_rc4)
Diffstat (limited to 'dev-libs/expat')
-rw-r--r--dev-libs/expat/expat-1.95.7-r1.ebuild11
-rw-r--r--dev-libs/expat/expat-1.95.7.ebuild7
-rw-r--r--dev-libs/expat/expat-1.95.8.ebuild4
3 files changed, 10 insertions, 12 deletions
diff --git a/dev-libs/expat/expat-1.95.7-r1.ebuild b/dev-libs/expat/expat-1.95.7-r1.ebuild
index caccc35c50ff..fb9a8260e6b0 100644
--- a/dev-libs/expat/expat-1.95.7-r1.ebuild
+++ b/dev-libs/expat/expat-1.95.7-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.7-r1.ebuild,v 1.6 2005/01/16 22:34:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.7-r1.ebuild,v 1.7 2005/10/06 22:48:18 vapier Exp $
-inherit gnuconfig libtool
+inherit libtool
DESCRIPTION="XML parsing libraries"
HOMEPAGE="http://expat.sourceforge.net/"
@@ -13,16 +13,15 @@ SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
IUSE="test"
-DEPEND="virtual/libc
- test? ( >=dev-libs/check-0.8 )"
+DEPEND="test? ( >=dev-libs/check-0.8 )"
+RDEPEND=""
src_unpack() {
hasq "test" ${FEATURES} && ! use test && die "You must put test into your USE if you have FEATURES=test"
unpack ${A}
cd "${S}"
- gnuconfig_update
- uclibctoolize
+ elibtoolize
}
src_install() {
diff --git a/dev-libs/expat/expat-1.95.7.ebuild b/dev-libs/expat/expat-1.95.7.ebuild
index 4e564bd7080f..cc2a0db39e5c 100644
--- a/dev-libs/expat/expat-1.95.7.ebuild
+++ b/dev-libs/expat/expat-1.95.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.7.ebuild,v 1.25 2005/01/11 21:18:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.7.ebuild,v 1.26 2005/10/06 22:48:18 vapier Exp $
-inherit gnuconfig libtool
+inherit libtool
DESCRIPTION="XML parsing libraries"
HOMEPAGE="http://expat.sourceforge.net/"
@@ -18,8 +18,7 @@ DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
cd "${S}"
- gnuconfig_update
- uclibctoolize
+ elibtoolize
}
src_install() {
diff --git a/dev-libs/expat/expat-1.95.8.ebuild b/dev-libs/expat/expat-1.95.8.ebuild
index d29c50ae4c79..0f44eec64866 100644
--- a/dev-libs/expat/expat-1.95.8.ebuild
+++ b/dev-libs/expat/expat-1.95.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.8.ebuild,v 1.15 2005/05/29 09:13:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.8.ebuild,v 1.16 2005/10/06 22:48:18 vapier Exp $
inherit libtool
@@ -19,7 +19,7 @@ RDEPEND=""
src_unpack() {
unpack ${A}
cd "${S}"
- uclibctoolize
+ elibtoolize
}
src_test() {