summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-02-28 14:53:19 +0000
committerDavid Holm <dholm@gentoo.org>2004-02-28 14:53:19 +0000
commit7c1a4cfe54b8ae2459f6e3f1c0e46ab8f6b2b133 (patch)
tree0cac49ce085a0cdf7771b6b64dd7ecad76d2e3f8 /dev-libs/dmalloc/files
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-7c1a4cfe54b8ae2459f6e3f1c0e46ab8f6b2b133.tar.gz
gentoo-2-7c1a4cfe54b8ae2459f6e3f1c0e46ab8f6b2b133.tar.bz2
gentoo-2-7c1a4cfe54b8ae2459f6e3f1c0e46ab8f6b2b133.zip
Bumped version and added it to ~ppc
Diffstat (limited to 'dev-libs/dmalloc/files')
-rw-r--r--dev-libs/dmalloc/files/digest-dmalloc-5.3.01
-rw-r--r--dev-libs/dmalloc/files/dmalloc-5.3.0-fpic.patch42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/dmalloc/files/digest-dmalloc-5.3.0 b/dev-libs/dmalloc/files/digest-dmalloc-5.3.0
new file mode 100644
index 000000000000..88ced08aae58
--- /dev/null
+++ b/dev-libs/dmalloc/files/digest-dmalloc-5.3.0
@@ -0,0 +1 @@
+MD5 d11a4a5d5bd258ef7461babec9e177fa dmalloc-5.3.0.tgz 346994
diff --git a/dev-libs/dmalloc/files/dmalloc-5.3.0-fpic.patch b/dev-libs/dmalloc/files/dmalloc-5.3.0-fpic.patch
new file mode 100644
index 000000000000..6a67b6e43972
--- /dev/null
+++ b/dev-libs/dmalloc/files/dmalloc-5.3.0-fpic.patch
@@ -0,0 +1,42 @@
+diff -Naur dmalloc-5.3.0.orig/Makefile.in dmalloc-5.3.0/Makefile.in
+--- dmalloc-5.3.0.orig/Makefile.in 2004-02-28 15:37:40.000000000 +0100
++++ dmalloc-5.3.0/Makefile.in 2004-02-28 15:39:04.000000000 +0100
+@@ -318,17 +318,17 @@
+ # special _th versions of objects with the LOCK_THREADS variable defined to 1
+ chunk_th.o : $(srcdir)/chunk.c
+ rm -f $@
+- $(CC) $(CFLAGS) $(CPPFLAGS) $(DEFS) $(INCS) -DLOCK_THREADS=1 \
++ $(CC) $(CFLAGS) -fPIC $(CPPFLAGS) $(DEFS) $(INCS) -DLOCK_THREADS=1 \
+ -c $(srcdir)/chunk.c -o ./$@
+
+ error_th.o : $(srcdir)/error.c
+ rm -f $@
+- $(CC) $(CFLAGS) $(CPPFLAGS) $(DEFS) $(INCS) -DLOCK_THREADS=1 \
++ $(CC) $(CFLAGS) -fPIC $(CPPFLAGS) $(DEFS) $(INCS) -DLOCK_THREADS=1 \
+ -c $(srcdir)/error.c -o ./$@
+
+ malloc_th.o : $(srcdir)/malloc.c
+ rm -f $@
+- $(CC) $(CFLAGS) $(CPPFLAGS) $(DEFS) $(INCS) -DLOCK_THREADS=1 \
++ $(CC) $(CFLAGS) -fPIC $(CPPFLAGS) $(DEFS) $(INCS) -DLOCK_THREADS=1 \
+ -c $(srcdir)/malloc.c -o ./$@
+
+ tests : $(TEST)
+@@ -354,7 +354,7 @@
+
+ .c.o :
+ rm -f $@
+- $(CC) $(CFLAGS) $(CPPFLAGS) $(DEFS) $(INCS) -c $< -o ./$@
++ $(CC) $(CFLAGS) -fPIC $(CPPFLAGS) $(DEFS) $(INCS) -c $< -o ./$@
+
+ #
+ # .cc.o auto-target doesn't work on some systems.
+@@ -362,7 +362,7 @@
+ #
+ dmallocc.o : $(srcdir)/dmallocc.cc
+ rm -f $@
+- $(CXX) $(CFLAGS) $(CPPFLAGS) $(DEFS) $(INCS) -c $(srcdir)/dmallocc.cc \
++ $(CXX) $(CFLAGS) -fPIC $(CPPFLAGS) $(DEFS) $(INCS) -c $(srcdir)/dmallocc.cc \
+ -o ./$@
+
+ .texi.info :