summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-04-12 13:51:53 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-04-12 13:51:53 +0000
commit533cd265e1c82d722debe139f39c82119606ae4a (patch)
treebc514eecbda1372948effa527ae1239395bed398 /dev-libs/cpl-stratego/cpl-stratego-0.4.ebuild
parentATerm term library (diff)
downloadgentoo-2-533cd265e1c82d722debe139f39c82119606ae4a.tar.gz
gentoo-2-533cd265e1c82d722debe139f39c82119606ae4a.tar.bz2
gentoo-2-533cd265e1c82d722debe139f39c82119606ae4a.zip
Choice library for Stratego
Diffstat (limited to 'dev-libs/cpl-stratego/cpl-stratego-0.4.ebuild')
-rw-r--r--dev-libs/cpl-stratego/cpl-stratego-0.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/cpl-stratego/cpl-stratego-0.4.ebuild b/dev-libs/cpl-stratego/cpl-stratego-0.4.ebuild
new file mode 100644
index 000000000000..584bce3af6d8
--- /dev/null
+++ b/dev-libs/cpl-stratego/cpl-stratego-0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Karl Trygve Kalleberg
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cpl-stratego/cpl-stratego-0.4.ebuild,v 1.1 2002/04/12 13:51:53 karltk Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Choice library mostly used by Stratego"
+SRC_URI="http://www.stratego-language.org/ftp/${P}.tar.gz"
+HOMEPAGE="http://www.stratego-language.org"
+
+DEPEND="virtual/glibc"
+RDEPEND="$DEPEND"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+ #make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ #make \
+ # prefix=${D}/usr \
+ # mandir=${D}/usr/share/man \
+ # infodir=${D}/usr/share/info \
+ # install || die
+}