summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-01-12 15:25:42 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-01-12 15:25:42 +0000
commite3ce251771951020dc9e90ffda4251ce5f8137d3 (patch)
treedbf0a3e27222232fa442f9f3d5cfefa432bd67c3 /dev-libs/collada-dom/collada-dom-2.4.3_pre20150112.ebuild
parentUse "--force" when running eautoconf through eautoreconf (bug #527506) (diff)
downloadgentoo-2-e3ce251771951020dc9e90ffda4251ce5f8137d3.tar.gz
gentoo-2-e3ce251771951020dc9e90ffda4251ce5f8137d3.tar.bz2
gentoo-2-e3ce251771951020dc9e90ffda4251ce5f8137d3.zip
add live ebuild for github version and take a snapshot from there: sf version is not maintained anymore and is buggy; thanks to José Henriques for the help in this investigation
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-libs/collada-dom/collada-dom-2.4.3_pre20150112.ebuild')
-rw-r--r--dev-libs/collada-dom/collada-dom-2.4.3_pre20150112.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/collada-dom/collada-dom-2.4.3_pre20150112.ebuild b/dev-libs/collada-dom/collada-dom-2.4.3_pre20150112.ebuild
new file mode 100644
index 000000000000..99b4d7a9c8c1
--- /dev/null
+++ b/dev-libs/collada-dom/collada-dom-2.4.3_pre20150112.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/collada-dom/collada-dom-2.4.3_pre20150112.ebuild,v 1.1 2015/01/12 15:25:42 aballier Exp $
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/rdiankov/collada-dom"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+elif [ "${PV%_pre*}" != "${PV}" ]; then
+ # snapshot
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/rdiankov/collada-dom/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="COLLADA Document Object Model (DOM) C++ Library"
+HOMEPAGE="https://github.com/rdiankov/collada-dom"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib:=[minizip]
+ dev-libs/libxml2
+ dev-libs/libpcre[cxx]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"